]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/commitdiff
- cleanup, separated -static,-dll
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 6 Mar 2007 20:06:26 +0000 (20:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    crossmingw32-fontconfig.spec -> 1.3

crossmingw32-fontconfig.spec

index e0dc1414ee7310f5881cdcaa747d075e0843cd48..93b8cdca980f72869b2e13ca8ee6e882dee27115 100644 (file)
@@ -1,15 +1,15 @@
 #
 # Conditional build
 %bcond_with    bytecode        # use bytecode hinting instead of autohinting by default
+#
 %define                _realname   fontconfig
 Summary:       Font configuration and customization tools - cross Mingw32 versoin
-Summary(pl.UTF-8):Narzędzia do konfigurowania fontów - wersja skrośna dla Mingw32
-Summary(pt_BR.UTF-8):Ferramentas para configuração e customização do acesso a fontes
+Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów - wersja skrośna dla Mingw32
 Name:          crossmingw32-%{_realname}
 Version:       2.4.2
 Release:       1
 License:       MIT
-Group:         Libraries
+Group:         Development/Libraries
 Source0:       http://fontconfig.org/release/%{_realname}-%{version}.tar.gz
 # Source0-md5: f035852f521b54677f2b5c9e2f6d54a4
 Patch0:                %{name}-dll.patch
@@ -21,7 +21,10 @@ BuildRequires:       autoconf
 BuildRequires: automake
 BuildRequires: crossmingw32-expat
 BuildRequires: crossmingw32-freetype >= 2.1.5
-BuildRequires: crossmingw32-pkgconfig
+BuildRequires: crossmingw32-gcc
+BuildRequires: libtool
+BuildRequires: pkgconfig
+Requires:      crossmingw32-expat
 Requires:      crossmingw32-freetype >= 2.1.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -30,13 +33,11 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                target                  i386-mingw32
 %define                target_platform         i386-pc-mingw32
 %define                arch                    %{_prefix}/%{target}
-%define                gccarch                 %{_prefix}/lib/gcc-lib/%{target}
-%define                gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
 
 %define                _sysprefix              /usr
 %define                _prefix                 %{_sysprefix}/%{target}
-%define                _aclocaldir             %{_datadir}/aclocal
 %define                _pkgconfigdir           %{_libdir}/pkgconfig
+%define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
 
@@ -44,19 +45,39 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Fontconfig is designed to locate fonts within the system and select
 them according to requirements specified by applications.
 
-This package contains tools and documentation.
+This package contains the cross version for Win32.
 
 %description -l pl.UTF-8
 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
 systemie i wybierania ich w zależności od potrzeb aplikacji.
 
-Paket ten zawiera programy narzędziowe i dokumentację.
+Paket ten zawiera wersję skrośną dla Win32.
+
+%package static
+Summary:       Static freetype library (cross mingw32 version)
+Summary(pl.UTF-8):     Statyczna biblioteka freetype (wersja skrośna mingw32)
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description static
+Static freetype library (cross mingw32 version).
+
+%description static -l pl.UTF-8
+Statyczna biblioteka freetype (wersja skrośna mingw32).
 
-%description -l pt_BR.UTF-8
-Fontconfig é uma biblioteca para configuração e customização do
-acesso a fontes.
+%package dll
+Summary:       DLL freetype library for Windows
+Summary(pl.UTF-8):     Biblioteka DLL freetype dla Windows
+Group:         Applications/Emulators
+Requires:      crossmingw32-expat-dll
+Requires:      crossmingw32-freetype-dll >= 2.1.5
+Requires:      wine
 
-Este pacote contém as ferramentas e documentação.
+%description dll
+DLL freetype library for Windows.
+
+%description dll -l pl.UTF-8
+Biblioteka DLL freetype dla Windows.
 
 %prep
 %setup -q -n %{_realname}-%{version}
@@ -80,41 +101,43 @@ export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
        --with-arch=%{target} \
        --disable-docs
 
-#%{__sed} -i -e 's/^deplibs_check_method=.*/deplibs_check_method="pass_all"/' libtool
-
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -f conf.d/README README.confd
+install -d $RPM_BUILD_ROOT%{_dlldir}
+mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
+
+%if 0%{!?debug:1}
+%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
+%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
+%endif
+
+rm -rf $RPM_BUILD_ROOT%{_datadir}/man
+# runtime
+rm -rf $RPM_BUILD_ROOT/etc/fonts
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-umask 022
-# Is this needed?
-#HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
-
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING ChangeLog README README.confd
-#%dir %{_sysconfdir}/fonts
-#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
-#%{_sysconfdir}/fonts/fonts.dtd
-#%dir %{_sysconfdir}/fonts/conf.avail
-#%{_sysconfdir}/fonts/conf.avail/*.conf
-#%{_sysconfdir}/fonts/conf.avail/README
-#%dir %{_sysconfdir}/fonts/conf.d
-#%config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
-%{_libdir}/lib*.la
-%{_libdir}/lib*.a
-%{_bindir}/*.dll
+%doc AUTHORS COPYING ChangeLog README
+%{_libdir}/libfontconfig.dll.a
+%{_libdir}/libfontconfig.la
+%{_libdir}/fontconfig.def
 %dir %{_includedir}/fontconfig
 %{_includedir}/fontconfig/*.h
 %{_pkgconfigdir}/fontconfig.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libfontconfig.a
+
+%files dll
+%defattr(644,root,root,755)
+%{_dlldir}/libfontconfig-*.dll
This page took 0.174684 seconds and 4 git commands to generate.