]> git.pld-linux.org Git - packages/crossmingw32-dx70.git/blob - crossmingw32-dx70.spec
- unified MinGW32 caps
[packages/crossmingw32-dx70.git] / crossmingw32-dx70.spec
1 Summary:        MinGW32 binary utility development utilities - DirectX 7.0 API
2 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne dla MinGW32 - API DirectX 7.0
3 Name:           crossmingw32-dx70
4 Version:        7.0
5 Release:        4
6 Epoch:          1
7 License:        Free (libs), (c) Microsoft Corporation (headers)
8 Group:          Development/Libraries
9 # headers are Copyright (C) 19xx Microsoft Corporation - what about license???
10 # (even if distributable, are they "Free"?!)
11 Source0:        http://alleg.sourceforge.net/files/dx70_mgw.zip
12 # Source0-md5:  8a57b4c81a296d75f75d7a9810ae59a0
13 Source1:        http://www.libsdl.org/extras/win32/common/directx-devel.tar.gz
14 # Source1-md5:  389a36e4d209c0a76bea7d7cb6315315
15 BuildRequires:  unzip
16 Requires:       crossmingw32-runtime
17 Provides:       crossmingw32-dx = 7.0
18 Obsoletes:      crossmingw32-dx
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         target          i386-mingw32
22 %define         target_platform i386-pc-mingw32
23 %define         arch            %{_prefix}/%{target}
24
25 %define         __unzip         unzip -q -o
26 # strip fails on static COFF files
27 %define         no_install_post_strip 1
28
29 %description
30 crossmingw32 is a complete cross-compiling development system for
31 building stand-alone Microsoft Windows applications under Linux using
32 the MinGW32 build libraries. This includes a binutils, gcc with g++
33 and objc, and libstdc++, all cross targeted to i386-mingw32, along
34 with supporting Win32 libraries in 'coff' format from free sources.
35
36 This package contains DirectX 7.0 API includes and libraries.
37
38 %description -l pl.UTF-8
39 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
40 pozwalającym budować aplikacje MS Windows pod Linuksem używając
41 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
42 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
43 z bibliotek w formacie COFF.
44
45 Ten pakiet zawiera pliki nagłówkowe i biblioteki API DirectX 7.0.
46
47 %prep
48 %setup -q -c
49 mkdir extras
50 cd extras
51 tar zxf %{SOURCE1}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{arch}/{include,lib}
56
57 mv -f lib/src/*.htm .
58 rm -rf lib/src
59 rm -rf include/src
60
61 cp -fa include/* $RPM_BUILD_ROOT%{arch}/include
62 cp -fa lib/* $RPM_BUILD_ROOT%{arch}/lib
63
64 cp extras/include/directx.h $RPM_BUILD_ROOT%{arch}/include
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc directx.htm
72 %{arch}/include/d3d*.h
73 %{arch}/include/d3d*.inl
74 %{arch}/include/ddraw.h
75 %{arch}/include/dinput*.h
76 %{arch}/include/dls1.h
77 %{arch}/include/dls2.h
78 %{arch}/include/dmdls.h
79 %{arch}/include/dmerror.h
80 %{arch}/include/dmksctrl.h
81 %{arch}/include/dmus*.h
82 %{arch}/include/dplay.h
83 %{arch}/include/dplobby.h
84 %{arch}/include/directx.h
85 %{arch}/include/dsetup.h
86 %{arch}/include/dsound.h
87 %{arch}/include/dvp.h
88 %{arch}/include/dxfile.h
89 %{arch}/include/dxsdk.inc
90 %{arch}/include/multimon.h
91 %{arch}/include/rmxfguid.h
92 %{arch}/include/rmxftmpl.h
93 %{arch}/include/rmxftmpl.x
94 %{arch}/lib/libd3dim.a
95 %{arch}/lib/libd3drm.a
96 %{arch}/lib/libd3dxof.a
97 %{arch}/lib/libddraw.a
98 %{arch}/lib/libdinput.a
99 %{arch}/lib/libdplayx.a
100 %{arch}/lib/libdsetup.a
101 %{arch}/lib/libdsound.a
102 %{arch}/lib/libdxguid.a
This page took 0.048813 seconds and 3 git commands to generate.