]> git.pld-linux.org Git - packages/crossmingw32-boost.git/commitdiff
- conditionally enable Boost Serialization (requires wine for building)
authorŁukasz Krotowski <lkrotowski@pld-linux.org>
Fri, 12 Sep 2008 17:45:36 +0000 (17:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    crossmingw32-boost.spec -> 1.13

crossmingw32-boost.spec

index aa3801369c8529857fefc66b64bce8c04a2cc019..c06a25d54680cf5bf2b413a8e58879636687d02e 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_with    serialization   # enable Boost Serialization
+#
 %define                realname        boost
 Summary:       The Boost C++ Libraries - Mingw32 cross version
 Summary(pl.UTF-8):     Biblioteki C++ "Boost" - wersja skrośna dla Mingw32
@@ -17,6 +21,7 @@ BuildRequires:        crossmingw32-gcc-c++
 BuildRequires: crossmingw32-runtime
 BuildRequires: crossmingw32-w32api
 BuildRequires: crossmingw32-zlib
+%{?with_serialization:BuildRequires:   wine-programs}
 Requires:      crossmingw32-bzip2
 Requires:      crossmingw32-runtime
 Requires:      crossmingw32-zlib
@@ -92,6 +97,12 @@ echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}" ;' \
        >tools/build/v2/user-config.jam
 
 %build
+%if %{with serialization}
+export WINEPREFIX=`pwd`/wineprefix
+wineprefixcreate
+cp %{_prefix}/bin/mingwm10.dll wineprefix/drive_c/windows/system32/
+%endif
+
 CC="%{__cc}" ; export CC
 CXX="%{__cxx}" ; export CXX
 LD=%{target}-ld ; export LD
@@ -104,7 +115,7 @@ bjam \
        -sBZIP2_BINARY=bzip2 \
        --toolset=gcc \
        --without-python \
-       --without-serialization \
+       %{!?with_serialization:--without-serialization} \
        --without-test \
        variant=release \
        debug-symbols=on \
This page took 0.091042 seconds and 4 git commands to generate.