]> git.pld-linux.org Git - packages/crossmingw32-boost.git/commitdiff
- updated to 1.73.0 auto/th/crossmingw32-boost-1.73.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Jul 2020 08:29:36 +0000 (10:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Jul 2020 08:29:36 +0000 (10:29 +0200)
- added (reverse) mingw-lld patch (revert mingw llvm fix that breaks mingw gcc build)

boost-mingw-lld.patch [new file with mode: 0644]
crossmingw32-boost.spec

diff --git a/boost-mingw-lld.patch b/boost-mingw-lld.patch
new file mode 100644 (file)
index 0000000..58b3c0c
--- /dev/null
@@ -0,0 +1,42 @@
+From 85783e8cbba03804e13b3d314112df6b089ed2c0 Mon Sep 17 00:00:00 2001
+From: Eric Astor <epastor@google.com>
+Date: Fri, 22 Nov 2019 11:07:15 -0500
+Subject: [PATCH] Fix exports for 32-bit GNU assembler files targeting Windows.
+
+The incorrect exports can cause linker issues (at least when using LLVM's lld-link) claiming that these primitives are not available.
+---
+ src/asm/jump_i386_ms_pe_gas.asm  | 2 +-
+ src/asm/make_i386_ms_pe_gas.asm  | 2 +-
+ src/asm/ontop_i386_ms_pe_gas.asm | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/asm/jump_i386_ms_pe_gas.asm b/src/asm/jump_i386_ms_pe_gas.asm
+index 8512a3d0..4c623006 100644
+--- a/src/asm/jump_i386_ms_pe_gas.asm
++++ b/src/asm/jump_i386_ms_pe_gas.asm
+@@ -114,4 +114,4 @@ _jump_fcontext:
+     jmp *%ecx
+ .section .drectve
+-.ascii " -export:\"jump_fcontext\""
++.ascii " -export:\"_jump_fcontext\""
+diff --git a/src/asm/make_i386_ms_pe_gas.asm b/src/asm/make_i386_ms_pe_gas.asm
+index dcb77000..f2e3b689 100644
+--- a/src/asm/make_i386_ms_pe_gas.asm
++++ b/src/asm/make_i386_ms_pe_gas.asm
+@@ -144,4 +144,4 @@ finish:
+ .def  __exit; .scl    2;      .type   32;     .endef  /* standard C library function */
+ .section .drectve
+-.ascii " -export:\"make_fcontext\""
++.ascii " -export:\"_make_fcontext\""
+diff --git a/src/asm/ontop_i386_ms_pe_gas.asm b/src/asm/ontop_i386_ms_pe_gas.asm
+index 41f15f5b..8bfe93c6 100644
+--- a/src/asm/ontop_i386_ms_pe_gas.asm
++++ b/src/asm/ontop_i386_ms_pe_gas.asm
+@@ -122,4 +122,4 @@ _ontop_fcontext:
+     jmp  *%ecx
+ .section .drectve
+-.ascii " -export:\"ontop_fcontext\""
++.ascii " -export:\"_ontop_fcontext\""
index 13dca725d4d20380e5ea3617e3c96d1e79e0577b..a6a8719346fa2db3ff2cb3cc316e10226eb75fcb 100644 (file)
@@ -8,13 +8,14 @@
 Summary:       The Boost C++ Libraries - MinGW32 cross version
 Summary(pl.UTF-8):     Biblioteki C++ "Boost" - wersja skrośna dla MinGW32
 Name:          crossmingw32-%{realname}
-Version:       1.71.0
+Version:       1.73.0
 %define        fver    %(echo %{version} | tr . _)
 Release:       1
 License:       Boost Software License and others
 Group:         Development/Libraries
 Source0:       http://dl.bintray.com/boostorg/release/%{version}/source/%{realname}_%{fver}.tar.bz2
-# Source0-md5: 4cdf9b5c2dc01fb2b7b733d5af30e558
+# Source0-md5: 9273c8c4576423562bbe84574b07b2bd
+Patch0:                boost-mingw-lld.patch
 URL:           http://www.boost.org/
 BuildRequires: crossmingw32-bzip2
 BuildRequires: crossmingw32-gcc-c++
@@ -48,7 +49,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                filterout_c     -f[-a-z0-9=]*
 %define                filterout_cxx   -f[-a-z0-9=]*
 
-%define                abi_tag         mgw*-mt-x32-1_71
+%define                abi_tag         mgw*-mt-x32-1_73
 
 %description
 The Boost web site provides free peer-reviewed portable C++ source
@@ -96,6 +97,9 @@ Boost - biblioteki DLL dla Windows.
 
 %prep
 %setup -q -n %{realname}_%{fver}
+cd libs/context
+%patch0 -R -p1
+cd ../..
 
 echo 'using gcc : : %{target}-g++ : ' \
        '<cxxflags>"%{rpmcxxflags}"' \
@@ -165,6 +169,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_math_tr1-%{abi_tag}.dll.a
 %{_libdir}/libboost_math_tr1f-%{abi_tag}.dll.a
 %{_libdir}/libboost_math_tr1l-%{abi_tag}.dll.a
+%{_libdir}/libboost_nowide-%{abi_tag}.dll.a
 %{?with_test:%{_libdir}/libboost_prg_exec_monitor-%{abi_tag}.dll.a}
 %{_libdir}/libboost_program_options-%{abi_tag}.dll.a
 %{_libdir}/libboost_random-%{abi_tag}.dll.a
@@ -205,6 +210,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_math_tr1-%{abi_tag}.a
 %{_libdir}/libboost_math_tr1f-%{abi_tag}.a
 %{_libdir}/libboost_math_tr1l-%{abi_tag}.a
+%{_libdir}/libboost_nowide-%{abi_tag}.a
 %{?with_test:%{_libdir}/libboost_prg_exec_monitor-%{abi_tag}.a}
 %{_libdir}/libboost_program_options-%{abi_tag}.a
 %{_libdir}/libboost_random-%{abi_tag}.a
@@ -241,6 +247,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_dlldir}/libboost_math_tr1-%{abi_tag}.dll
 %{_dlldir}/libboost_math_tr1f-%{abi_tag}.dll
 %{_dlldir}/libboost_math_tr1l-%{abi_tag}.dll
+%{_dlldir}/libboost_nowide-%{abi_tag}.dll
 %{?with_test:%{_dlldir}/libboost_prg_exec_monitor-%{abi_tag}.dll}
 %{_dlldir}/libboost_program_options-%{abi_tag}.dll
 %{_dlldir}/libboost_random-%{abi_tag}.dll
This page took 0.204259 seconds and 4 git commands to generate.