]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
- updated to 2.42
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.31.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  a517a836dd5747cc9e64d81addc517ad
14 Patch0:         binutils-libdir.patch
15 URL:            http://sources.redhat.com/binutils/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  bash
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  gettext-tools
22 BuildRequires:  lzip
23 BuildRequires:  perl-tools-pod
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  texinfo >= 4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          i386-mingw32
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 crossmingw32 is a complete cross-compiling development system for
33 building stand-alone Microsoft Windows applications under Linux using
34 the MinGW32 build libraries. This includes a binutils, gcc with g++
35 and objc, and libstdc++, all cross targeted to i386-mingw32, along
36 with supporting Win32 libraries in 'coff' format from free sources.
37
38 This package contains cross targeted binutils.
39
40 %description -l pl.UTF-8
41 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
42 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
43 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
44 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
45 COFF.
46
47 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
48
49 %prep
50 %setup -q -n binutils-%{version}
51 %patch0 -p1
52
53 # file contains hacks for ac 2.64 only
54 %{__rm} config/override.m4
55 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
56
57 %build
58 cp -f /usr/share/automake/config.* .
59 %{__aclocal}
60 %{__autoconf}
61
62 # non-standard regeneration (needed because of libdir patch)
63 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
64 for dir in gas bfd; do
65         cd $dir || exit 1
66         %{__aclocal} -I .. -I ../config -I ../bfd
67         %{__automake} Makefile
68         %{__automake} doc/Makefile
69         %{__autoconf}
70         cd ..
71 done
72
73 # We don't install libbfd (nor use shared binutils libraries) to avoid
74 # conflict with native binutils.
75
76 # ldscripts won't be generated properly if SHELL is not bash...
77 CFLAGS="%{rpmcflags}" \
78 LDFLAGS="%{rpmldflags}" \
79 CONFIG_SHELL="/bin/bash" \
80 ./configure \
81         --disable-nls \
82         --disable-shared \
83         --prefix=%{_prefix} \
84         --libdir=%{_libdir} \
85         --mandir=%{_mandir} \
86         --infodir=%{_infodir} \
87         --host=%{_target_platform} \
88         --build=%{_target_platform} \
89         --target=%{target}
90
91 %{__make} all \
92         tooldir=%{_prefix}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         INSTALL='$$s/install-sh -c' \
99         prefix=$RPM_BUILD_ROOT%{_prefix} \
100         mandir=$RPM_BUILD_ROOT%{_mandir} \
101         infodir=$RPM_BUILD_ROOT%{_infodir} \
102         libdir=$RPM_BUILD_ROOT%{_libdir}
103
104 # not prefixed, keep infos only from native packages
105 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
106
107 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
108 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README
116 # mingw32 directory tree
117 %dir %{arch}
118 %dir %{arch}/lib
119 %dir %{arch}/lib/pkgconfig
120 %dir %{arch}/bin
121 # binutils files
122 %attr(755,root,root) %{arch}/bin/ar
123 %attr(755,root,root) %{arch}/bin/as
124 %attr(755,root,root) %{arch}/bin/dlltool
125 %attr(755,root,root) %{arch}/bin/ld
126 %attr(755,root,root) %{arch}/bin/ld.bfd
127 %attr(755,root,root) %{arch}/bin/nm
128 %attr(755,root,root) %{arch}/bin/objcopy
129 %attr(755,root,root) %{arch}/bin/objdump
130 %attr(755,root,root) %{arch}/bin/ranlib
131 %attr(755,root,root) %{arch}/bin/readelf
132 %attr(755,root,root) %{arch}/bin/strip
133 %{arch}/lib/ldscripts
134 %attr(755,root,root) %{_bindir}/%{target}-addr2line
135 %attr(755,root,root) %{_bindir}/%{target}-ar
136 %attr(755,root,root) %{_bindir}/%{target}-as
137 %attr(755,root,root) %{_bindir}/%{target}-c++filt
138 %attr(755,root,root) %{_bindir}/%{target}-dlltool
139 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
140 %attr(755,root,root) %{_bindir}/%{target}-elfedit
141 %attr(755,root,root) %{_bindir}/%{target}-gprof
142 %attr(755,root,root) %{_bindir}/%{target}-ld
143 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
144 %attr(755,root,root) %{_bindir}/%{target}-nm
145 %attr(755,root,root) %{_bindir}/%{target}-objcopy
146 %attr(755,root,root) %{_bindir}/%{target}-objdump
147 %attr(755,root,root) %{_bindir}/%{target}-ranlib
148 %attr(755,root,root) %{_bindir}/%{target}-readelf
149 %attr(755,root,root) %{_bindir}/%{target}-size
150 %attr(755,root,root) %{_bindir}/%{target}-strings
151 %attr(755,root,root) %{_bindir}/%{target}-strip
152 %attr(755,root,root) %{_bindir}/%{target}-windmc
153 %attr(755,root,root) %{_bindir}/%{target}-windres
154 %{_mandir}/man1/%{target}-addr2line.1*
155 %{_mandir}/man1/%{target}-ar.1*
156 %{_mandir}/man1/%{target}-as.1*
157 %{_mandir}/man1/%{target}-c++filt.1*
158 %{_mandir}/man1/%{target}-dlltool.1*
159 %{_mandir}/man1/%{target}-elfedit.1*
160 %{_mandir}/man1/%{target}-gprof.1*
161 %{_mandir}/man1/%{target}-ld.1*
162 %{_mandir}/man1/%{target}-nm.1*
163 %{_mandir}/man1/%{target}-objcopy.1*
164 %{_mandir}/man1/%{target}-objdump.1*
165 %{_mandir}/man1/%{target}-ranlib.1*
166 %{_mandir}/man1/%{target}-readelf.1*
167 %{_mandir}/man1/%{target}-size.1*
168 %{_mandir}/man1/%{target}-strings.1*
169 %{_mandir}/man1/%{target}-strip.1*
170 %{_mandir}/man1/%{target}-windmc.1*
171 %{_mandir}/man1/%{target}-windres.1*
This page took 0.078441 seconds and 3 git commands to generate.