]> git.pld-linux.org Git - packages/crossmingw32-allegro.git/commitdiff
- 4.2.0 (kiesyoo at o2 pl) auto/ac/allegro-4_2_1-1 auto/th/allegro-4_2_0-1 auto/th/allegro-4_3_0-1 auto/th/allegro-4_3_1-1 auto/ti/allegro-4_3_1-1
authorwolf <wolf@pld-linux.org>
Sun, 13 Nov 2005 18:48:21 +0000 (18:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    allegro-examples.patch -> 1.5
    allegro-info.patch -> 1.6
    allegro-opt.patch -> 1.9

allegro-examples.patch
allegro-info.patch
allegro-opt.patch

index 3240e7c5d0ed013008e190e222cfd32ed58611b7..aa85db2ff0d01ba55e98f5a5e1724cf5d84a1158 100644 (file)
@@ -1,23 +1,22 @@
 --- allegro-4.1.17/makefile.in.orig    2004-12-02 02:02:14.000000000 +0100
 +++ allegro-4.1.17/makefile.in 2005-01-16 22:24:04.277495544 +0100
-@@ -526,7 +526,7 @@
+@@ -527,7 +527,7 @@
          $(INSTALL_DATA) $$file $(DESTDIR)$(includedir)/allegro/platform/; \
        done
  
 -INSTALL_EXES = $(filter tools/%, $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES))
-+INSTALL_EXES = $(filter tools/% demo/% setup/% tests/% examples/%, $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES) $(ALLEGRO_EXAMPLE_EXES))
++INSTALL_EXES = $(filter tools/% demo/% setup/% tests/% examples/%, $(ALLEGRO_EXE_TARGETS))
  
  install-programs: $(INSTALL_EXES)
        $(mkinstalldirs) $(DESTDIR)$(bindir)
-@@ -617,9 +617,10 @@
+@@ -618,9 +618,9 @@
        rm -rf $(includedir)/allegro
  
  uninstall-programs:
 -      @for prog in $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES); do \
 -        if test "X`echo $$prog | sed -e s,tools/.\*,,`" = X; then \
 -          p=`echo $$prog | sed -e s,tools/,,`; \
-+      @for prog in $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES) \
-+        $(ALLEGRO_EXAMPLE_EXES) ; do \
++      @for prog in $(ALLEGRO_EXE_TARGETS); do \
 +        if test "X`echo $$prog | sed -e s,.*/.\*,,`" = X; then \
 +          p=`echo $$prog | sed -e s,,,`; \
            echo rm -f $(bindir)/$$p; \
index f4825812c0390f6fc0a7bf4e8b8dc53a67e3433b..5315ce3c715c2c05f02f43ddae6dd60dcf9b1e32 100644 (file)
@@ -1,7 +1,8 @@
 Don't use tabs, they are expanded at wrong moment
 --- allegro-4.1.12/docs/src/allegro._tx~       Fri Nov 23 07:03:08 2001
 +++ allegro-4.1.12/docs/src/allegro._tx        Fri Nov 23 07:03:08 2001
-@@ -24,8 +24,8 @@
+@@ -31,9 +31,9 @@
+ @# This should remain commented at the moment (dvi output) @$@finalout
  @$
  @$@ifinfo
 -@$@dircategory Libraries
index de791f4ae26468903e268086d9b63ccfb28b0a39..cb2231140a66eecc78ae6f0e437ee0c9cd777839 100644 (file)
@@ -1,11 +1,11 @@
 --- aa/allegro-4.1.15/configure.in     2004-04-27 13:53:02.000000000 +0200
 +++ allegro-4.1.15/configure.in        2004-05-23 21:18:36.478313632 +0200
-@@ -668,26 +662,7 @@
+@@ -720,38 +720,7 @@
  
  dnl How to compile C and asm files.
- if test -n "GCC"; then
+ if test -n "$GCC"; then
 -  if test "X$allegro_strict_warnings" = "Xyes"; then
--    WFLAGS="-Wall -W -Wstrict-prototypes -Wno-unused -Werror"
+-    WFLAGS="-Wall -W -Wstrict-prototypes -Wno-unused-parameter -Werror"
 -  else
 -    WFLAGS="-Wall -Wno-unused"
 -  fi
 -    else
 -      TARGET_ARCH="-mcpu=$allegro_optimizations"
 -    fi
+-  elif test "X$allegro_cv_processor_type" = "Xamd64"; then
+-    dnl Change default pentium->athlon64
+-    if test "X$allegro_optimizations" = "Xpentium"; then
+-      allegro_optimizations="k8"
+-    fi
+-    if test "$allegro_exclusive_optimizations" != none; then
+-      TARGET_ARCH="-march=$allegro_exclusive_optimizations"
+-    elif test "X$allegro_cv_support_amd64_mtune" = "Xyes"; then
+-      TARGET_ARCH="-mtune=$allegro_optimizations"
+-    else
+-      TARGET_ARCH="-mcpu=$allegro_optimizations"
+-    fi
 -  else
 -    TARGET_ARCH=
 -  fi
@@ -28,7 +40,7 @@
    ALLEGRO_DEBUG_CFLAGS="$CFLAGS -g $WFLAGS -DDEBUGMODE"
    if test "X$allegro_debug_with_fortify" = "Xyes"; then
       ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DFORTIFY"
-@@ -692,12 +670,8 @@
+@@ -759,12 +728,8 @@
    if test "X$allegro_debug_with_dmalloc" = "Xyes"; then
       ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DDMALLOC"
    fi
@@ -39,7 +51,7 @@
 -    CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
 -  fi
 +  CFLAGS="$CFLAGS $TARGET_ARCH"
-+      ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $WFLAGS"
++  ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $WFLAGS"
    ALLEGRO_SFLAGS="-x assembler-with-cpp"
    ALLEGRO_SHAREDLIB_CFLAGS="-fPIC -DALLEGRO_SHARED"
  else
This page took 0.055771 seconds and 4 git commands to generate.