]> git.pld-linux.org Git - packages/crossmingw32-SDL_mixer.git/blob - crossmingw32-SDL_mixer.spec
- updated mingw32 packaging
[packages/crossmingw32-SDL_mixer.git] / crossmingw32-SDL_mixer.spec
1 %define         realname        SDL_mixer
2 Summary:        Simple DirectMedia Layer - Sample Mixer Library - MinGW32 cross version
3 Summary(pl.UTF-8):      Simple DirectMedia Layer - biblioteka miksująca próbki dźwiękowe - wersja skrośna MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.12
6 Release:        1
7 License:        Zlib-like
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/projects/SDL_mixer/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  e03ff73d77a55e3572ad0217131dc4a1
11 URL:            http://www.libsdl.org/projects/SDL_mixer/
12 BuildRequires:  crossmingw32-SDL >= 1.2.10
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  crossmingw32-libvorbis >= 1.0
15 BuildRequires:  crossmingw32-w32api
16 Requires:       crossmingw32-SDL >= 1.2.10
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target                  i386-mingw32
23 %define         target_platform         i386-pc-mingw32
24
25 %define         _sysprefix              /usr
26 %define         _prefix                 %{_sysprefix}/%{target}
27 %define         _libdir                 %{_prefix}/lib
28 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
29 %define         _dlldir                 /usr/share/wine/windows/system
30 %define         __cc                    %{target}-gcc
31 %define         __cxx                   %{target}-g++
32 %define         __pkgconfig_provides    %{nil}
33 %define         __pkgconfig_requires    %{nil}
34
35 %ifnarch %{ix86}
36 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
37 %define         optflags        -O2
38 %endif
39 # -z options are invalid for mingw linker, most of -f options are Linux-specific
40 %define         filterout_ld    -Wl,-z,.*
41 %define         filterout_c     -f[-a-z0-9=]*
42
43 %description
44 Due to popular demand, here is a simple multi-channel audio mixer. It
45 supports 4 channels of 16 bit stereo audio, plus a single channel of
46 music, mixed by the popular MikMod MOD, Timidity MIDI and SMPEG MP3
47 libraries.
48
49 This package contains the cross version for Win32.
50
51 %description -l pl.UTF-8
52 SDL_mixer to prosty wielokanałowy mikser audio. Obsługuje 4 kanały
53 16-bitowego dźwięku stereo plus jeden kanał dla muzyki miksowanej
54 przez popularne biblioteki MikMod MOD, Timitity MIDI i SMPEG MP3.
55
56 Ten pakiet zawiera wersję skrośną dla Win32.
57
58 %package static
59 Summary:        Static SDL_mixer library (cross MinGW32 version)
60 Summary(pl.UTF-8):      Statyczna biblioteka SDL_mixer (wersja skrośna MinGW32)
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static SDL_mixer library (cross MinGW32 version).
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka SDL_mixer (wersja skrośna MinGW32).
69
70 %package dll
71 Summary:        SDL_mixer - DLL library for Windows
72 Summary(pl.UTF-8):      SDL_mixer - biblioteka DLL dla Windows
73 Group:          Applications/Emulators
74 Requires:       crossmingw32-SDL-dll >= 1.2.10
75 Requires:       wine
76
77 %description dll
78 SDL_mixer - DLL library for Windows.
79
80 %description dll -l pl.UTF-8
81 SDL_mixer - biblioteka DLL dla Windows.
82
83 %prep
84 %setup -q -n %{realname}-%{version}
85
86 %build
87 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
88 %configure \
89         --host=%{target} \
90         --target=%{target} \
91         --with-sdl-prefix=%{_prefix} \
92         --disable-music-mp3 \
93         --disable-music-mod
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT%{_dlldir}
104 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
105
106 %if 0%{!?debug:1}
107 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
108 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc CHANGES COPYING README
117 %{_libdir}/libSDL_mixer.dll.a
118 %{_libdir}/libSDL_mixer.la
119 %{_includedir}/SDL/SDL_mixer.h
120 %{_pkgconfigdir}/SDL_mixer.pc
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libSDL_mixer.a
125
126 %files dll
127 %defattr(644,root,root,755)
128 %{_dlldir}/SDL_mixer.dll
This page took 0.200264 seconds and 3 git commands to generate.