]> git.pld-linux.org Git - packages/crossmingw32-SDL_image.git/blame - crossmingw32-SDL_image.spec
added filterout_c for -f* options
[packages/crossmingw32-SDL_image.git] / crossmingw32-SDL_image.spec
CommitLineData
2b9321d8 1%define realname SDL_image
11374edc
JB
2Summary: Simple DirectMedia Layer - Sample Image Loading Library - MinGW32 cross version
3Summary(pl.UTF-8): Przykładowa biblioteka do ładowania obrazków - wersja skrośna dla MinGW32
2b9321d8 4Name: crossmingw32-%{realname}
b4114a6f 5Version: 1.2.12
da815f48 6Release: 4
2c5f2605 7License: Zlib-like
2b9321d8 8Group: Libraries
9Source0: http://www.libsdl.org/projects/SDL_image/release/%{realname}-%{version}.tar.gz
b4114a6f 10# Source0-md5: a0f9098ebe5400f0bdc9b62e60797ecb
2b9321d8 11URL: http://www.libsdl.org/projects/SDL_image/
12BuildRequires: autoconf
13BuildRequires: automake
d18c8144 14BuildRequires: crossmingw32-SDL >= 1.2.10
2b9321d8 15BuildRequires: crossmingw32-gcc
f34a67a9 16BuildRequires: crossmingw32-libjpeg >= 7
b4114a6f 17BuildRequires: crossmingw32-libpng >= 1.5.0
2c5f2605 18BuildRequires: crossmingw32-libtiff >= 4
b4114a6f 19BuildRequires: crossmingw32-libwebp >= 0.1.3
2b9321d8 20BuildRequires: crossmingw32-w32api
f34a67a9
JB
21BuildRequires: libtool >= 2:2.0
22BuildRequires: pkgconfig >= 1:0.9.0
d18c8144 23Requires: crossmingw32-SDL >= 1.2.10
37e61a0a 24Requires: crossmingw32-runtime
2b9321d8 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define no_install_post_strip 1
28
d18c8144
JB
29%define target i386-mingw32
30%define target_platform i386-pc-mingw32
2b9321d8 31
d18c8144
JB
32%define _sysprefix /usr
33%define _prefix %{_sysprefix}/%{target}
c8701c7c 34%define _libdir %{_prefix}/lib
f34a67a9 35%define _pkgconfigdir %{_prefix}/lib/pkgconfig
d18c8144
JB
36%define _dlldir /usr/share/wine/windows/system
37%define __cc %{target}-gcc
38%define __cxx %{target}-g++
d9427a69 39%define __pkgconfig_provides %{nil}
4063b14e 40%define __pkgconfig_requires %{nil}
2b9321d8 41
f34a67a9
JB
42%ifnarch %{ix86}
43# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
dcf46c3e 44%define optflags -O2
45%endif
da815f48 46# -z options are invalid for mingw linker, most of -f options are Linux-specific
f34a67a9 47%define filterout_ld -Wl,-z,.*
da815f48 48%define filterout_c -f[-a-z0-9=]*
dcf46c3e 49
2b9321d8 50%description
51This is a simple library to load images of various formats as SDL
b4114a6f
JB
52surfaces. This library currently supports BMP, GIF, JPEG, LBM, PCX,
53PNG, PNM (PBM/PGM/PPM), TGA, TIFF, WebP, XCF and XPM formats.
2b9321d8 54
d18c8144
JB
55This package contains the cross version for Win32.
56
359a03f1
JR
57%description -l pl.UTF-8
58Jest to prosta biblioteka służąca do ładowania różnego formatu
59obrazków jako powierzchni SDL. W chwili obecnej biblioteka obsługuje
b4114a6f
JB
60następujące formaty: BMP, GIF, JPEG, LBM, PCX, PNG, PNM (PBM/PGM/PPM),
61TGA, TIFF, WebP, XCF oraz XPM.
2b9321d8 62
d18c8144
JB
63Ten pakiet zawiera wersję skrośną dla Win32.
64
65%package static
11374edc
JB
66Summary: Static SDL_image library (cross MinGW32 version)
67Summary(pl.UTF-8): Statyczna biblioteka SDL_image (wersja skrośna MinGW32)
d18c8144
JB
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70
71%description static
11374edc 72Static SDL_image library (cross MinGW32 version).
d18c8144
JB
73
74%description static -l pl.UTF-8
11374edc 75Statyczna biblioteka SDL_image (wersja skrośna MinGW32).
d18c8144 76
2b9321d8 77%package dll
d18c8144
JB
78Summary: SDL_image - DLL library for Windows
79Summary(pl.UTF-8): SDL_image - biblioteka DLL dla Windows
2b9321d8 80Group: Applications/Emulators
d18c8144
JB
81Requires: crossmingw32-SDL-dll >= 1.2.10
82Requires: wine
2b9321d8 83
84%description dll
d18c8144 85SDL_image - DLL library for Windows.
2b9321d8 86
359a03f1 87%description dll -l pl.UTF-8
d18c8144 88SDL_image - biblioteka DLL dla Windows.
2b9321d8 89
90%prep
91%setup -q -n %{realname}-%{version}
2b9321d8 92
93%build
f34a67a9 94export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
2b9321d8 95%{__libtoolize}
96%{__aclocal}
97%{__autoconf}
98%{__automake}
99# no sdl test, because it requires configured wine to work
100%configure \
d18c8144 101 --host=%{target} \
076dc26b 102 --target=%{target} \
d18c8144 103 --with-sdl-prefix=%{_prefix} \
f34a67a9 104 --disable-sdltest
2b9321d8 105
d18c8144
JB
106# LIBS hack for libtool not detecting libraries without .la files
107%{__make} \
108 LIBS="$(%{_bindir}/sdl-config --libs | sed -e 's/\(-lmingw32\|-lSDLmain\)/-Wl,\1/g')"
2b9321d8 109
d18c8144
JB
110%install
111rm -rf $RPM_BUILD_ROOT
2b9321d8 112
d18c8144
JB
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116install -d $RPM_BUILD_ROOT%{_dlldir}
117mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
2b9321d8 118
119%if 0%{!?debug:1}
d18c8144
JB
120%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
2b9321d8 122%endif
123
2b9321d8 124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%files
128%defattr(644,root,root,755)
d18c8144
JB
129%doc CHANGES README
130%{_libdir}/libSDL_image.dll.a
131%{_libdir}/libSDL_image.la
132%{_includedir}/SDL/SDL_image.h
f34a67a9 133%{_pkgconfigdir}/SDL_image.pc
d18c8144
JB
134
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libSDL_image.a
2b9321d8 138
139%files dll
140%defattr(644,root,root,755)
d18c8144 141%{_dlldir}/libSDL_image-*.dll
This page took 0.076268 seconds and 4 git commands to generate.