]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blobdiff - crossmingw32-SDL.spec
- tabs in preamble
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
index 4a158a33e42ca36753eb97acb1598f0d53372aa7..a9dc000b6542f98366dc66cf5331348733907a91 100644 (file)
@@ -1,30 +1,27 @@
 %define                realname        SDL
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library - Mingw32 cross version
-Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skro¶na dla Mingw32
+Summary(pl.UTF-8):     SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skrośna dla Mingw32
 Name:          crossmingw32-%{realname}
-Version:       1.2.7
+Version:       1.2.11
 Release:       1
 License:       LGPL
-Group:         X11/Libraries
-Source0:       http://www.libsdl.org/cvs/SDL-1.2.tar.gz
-# Source0-md5: a925e42b258eb25d0041bd88d5704e8f
-Patch0:                %{realname}-byteorder.patch
-Patch1:                %{realname}-fixlibs.patch
-Patch2:                %{realname}-amfix.patch
-Patch3:                %{realname}-lpthread.patch
-Patch4:                %{realname}-no_rpath_in_sdl-config.patch
+Group:         Libraries
+Source0:       http://www.libsdl.org/release/%{realname}-%{version}.tar.gz
+# Source0-md5: 418b42956b7cd103bfab1b9077ccc149
+Patch0:                %{realname}-mmx-constraints.patch
+Patch1:                %{realname}-acfix.patch
 URL:           http://www.libsdl.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: crossmingw32-gcc
+BuildRequires: crossmingw32-runtime
 BuildRequires: crossmingw32-w32api
 BuildRequires: crossmingw32-w32api-dx
 BuildRequires: libtool >= 2:1.4d
-BuildConflicts:        crossmingw32-dx70
-%ifarch %{ix86}
 BuildRequires: nasm
-%endif
 BuildRequires: perl-modules
+BuildConflicts:        crossmingw32-dx70
+Requires:      crossmingw32-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
@@ -38,6 +35,11 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                __cc            %{target}-gcc
 %define                __cxx           %{target}-g++
 
+%ifarch alpha sparc sparc64 sparcv9
+# alpha's -mieee and sparc's -mtune=* are not valid for target's gcc
+%define                optflags        -O2
+%endif
+
 %description
 SDL (Simple DirectMedia Layer) is a library that allows you portable,
 low level access to a video framebuffer, audio output, mouse, and
@@ -45,37 +47,34 @@ keyboard. It can support both windowed and DGA modes of XFree86, and
 it is designed to be portable - applications linked with SDL can also
 be built on Win32 and BeOS.
 
-%description -l pl
-SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
-przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
-myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
-jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
-konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
+%description -l pl.UTF-8
+SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
+przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
+myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
+jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
+konsolidowane z SDL można również budować w systemach Win32 i BeOS.
 
-%description -l pt_BR
-Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
-baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
+%description -l pt_BR.UTF-8
+Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
+baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
 
-Essa biblioteca é usada por alguns jogos.
+Essa biblioteca é usada por alguns jogos.
 
 %package dll
 Summary:       SDL - DLL library for Windows
-Summary(pl):   SDL - biblioteka DLL dla Windows
+Summary(pl.UTF-8):     SDL - biblioteka DLL dla Windows
 Group:         Applications/Emulators
 
 %description dll
 SDL - DLL library for Windows.
 
-%description dll -l pl
+%description dll -l pl.UTF-8
 SDL - biblioteka DLL dla Windows.
 
 %prep
-%setup -q -n %{realname}-1.2
+%setup -q -n %{realname}-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
 CC=%{target}-gcc ; export CC
@@ -105,12 +104,12 @@ TARGET="%{target}" ; export TARGET
 %{__make}
 
 cat sdl-config | sed -e 's@-I/usr/include/SDL@-I%{arch}/include/SDL@' \
-       -e 's@libdirs="-L/usr/lib"@libdirs="-L%{arch}/lib"@' > sdl.new
+       -e 's@ -L/usr/lib @ -L%{arch}/lib @' > sdl.new
 mv -f sdl.new sdl-config
 
 %if 0%{!?debug:1}
-%{target}-strip src/.libs/SDL.dll
-%{target}-strip -g -R.comment -R.note src/.libs/*.a
+%{target}-strip build/.libs/SDL.dll
+#%{target}-strip -g -R.comment -R.note build/.libs/*.a
 %endif
 
 %install
@@ -121,8 +120,8 @@ install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
 
 install include/*.h $RPM_BUILD_ROOT%{arch}/include/SDL
 install sdl-config $RPM_BUILD_ROOT%{arch}/bin/sdl-config
-install src/.libs/libSDL{,.dll}.a src/main/libSDLmain.a $RPM_BUILD_ROOT%{arch}/lib
-install src/.libs/SDL.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system/
+install build/.libs/libSDL{,.dll}.a build/libSDLmain.a $RPM_BUILD_ROOT%{arch}/lib
+install build/.libs/SDL.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
 
 ln -s %{arch}/bin/sdl-config $RPM_BUILD_ROOT%{_bindir}/%{target}-sdl-config
 
This page took 0.092106 seconds and 4 git commands to generate.