]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blob - crossmingw32-SDL.spec
- updated to 1.2.15
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
1 %define         realname        SDL
2 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library - MinGW32 cross version
3 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.15
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  9d96df8417572a2afb781a7c4c811a85
11 Patch0:         %{realname}-acfix.patch
12 URL:            http://www.libsdl.org/
13 BuildRequires:  autoconf >= 2.59-9
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-runtime
17 BuildRequires:  crossmingw32-w32api
18 BuildRequires:  crossmingw32-w32api-dx
19 BuildRequires:  libtool >= 2:2.0
20 BuildRequires:  nasm
21 BuildRequires:  perl-modules
22 BuildConflicts: crossmingw32-dx70
23 Requires:       crossmingw32-runtime
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker
44 %define         filterout_ld    -Wl,-z,.*
45
46 %description
47 SDL (Simple DirectMedia Layer) is a library that allows you portable,
48 low level access to a video framebuffer, audio output, mouse, and
49 keyboard. It can support both windowed and DGA modes of XFree86, and
50 it is designed to be portable - applications linked with SDL can also
51 be built on Win32 and BeOS.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
57 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
58 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
59 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
60 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
61
62 Ten pakiet zawiera wersję skrośną dla Win32.
63
64 %description -l pt_BR.UTF-8
65 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
66 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
67
68 Essa biblioteca é usada por alguns jogos.
69
70 %package static
71 Summary:        Static SDL library (cross MinGW32 version)
72 Summary(pl.UTF-8):      Statyczna biblioteka SDL (wersja skrośna MinGW32)
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description static
77 Static SDL library (cross MinGW32 version).
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka SDL (wersja skrośna MinGW32).
81
82 %package dll
83 Summary:        SDL - DLL library for Windows
84 Summary(pl.UTF-8):      SDL - biblioteka DLL dla Windows
85 Group:          Applications/Emulators
86
87 %description dll
88 SDL - DLL library for Windows.
89
90 %description dll -l pl.UTF-8
91 SDL - biblioteka DLL dla Windows.
92
93 %prep
94 %setup -q -n %{realname}-%{version}
95 %patch0 -p1
96
97 %build
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %configure \
102         --target=%{target} \
103         --host=%{target} \
104         --enable-nasm \
105         --disable-stdio-redirect
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT{%{_dlldir},%{_sysprefix}/bin}
116 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117 ln -s %{_bindir}/sdl-config $RPM_BUILD_ROOT%{_sysprefix}/bin/%{target}-sdl-config
118
119 %if 0%{!?debug:1}
120 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122 %endif
123
124 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,man}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
132 %attr(755,root,root) %{_sysprefix}/bin/%{target}-sdl-config
133 %attr(755,root,root) %{_bindir}/sdl-config
134 %{_libdir}/libSDL.dll.a
135 %{_libdir}/libSDL.la
136 %{_libdir}/libSDLmain.a
137 %{_includedir}/SDL
138 %{_pkgconfigdir}/sdl.pc
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libSDL.a
143
144 %files dll
145 %defattr(644,root,root,755)
146 %{_dlldir}/libSDL-1-2-0.dll
This page took 0.0866 seconds and 4 git commands to generate.