]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blob - crossmingw32-SDL.spec
- strip unwanted flags
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
1 %define         realname        SDL
2 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library - Mingw32 cross version
3 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.14
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  e52086d1b508fa0b76c52ee30b55bec4
11 Patch0:         %{realname}-mmx-constraints.patch
12 Patch1:         %{realname}-acfix.patch
13 URL:            http://www.libsdl.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  crossmingw32-gcc
17 BuildRequires:  crossmingw32-runtime
18 BuildRequires:  crossmingw32-w32api
19 BuildRequires:  crossmingw32-w32api-dx
20 BuildRequires:  libtool >= 2:2.0
21 BuildRequires:  nasm
22 BuildRequires:  perl-modules
23 BuildConflicts: crossmingw32-dx70
24 Requires:       crossmingw32-runtime
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker
45 %define         filterout_ld    -Wl,-z,.*
46
47 %description
48 SDL (Simple DirectMedia Layer) is a library that allows you portable,
49 low level access to a video framebuffer, audio output, mouse, and
50 keyboard. It can support both windowed and DGA modes of XFree86, and
51 it is designed to be portable - applications linked with SDL can also
52 be built on Win32 and BeOS.
53
54 This package contains the cross version for Win32.
55
56 %description -l pl.UTF-8
57 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
58 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
59 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
60 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
61 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
62
63 Ten pakiet zawiera wersję skrośną dla Win32.
64
65 %description -l pt_BR.UTF-8
66 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
67 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
68
69 Essa biblioteca é usada por alguns jogos.
70
71 %package static
72 Summary:        Static SDL library (cross mingw32 version)
73 Summary(pl.UTF-8):      Statyczna biblioteka SDL (wersja skrośna mingw32)
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description static
78 Static SDL library (cross mingw32 version).
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka SDL (wersja skrośna mingw32).
82
83 %package dll
84 Summary:        SDL - DLL library for Windows
85 Summary(pl.UTF-8):      SDL - biblioteka DLL dla Windows
86 Group:          Applications/Emulators
87
88 %description dll
89 SDL - DLL library for Windows.
90
91 %description dll -l pl.UTF-8
92 SDL - biblioteka DLL dla Windows.
93
94 %prep
95 %setup -q -n %{realname}-%{version}
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %configure \
104         --target=%{target} \
105         --host=%{target} \
106         --enable-nasm \
107         --disable-stdio-redirect
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT{%{_dlldir},%{_sysprefix}/bin}
118 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
119 ln -s %{_bindir}/sdl-config $RPM_BUILD_ROOT%{_sysprefix}/bin/%{target}-sdl-config
120
121 %if 0%{!?debug:1}
122 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
123 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
124 %endif
125
126 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,man}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
134 %attr(755,root,root) %{_sysprefix}/bin/%{target}-sdl-config
135 %attr(755,root,root) %{_bindir}/sdl-config
136 %{_libdir}/libSDL.dll.a
137 %{_libdir}/libSDL.la
138 %{_libdir}/libSDLmain.a
139 %{_includedir}/SDL
140 %{_pkgconfigdir}/sdl.pc
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libSDL.a
145
146 %files dll
147 %defattr(644,root,root,755)
148 %{_dlldir}/libSDL-1-2-0.dll
This page took 0.062171 seconds and 4 git commands to generate.