]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blob - crossmingw32-SDL.spec
- BC: crossmingw32-dx70
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
1 %define         realname        SDL
2 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library - Mingw32 cross version
3 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skro¶na dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.7
6 Release:        1
7 License:        LGPL
8 Group:          X11/Libraries
9 Source0:        http://www.libsdl.org/cvs/SDL-1.2.tar.gz
10 # Source0-md5:  a925e42b258eb25d0041bd88d5704e8f
11 Patch0:         %{realname}-byteorder.patch
12 Patch1:         %{realname}-fixlibs.patch
13 Patch2:         %{realname}-amfix.patch
14 Patch3:         %{realname}-lpthread.patch
15 Patch4:         %{realname}-ac25x.patch
16 Patch5:         %{realname}-no_rpath_in_sdl-config.patch
17 URL:            http://www.libsdl.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  crossmingw32-gcc
21 BuildRequires:  crossmingw32-w32api
22 BuildRequires:  crossmingw32-w32api-dx
23 BuildRequires:  libtool >= 2:1.4d
24 BuildConflicts: crossmingw32-dx70
25 %ifarch %{ix86}
26 BuildRequires:  nasm
27 %endif
28 BuildRequires:  perl-modules
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target          i386-mingw32
34 %define         target_platform i386-pc-mingw32
35 %define         arch            %{_prefix}/%{target}
36 %define         gccarch         %{_prefix}/lib/gcc-lib/%{target}
37 %define         gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
38
39 %define         __cc            %{target}-gcc
40 %define         __cxx           %{target}-g++
41
42 %description
43 SDL (Simple DirectMedia Layer) is a library that allows you portable,
44 low level access to a video framebuffer, audio output, mouse, and
45 keyboard. It can support both windowed and DGA modes of XFree86, and
46 it is designed to be portable - applications linked with SDL can also
47 be built on Win32 and BeOS.
48
49 %description -l pl
50 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
51 przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
52 myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
53 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
54 konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
55
56 %description -l pt_BR
57 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
58 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
59
60 Essa biblioteca é usada por alguns jogos.
61
62 %package dll
63 Summary:        SDL - DLL library for Windows
64 Summary(pl):    SDL - biblioteka DLL dla Windows
65 Group:          Applications/Emulators
66
67 %description dll
68 SDL - DLL library for Windows.
69
70 %description dll -l pl
71 SDL - biblioteka DLL dla Windows.
72
73 %prep
74 %setup -q -n %{realname}-1.2
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80 %patch5 -p1
81
82 %build
83 CC=%{target}-gcc ; export CC
84 CXX=%{target}-g++ ; export CXX
85 LD=%{target}-ld ; export LD
86 AR=%{target}-ar ; export AR
87 AS=%{target}-as ; export AS
88 CROSS_COMPILE=1 ; export CROSS_COMPILE
89 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
90 RANLIB=%{target}-ranlib ; export RANLIB
91 LDSHARED="%{target}-gcc -shared" ; export LDSHARED
92 TARGET="%{target}" ; export TARGET
93
94 ./autogen.sh
95 %configure \
96         --target=%{target} \
97         --host=%{target} \
98         --build=i386-linux \
99 %ifarch %{ix86}
100         --enable-nasm \
101 %else
102         --disable-nasm \
103 %endif
104         --prefix=%{arch} \
105         --disable-stdio-redirect
106
107 %{__make}
108
109 cat sdl-config | sed -e 's@-I/usr/include/SDL@-I%{arch}/include/SDL@' \
110         -e 's@libdirs="-L/usr/lib"@libdirs="-L%{arch}/lib"@' > sdl.new
111 mv -f sdl.new sdl-config
112
113 %if 0%{!?debug:1}
114 %{target}-strip src/.libs/SDL.dll
115 %{target}-strip -g -R.comment -R.note src/.libs/*.a
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{arch}/{bin,include/SDL,lib}
121 install -d $RPM_BUILD_ROOT%{_bindir}
122 install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
123
124 install include/*.h $RPM_BUILD_ROOT%{arch}/include/SDL
125 install sdl-config $RPM_BUILD_ROOT%{arch}/bin/sdl-config
126 install src/.libs/libSDL{,.dll}.a src/main/libSDLmain.a $RPM_BUILD_ROOT%{arch}/lib
127 install src/.libs/SDL.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system/
128
129 ln -s %{arch}/bin/sdl-config $RPM_BUILD_ROOT%{_bindir}/%{target}-sdl-config
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{arch}/bin/*
138 %{arch}/include/SDL
139 %{arch}/lib/*
140
141 %files dll
142 %defattr(644,root,root,755)
143 %{_datadir}/wine/windows/system/*
This page took 0.065911 seconds and 4 git commands to generate.