]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blob - crossmingw32-SDL.spec
d902366f2f0107e4729ad3f13db6c06ae47f64a6
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
1 %define         realname        SDL
2 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library - MinGW32 cross version
3 Summary(pl.UTF-8):      SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.15
6 Release:        2
7 License:        LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  9d96df8417572a2afb781a7c4c811a85
11 Patch0:         %{realname}-acfix.patch
12 URL:            http://www.libsdl.org/
13 BuildRequires:  autoconf >= 2.59-9
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-runtime
17 BuildRequires:  crossmingw32-w32api
18 BuildRequires:  crossmingw32-w32api-dx
19 BuildRequires:  libtool >= 2:2.0
20 BuildRequires:  nasm
21 BuildRequires:  perl-modules
22 BuildConflicts: crossmingw32-dx70
23 Requires:       crossmingw32-runtime
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker
45 %define         filterout_ld    -Wl,-z,.*
46
47 %description
48 SDL (Simple DirectMedia Layer) is a library that allows you portable,
49 low level access to a video framebuffer, audio output, mouse, and
50 keyboard. It can support both windowed and DGA modes of XFree86, and
51 it is designed to be portable - applications linked with SDL can also
52 be built on Win32 and BeOS.
53
54 This package contains the cross version for Win32.
55
56 %description -l pl.UTF-8
57 SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
58 przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
59 myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
60 jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
61 konsolidowane z SDL można również budować w systemach Win32 i BeOS.
62
63 Ten pakiet zawiera wersję skrośną dla Win32.
64
65 %description -l pt_BR.UTF-8
66 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
67 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
68
69 Essa biblioteca é usada por alguns jogos.
70
71 %package static
72 Summary:        Static SDL library (cross MinGW32 version)
73 Summary(pl.UTF-8):      Statyczna biblioteka SDL (wersja skrośna MinGW32)
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description static
78 Static SDL library (cross MinGW32 version).
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka SDL (wersja skrośna MinGW32).
82
83 %package dll
84 Summary:        SDL - DLL library for Windows
85 Summary(pl.UTF-8):      SDL - biblioteka DLL dla Windows
86 Group:          Applications/Emulators
87
88 %description dll
89 SDL - DLL library for Windows.
90
91 %description dll -l pl.UTF-8
92 SDL - biblioteka DLL dla Windows.
93
94 %prep
95 %setup -q -n %{realname}-%{version}
96 %patch0 -p1
97
98 : > acinclude.m4
99 echo 'AC_DEFUN([AM_PATH_ESD],[$3])' >> acinclude.m4
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %configure \
106         --target=%{target} \
107         --host=%{target} \
108         --enable-nasm \
109         --disable-stdio-redirect
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT{%{_dlldir},%{_sysprefix}/bin}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121 ln -s %{_bindir}/sdl-config $RPM_BUILD_ROOT%{_sysprefix}/bin/%{target}-sdl-config
122
123 %if 0%{!?debug:1}
124 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
125 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
126 %endif
127
128 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,man}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
136 %attr(755,root,root) %{_sysprefix}/bin/%{target}-sdl-config
137 %attr(755,root,root) %{_bindir}/sdl-config
138 %{_libdir}/libSDL.dll.a
139 %{_libdir}/libSDL.la
140 %{_libdir}/libSDLmain.a
141 %{_includedir}/SDL
142 %{_pkgconfigdir}/sdl.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libSDL.a
147
148 %files dll
149 %defattr(644,root,root,755)
150 %{_dlldir}/libSDL-1-2-0.dll
This page took 0.053606 seconds and 2 git commands to generate.