]> git.pld-linux.org Git - packages/crossmingw32-SDL.git/blame_incremental - crossmingw32-SDL.spec
- unified macros order
[packages/crossmingw32-SDL.git] / crossmingw32-SDL.spec
... / ...
CommitLineData
1%define realname SDL
2Summary: SDL (Simple DirectMedia Layer) - Game/Multimedia Library - Mingw32 cross version
3Summary(pl.UTF-8): SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów - wersja skrośna dla Mingw32
4Name: crossmingw32-%{realname}
5Version: 1.2.13
6Release: 1
7License: LGPL v2.1+
8Group: Libraries
9Source0: http://www.libsdl.org/release/%{realname}-%{version}.tar.gz
10# Source0-md5: c6660feea2a6834de10bc71b2f8e4d88
11Patch0: %{realname}-mmx-constraints.patch
12Patch1: %{realname}-acfix.patch
13URL: http://www.libsdl.org/
14BuildRequires: autoconf
15BuildRequires: automake
16BuildRequires: crossmingw32-gcc
17BuildRequires: crossmingw32-runtime
18BuildRequires: crossmingw32-w32api
19BuildRequires: crossmingw32-w32api-dx
20BuildRequires: libtool >= 2:1.4d
21BuildRequires: nasm
22BuildRequires: perl-modules
23BuildConflicts: crossmingw32-dx70
24Requires: crossmingw32-runtime
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define no_install_post_strip 1
28
29%define target i386-mingw32
30%define target_platform i386-pc-mingw32
31
32%define _sysprefix /usr
33%define _prefix %{_sysprefix}/%{target}
34%define _libdir %{_prefix}/lib
35%define _pkgconfigdir %{_prefix}/lib/pkgconfig
36%define _dlldir /usr/share/wine/windows/system
37%define __cc %{target}-gcc
38%define __cxx %{target}-g++
39
40%ifarch alpha sparc sparc64 sparcv9
41# alpha's -mieee and sparc's -mtune=* are not valid for target's gcc
42%define optflags -O2
43%endif
44
45%description
46SDL (Simple DirectMedia Layer) is a library that allows you portable,
47low level access to a video framebuffer, audio output, mouse, and
48keyboard. It can support both windowed and DGA modes of XFree86, and
49it is designed to be portable - applications linked with SDL can also
50be built on Win32 and BeOS.
51
52This package contains the cross version for Win32.
53
54%description -l pl.UTF-8
55SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
56przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
57myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
58jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
59konsolidowane z SDL można również budować w systemach Win32 i BeOS.
60
61Ten pakiet zawiera wersję skrośną dla Win32.
62
63%description -l pt_BR.UTF-8
64Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
65baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
66
67Essa biblioteca é usada por alguns jogos.
68
69%package static
70Summary: Static SDL library (cross mingw32 version)
71Summary(pl.UTF-8): Statyczna biblioteka SDL (wersja skrośna mingw32)
72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description static
76Static SDL library (cross mingw32 version).
77
78%description static -l pl.UTF-8
79Statyczna biblioteka SDL (wersja skrośna mingw32).
80
81%package dll
82Summary: SDL - DLL library for Windows
83Summary(pl.UTF-8): SDL - biblioteka DLL dla Windows
84Group: Applications/Emulators
85
86%description dll
87SDL - DLL library for Windows.
88
89%description dll -l pl.UTF-8
90SDL - biblioteka DLL dla Windows.
91
92%prep
93%setup -q -n %{realname}-%{version}
94%patch0 -p1
95%patch1 -p1
96
97%build
98%{__libtoolize}
99%{__aclocal}
100%{__autoconf}
101%configure \
102 --target=%{target} \
103 --host=%{target} \
104 --enable-nasm \
105 --disable-stdio-redirect
106
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115install -d $RPM_BUILD_ROOT{%{_dlldir},%{_sysprefix}/bin}
116mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117ln -s %{_bindir}/sdl-config $RPM_BUILD_ROOT%{_sysprefix}/bin/%{target}-sdl-config
118
119%if 0%{!?debug:1}
120%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122%endif
123
124rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,man}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%files
130%defattr(644,root,root,755)
131%doc BUGS CREDITS README README-SDL.txt TODO WhatsNew
132%attr(755,root,root) %{_sysprefix}/bin/%{target}-sdl-config
133%attr(755,root,root) %{_bindir}/sdl-config
134%{_libdir}/libSDL.dll.a
135%{_libdir}/libSDL.la
136%{_libdir}/libSDLmain.a
137%{_includedir}/SDL
138%{_pkgconfigdir}/sdl.pc
139
140%files static
141%defattr(644,root,root,755)
142%{_libdir}/libSDL.a
143
144%files dll
145%defattr(644,root,root,755)
146%{_dlldir}/SDL.dll
This page took 0.028919 seconds and 4 git commands to generate.