]> git.pld-linux.org Git - packages/crossm68k-gcc.git/blame - crossm68k-gcc.spec
- outdated
[packages/crossm68k-gcc.git] / crossm68k-gcc.spec
CommitLineData
6ab9e64e 1Summary: Cross m68k GNU binary utility development utilities - gcc
9a941d00
ER
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - m68k gcc
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - m68k gcc
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla m68k - gcc
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - m68k gcc
88a9c143 6Summary(tr.UTF-8): GNU geliţtirme araçlarý - m68k gcc
6ab9e64e 7Name: crossm68k-gcc
88a9c143 8Version: 3.3.6
6ab9e64e 9Release: 1
10Epoch: 1
11License: GPL
12Group: Development/Languages
13Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
88a9c143 14# Source0-md5: 6936616a967da5a0b46f1e7424a06414
15Patch0: %{name}-coldfire-targets.patch
16Patch1: %{name}-coldfire-frame.patch
17Patch2: %{name}-idshlib.patch
18Patch3: %{name}-coldfire-omitfp.patch
19Patch4: %{name}-specs.patch
20Patch5: %{name}-thunk.patch
21Patch6: %{name}-nowchar.patch
6ab9e64e 22BuildRequires: /bin/bash
23BuildRequires: autoconf
24BuildRequires: bison
25BuildRequires: crossm68k-binutils
df4a3e43 26BuildRequires: crossm68k-uClibc
6ab9e64e 27BuildRequires: flex
88a9c143 28BuildRequires: sed >= 4.0
6ab9e64e 29Requires: crossm68k-binutils
6ab9e64e 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
df4a3e43 32%define target m68k-elf
6ab9e64e 33%define arch %{_prefix}/%{target}
34%define gccarch %{_libdir}/gcc-lib/%{target}
35%define gcclib %{_libdir}/gcc-lib/%{target}/%{version}
36
88a9c143 37%define _noautostrip .*lib.*\\.a
6ab9e64e 38
39%description
40This package contains a cross-gcc which allows the creation of
41binaries to be run on m68k linux (architecture m68k-linux) on other
42machines.
43
e7003046
JR
44%description -l de.UTF-8
45Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
46anderem Rechner Code für m68k-Linux zu generieren.
6ab9e64e 47
e7003046
JR
48%description -l pl.UTF-8
49Ten pakiet zawiera skrośny gcc pozwalający na robienie na innych
50maszynach binariów do uruchamiania na m68k.
6ab9e64e 51
52%prep
53%setup -q -n gcc-%{version}
df4a3e43 54%patch0 -p1
55%patch1 -p1
56%patch2 -p1
57%patch3 -p1
88a9c143 58%patch4 -p1
59%patch5 -p1
60%patch6 -p1
6ab9e64e 61
88a9c143 62sed -i 's#unsigned signo;#int signo;#' \
63 libiberty/strsignal.c
df4a3e43 64
88a9c143 65sed -i 's#char \*message;#const char *message;#' \
66 libiberty/strsignal.c
6ab9e64e 67
88a9c143 68rm -rf libstdc++-v3/config/os/newlib
69ln -s generic libstdc++-v3/config/os/newlib
70
71%build
72rm -rf %{target}-obj && install -d %{target}-obj && cd %{target}-obj
73
74CFLAGS="%{rpmcflags}" \
75CXXFLAGS="%{rpmcflags}" \
76TEXCONFIG=false \
6ab9e64e 77../configure \
78 --prefix=%{_prefix} \
79 --infodir=%{_infodir} \
80 --mandir=%{_mandir} \
81 --bindir=%{_bindir} \
82 --libdir=%{_libdir} \
83 --libexecdir=%{_libdir} \
88a9c143 84 --disable-nls \
6ab9e64e 85 --disable-shared \
88a9c143 86 --disable-wchar_t \
87 --enable-languages="c" \
347d3e57 88 --enable-target-optspace \
88a9c143 89 --enable-threads=posix \
90 --with-headers=%{arch}/include \
91 --with-multilib \
92 --with-newlib \
93 --with-system-zlib \
94 --without-x \
6ab9e64e 95 --target=%{target} \
96 --host=%{_target_platform} \
97 --build=%{_target_platform}
df4a3e43 98cd ..
88a9c143 99%{__make} -C %{target}-obj
6ab9e64e 100
101%install
102rm -rf $RPM_BUILD_ROOT
103
88a9c143 104%{__make} -C %{target}-obj install \
105 DESTDIR=$RPM_BUILD_ROOT
2d91fcf5 106
88a9c143 107find $RPM_BUILD_ROOT -type f -name 'libiberty.a' | \
108 xargs rm
6ab9e64e 109
110%if 0%{!?debug:1}
88a9c143 111find $RPM_BUILD_ROOT -type f -name '*.[ao]' | \
112 xargs %{target}-strip --strip-debug
6ab9e64e 113%endif
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
88a9c143 120%attr(755,root,root) %{_bindir}/%{target}-cpp
121%attr(755,root,root) %{_bindir}/%{target}-gc*
6ab9e64e 122%attr(755,root,root) %{gcclib}/cc1
123%attr(755,root,root) %{gcclib}/collect2
df4a3e43 124%dir %{gccarch}
125%dir %{gcclib}
88a9c143 126%dir %{gcclib}/include
127%{gcclib}/include/*.h
128%{gcclib}/m*
129%{gcclib}/specs
6ab9e64e 130%{_mandir}/man1/%{target}-gcc.1*
This page took 0.13124 seconds and 4 git commands to generate.