]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- tab
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl.UTF-8):      Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.9.1
5 Release:        2
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  9444daefe1a457b4a18101c255be6cdc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-ac260.patch
14 Patch1:         %{name}-check.patch
15 Patch2:         %{name}-daemon.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  xorg-lib-libX11-devel
18 BuildRequires:  xorg-lib-libXaw-devel
19 BuildRequires:  xorg-lib-libXmu-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  cproto
23 BuildRequires:  libtool
24 BuildRequires:  python-devel >= 1:2.3
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires(post,preun):   /sbin/chkconfig
27 %pyrequires_eq  python
28 Requires:       crossfire-maps
29 Requires:       rc-scripts
30 Conflicts:      logrotate < 3.7-4
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _localstatedir  /var/lib
34
35 %description
36 This is a multiplayer graphical arcade and adventure game made for the
37 X-Window environment. There are also Windows and Java clients
38 available.
39
40 It has certain flavours from other games, especially Gauntlet (TM) and
41 Nethack/Moria.
42
43 Any number of players can move around in their own window, finding and
44 sing items and battle monsters. They can choose to cooperate or
45 compete in the same "world".
46
47 %description -l pl.UTF-8
48 To jest graficzna gra przygodowa dla środowiska X-Window. Są także
49 dostępni klienci pod Windows i w Javie.
50
51 %package editor
52 Summary:        Crossfire map editor
53 Summary(pl.UTF-8):      Edytor map Crossfire
54 Group:          Applications/Games
55
56 %description editor
57 Crossfire map editor.
58
59 %description editor -l pl.UTF-8
60 Edytor map Crossfire.
61
62 %package doc
63 Summary:        Crossfire game documentation
64 Summary(pl.UTF-8):      Dokumentacja gry Crossfire
65 Group:          Documentation
66
67 %description doc
68 Crossfire documentation for players. Includes handbook and spoiler.
69
70 %description doc -l pl.UTF-8
71 Dokumentacja dla graczy Crossfire. Zawiera podręcznik oraz spoiler.
72
73 %package plugin-python
74 Summary:        Python plugin for Crossfire server
75 Summary(pl.UTF-8):      Wtyczka Pythona dla serwera Crossfire
76 Group:          Applications/Games
77 Requires:       %{name} = %{version}-%{release}
78
79 %description plugin-python
80 Python plugin for Crossfire server.
81
82 %description plugin-python -l pl.UTF-8
83 Wtyczka Pythona dla serwera Crossfire.
84
85 %package plugin-anim
86 Summary:        Animation plugin for Crossfire server
87 Summary(pl.UTF-8):      Wtyczka animacji dla serwera Crossfire
88 Group:          Applications/Games
89 Requires:       %{name} = %{version}-%{release}
90
91 %description plugin-anim
92 Animation plugin for Crossfire server.
93
94 %description plugin-anim -l pl.UTF-8
95 Wtyczka animacji dla serwera Crossfire.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__automake}
108 touch include/autoconf.h{,.in}
109 %configure
110 install -d test/include
111 %{__make} -C test/toolkit proto
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
117         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/*.a
123 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
124 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
125 rm $RPM_BUILD_ROOT%{_bindir}/player_dl.pl
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
127 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
128 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
129 touch $RPM_BUILD_ROOT/var/log/crossfire
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 /sbin/chkconfig --add crossfire
136 %service crossfire restart "Crossfire server"
137
138 %preun
139 if [ "$1" = "0" ]; then
140         %service crossfire stop
141         /sbin/chkconfig --del crossfire
142 fi
143
144 %files
145 %defattr(644,root,root,755)
146 %doc DEVELOPERS README TODO ChangeLog
147 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
148 %attr(750,root,games) %{_bindir}/crossfire
149 %attr(755,root,games) %{_bindir}/crossfire-config
150 %dir %attr(750,root,games) %{_datadir}/crossfire
151 %{_datadir}/crossfire/*
152 %{_mandir}/man?/crossfire*
153 %dir %attr(770,root,games) %{_localstatedir}/crossfire
154 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
155 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
156 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
157 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
158 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/bookarch
159 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/highscore
160 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/temp.maps
161 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/clockdata
162 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/banish_file
163 %dir %{_sysconfdir}/crossfire
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/crossfire/*
165 %attr(754,root,root) /etc/rc.d/init.d/crossfire
166 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/crossfire
167 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/crossfire
168 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) /var/log/crossfire
169 %dir %{_libdir}/crossfire
170 %dir %{_libdir}/crossfire/plugins
171 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
172 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
173 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
174 %attr(755,root,root) %{_libdir}/crossfire/random_map
175
176 %files editor
177 %defattr(644,root,root,755)
178 %doc crossedit/doc/*.doc
179 %attr(755,root,root) %{_bindir}/crossedit
180 %{_mandir}/man?/crossedit*
181
182 %files doc
183 %defattr(644,root,root,755)
184 %doc doc/{handbook.ps,spoiler.ps}
185 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
186 %doc doc/{skills.doc,spellcasters_guide_to_runes}
187 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
188
189 %files plugin-python
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfpython.*
192
193 %files plugin-anim
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfanim.*
This page took 0.060719 seconds and 3 git commands to generate.