]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
c48beccf4158e01a8f67cf1541b70ab3e5f0e3b0
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.5.0
5 Release:        1
6 Group:          Applications/Games
7 License:        GPL
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  b22556499a1aa99a19e6c5c7b33d501f
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-perlpath.patch
14 URL:            http://crossfire.real-time.com/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  autoconf
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       crossfire-maps
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _localstatedir  /var/lib
22
23 %description 
24 This is a multiplayer graphical arcade and adventure game made for the
25 X-Window environment. There are also Windows and Java clients
26 available.
27
28 It has certain flavours from other games, especially Gauntlet (TM) and
29 Nethack/Moria.
30
31 Any number of players can move around in their own window, finding and
32 sing items and battle monsters. They can choose to cooperate or
33 compete in the same "world".
34
35 %description -l pl
36 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
37 dostêpni klienci pod Windows i w Javie.
38
39 %package editor
40 Summary:        Crossfire map editor
41 Summary(pl):    Edytor map crossfire
42 Group:          Applications/Games
43
44 %description editor
45 Crossfire map editor.
46
47 %description editor -l pl
48 Edytor map crossfire.
49
50 %package doc
51 Summary:        Crossfire game documentation
52 Summary(pl):    Dokumentacja gry crossfire
53 Group:          Applications/Games
54
55 %description doc
56 Crossfire documentation for players. Includes handbook and spoiler.
57
58 %description doc -l pl
59 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
60
61 %package plugin-python
62 Summary:        python plugin for crossfire server
63 Group:          Applications/Games
64 Requires:       %{name} = %{version}
65
66 %description plugin-python
67 Python plugin for crossfire server.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__autoconf}
75 %configure
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
81         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/plugin_python.a
87 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
88 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
89 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
90 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
91 touch $RPM_BUILD_ROOT/var/log/crossfire
92  
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 /sbin/chkconfig --add crossfire
98 if [ -r /var/lock/subsys/crossfire ]; then
99         /etc/rc.d/init.d/crossfire restart >&2
100 else
101         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
102 fi
103
104 %preun
105 if [ "$1" = "0" ]; then
106         if [ -r /var/lock/subsys/crossfire ]; then
107                 /etc/rc.d/init.d/crossfire stop >&2
108         fi
109         /sbin/chkconfig --del crossfire
110 fi
111
112 %files
113 %defattr(644,root,root,755)
114 %doc DEVELOPERS README TODO
115 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
116 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
117 %doc doc/Developers utils/crossloop{,.web,.pl}
118 %attr(750,root,games) %{_bindir}/crossfire
119 %attr(755,root,games) %{_bindir}/crossfire-config
120 %dir %attr(750,root,games) %{_datadir}/crossfire
121 %{_datadir}/crossfire/*
122 %{_mandir}/man?/crossfire*
123 %dir %attr(750,root,games) %{_localstatedir}/crossfire
124 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
125 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
126 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
127 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
128 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
129 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
130 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
131 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
132 %dir /etc/crossfire
133 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
134 %attr(754,root,root) /etc/rc.d/init.d/crossfire
135 %attr(660,root,root) /etc/logrotate.d/crossfire
136 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
137 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
138 %dir %{_libdir}/crossfire
139 %dir %{_libdir}/crossfire/plugins
140 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
141 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
142 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
143 %attr(755,root,root) %{_libdir}/crossfire/random_map
144                      
145 %files editor
146 %defattr(644,root,root,755)
147 %doc crossedit/doc/*.doc
148 %attr(755,root,root) %{_bindir}/crossedit
149 %{_mandir}/man?/crossedit*
150
151 %files doc
152 %defattr(644,root,root,755)
153 %doc doc/{handbook.ps,spoiler.ps}
154 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
155 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
156
157 %files plugin-python
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/crossfire/plugins/plugin_python.*
This page took 0.028431 seconds and 2 git commands to generate.