]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
b873a09d13d828118672fb5c1e681e1d04a1a316
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl.UTF-8):      Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.9.1
5 Release:        6
6 License:        GPL
7 Group:          X11/Applications/Games
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  9444daefe1a457b4a18101c255be6cdc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-ac260.patch
14 Patch1:         %{name}-check.patch
15 Patch2:         %{name}-daemon.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  check
20 BuildRequires:  cproto
21 BuildRequires:  libtool
22 BuildRequires:  python-devel >= 1:2.3
23 BuildRequires:  rpmbuild(macros) >= 1.268
24 BuildRequires:  xorg-lib-libX11-devel
25 BuildRequires:  xorg-lib-libXaw-devel
26 BuildRequires:  xorg-lib-libXmu-devel
27 Requires(post,preun):   /sbin/chkconfig
28 %pyrequires_eq  python
29 Requires:       crossfire-maps
30 Requires:       rc-scripts
31 Conflicts:      logrotate < 3.7-4
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _localstatedir  /var/lib
35
36 %description
37 This is a multiplayer graphical arcade and adventure game made for the
38 X-Window environment. There are also Windows and Java clients
39 available.
40
41 It has certain flavours from other games, especially Gauntlet (TM) and
42 Nethack/Moria.
43
44 Any number of players can move around in their own window, finding and
45 sing items and battle monsters. They can choose to cooperate or
46 compete in the same "world".
47
48 %description -l pl.UTF-8
49 To jest graficzna gra przygodowa dla środowiska X-Window. Są także
50 dostępni klienci pod Windows i w Javie.
51
52 %package editor
53 Summary:        Crossfire map editor
54 Summary(pl.UTF-8):      Edytor map Crossfire
55 Group:          X11/Applications/Games
56
57 %description editor
58 Crossfire map editor.
59
60 %description editor -l pl.UTF-8
61 Edytor map Crossfire.
62
63 %package doc
64 Summary:        Crossfire game documentation
65 Summary(pl.UTF-8):      Dokumentacja gry Crossfire
66 Group:          Documentation
67
68 %description doc
69 Crossfire documentation for players. Includes handbook and spoiler.
70
71 %description doc -l pl.UTF-8
72 Dokumentacja dla graczy Crossfire. Zawiera podręcznik oraz spoiler.
73
74 %package plugin-python
75 Summary:        Python plugin for Crossfire server
76 Summary(pl.UTF-8):      Wtyczka Pythona dla serwera Crossfire
77 Group:          X11/Applications/Games
78 Requires:       %{name} = %{version}-%{release}
79
80 %description plugin-python
81 Python plugin for Crossfire server.
82
83 %description plugin-python -l pl.UTF-8
84 Wtyczka Pythona dla serwera Crossfire.
85
86 %package plugin-anim
87 Summary:        Animation plugin for Crossfire server
88 Summary(pl.UTF-8):      Wtyczka animacji dla serwera Crossfire
89 Group:          X11/Applications/Games
90 Requires:       %{name} = %{version}-%{release}
91
92 %description plugin-anim
93 Animation plugin for Crossfire server.
94
95 %description plugin-anim -l pl.UTF-8
96 Wtyczka animacji dla serwera Crossfire.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__automake}
109 touch include/autoconf.h{,.in}
110 %configure
111 install -d test/include
112 %{__make} -C test/toolkit proto
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
118         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/*.a
124 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
125 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
126 rm $RPM_BUILD_ROOT%{_bindir}/player_dl.pl
127 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
128 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
129 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
130 touch $RPM_BUILD_ROOT/var/log/crossfire
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 /sbin/chkconfig --add crossfire
137 %service crossfire restart "Crossfire server"
138
139 %preun
140 if [ "$1" = "0" ]; then
141         %service crossfire stop
142         /sbin/chkconfig --del crossfire
143 fi
144
145 %files
146 %defattr(644,root,root,755)
147 %doc DEVELOPERS README TODO ChangeLog
148 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
149 %attr(750,root,games) %{_bindir}/crossfire
150 %attr(755,root,games) %{_bindir}/crossfire-config
151 %dir %attr(750,root,games) %{_datadir}/crossfire
152 %{_datadir}/crossfire/*
153 %{_mandir}/man?/crossfire*
154 %dir %attr(770,root,games) %{_localstatedir}/crossfire
155 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
156 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
157 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
158 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
159 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/bookarch
160 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/highscore
161 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/temp.maps
162 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/clockdata
163 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/banish_file
164 %dir %{_sysconfdir}/crossfire
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/crossfire/*
166 %attr(754,root,root) /etc/rc.d/init.d/crossfire
167 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/crossfire
168 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/crossfire
169 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) /var/log/crossfire
170 %dir %{_libdir}/crossfire
171 %dir %{_libdir}/crossfire/plugins
172 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
173 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
174 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
175 %attr(755,root,root) %{_libdir}/crossfire/random_map
176
177 %files editor
178 %defattr(644,root,root,755)
179 %doc crossedit/doc/*.doc
180 %attr(755,root,root) %{_bindir}/crossedit
181 %{_mandir}/man?/crossedit*
182
183 %files doc
184 %defattr(644,root,root,755)
185 %doc doc/{handbook.ps,spoiler.ps}
186 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
187 %doc doc/{skills.doc,spellcasters_guide_to_runes}
188 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
189
190 %files plugin-python
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfpython.*
193
194 %files plugin-anim
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfanim.*
This page took 0.036457 seconds and 2 git commands to generate.