]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- added missing BR
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.5.0
5 Release:        2
6 Group:          Applications/Games
7 License:        GPL
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  b22556499a1aa99a19e6c5c7b33d501f
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-perlpath.patch
14 URL:            http://crossfire.real-time.com/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  autoconf
17 BuildRequires:  python-devel >= 2.3
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       crossfire-maps
20 %pyrequires_eq  python
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _localstatedir  /var/lib
24
25 %description 
26 This is a multiplayer graphical arcade and adventure game made for the
27 X-Window environment. There are also Windows and Java clients
28 available.
29
30 It has certain flavours from other games, especially Gauntlet (TM) and
31 Nethack/Moria.
32
33 Any number of players can move around in their own window, finding and
34 sing items and battle monsters. They can choose to cooperate or
35 compete in the same "world".
36
37 %description -l pl
38 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
39 dostêpni klienci pod Windows i w Javie.
40
41 %package editor
42 Summary:        Crossfire map editor
43 Summary(pl):    Edytor map crossfire
44 Group:          Applications/Games
45
46 %description editor
47 Crossfire map editor.
48
49 %description editor -l pl
50 Edytor map crossfire.
51
52 %package doc
53 Summary:        Crossfire game documentation
54 Summary(pl):    Dokumentacja gry crossfire
55 Group:          Applications/Games
56
57 %description doc
58 Crossfire documentation for players. Includes handbook and spoiler.
59
60 %description doc -l pl
61 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
62
63 %package plugin-python
64 Summary:        python plugin for crossfire server
65 Group:          Applications/Games
66 Requires:       %{name} = %{version}
67
68 %description plugin-python
69 Python plugin for crossfire server.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %{__autoconf}
77 %configure
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
83         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/plugin_python.a
89 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
90 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
91 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
92 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
93 touch $RPM_BUILD_ROOT/var/log/crossfire
94  
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add crossfire
100 if [ -r /var/lock/subsys/crossfire ]; then
101         /etc/rc.d/init.d/crossfire restart >&2
102 else
103         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
104 fi
105
106 %preun
107 if [ "$1" = "0" ]; then
108         if [ -r /var/lock/subsys/crossfire ]; then
109                 /etc/rc.d/init.d/crossfire stop >&2
110         fi
111         /sbin/chkconfig --del crossfire
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc DEVELOPERS README TODO
117 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
118 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
119 %doc doc/Developers utils/crossloop{,.web,.pl}
120 %attr(750,root,games) %{_bindir}/crossfire
121 %attr(755,root,games) %{_bindir}/crossfire-config
122 %dir %attr(750,root,games) %{_datadir}/crossfire
123 %{_datadir}/crossfire/*
124 %{_mandir}/man?/crossfire*
125 %dir %attr(750,root,games) %{_localstatedir}/crossfire
126 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
127 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
128 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
129 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
130 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
131 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
132 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
133 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
134 %dir /etc/crossfire
135 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
136 %attr(754,root,root) /etc/rc.d/init.d/crossfire
137 %attr(660,root,root) /etc/logrotate.d/crossfire
138 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
139 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
140 %dir %{_libdir}/crossfire
141 %dir %{_libdir}/crossfire/plugins
142 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
143 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
144 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
145 %attr(755,root,root) %{_libdir}/crossfire/random_map
146                      
147 %files editor
148 %defattr(644,root,root,755)
149 %doc crossedit/doc/*.doc
150 %attr(755,root,root) %{_bindir}/crossedit
151 %{_mandir}/man?/crossedit*
152
153 %files doc
154 %defattr(644,root,root,755)
155 %doc doc/{handbook.ps,spoiler.ps}
156 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
157 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
158
159 %files plugin-python
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/crossfire/plugins/plugin_python.*
This page took 0.076474 seconds and 3 git commands to generate.