]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
a36435a38ed5e197a1b6038ae50b0c4816e7e7d3
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl.UTF-8):      Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.9.1
5 Release:        13
6 License:        GPL
7 Group:          X11/Applications/Games
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  9444daefe1a457b4a18101c255be6cdc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-ac260.patch
14 Patch1:         %{name}-check.patch
15 Patch2:         %{name}-daemon.patch
16 Patch3:         %{name}-python.patch
17 Patch4:         %{name}-am.patch
18 Patch5:         %{name}-libpng15.patch
19 URL:            http://crossfire.real-time.com/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  check
23 BuildRequires:  cproto
24 BuildRequires:  libtool
25 BuildRequires:  python-devel >= 1:2.3
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 BuildRequires:  xorg-lib-libX11-devel
28 BuildRequires:  xorg-lib-libXaw-devel
29 BuildRequires:  xorg-lib-libXmu-devel
30 Requires(post,preun):   /sbin/chkconfig
31 %pyrequires_eq  python
32 Requires:       crossfire-maps
33 Requires:       rc-scripts
34 Conflicts:      logrotate < 3.8.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _localstatedir  /var/lib
38
39 %description
40 This is a multiplayer graphical arcade and adventure game made for the
41 X-Window environment. There are also Windows and Java clients
42 available.
43
44 It has certain flavours from other games, especially Gauntlet (TM) and
45 Nethack/Moria.
46
47 Any number of players can move around in their own window, finding and
48 sing items and battle monsters. They can choose to cooperate or
49 compete in the same "world".
50
51 %description -l pl.UTF-8
52 To jest graficzna gra przygodowa dla środowiska X-Window. Są także
53 dostępni klienci pod Windows i w Javie.
54
55 %package editor
56 Summary:        Crossfire map editor
57 Summary(pl.UTF-8):      Edytor map Crossfire
58 Group:          X11/Applications/Games
59
60 %description editor
61 Crossfire map editor.
62
63 %description editor -l pl.UTF-8
64 Edytor map Crossfire.
65
66 %package doc
67 Summary:        Crossfire game documentation
68 Summary(pl.UTF-8):      Dokumentacja gry Crossfire
69 Group:          Documentation
70
71 %description doc
72 Crossfire documentation for players. Includes handbook and spoiler.
73
74 %description doc -l pl.UTF-8
75 Dokumentacja dla graczy Crossfire. Zawiera podręcznik oraz spoiler.
76
77 %package plugin-python
78 Summary:        Python plugin for Crossfire server
79 Summary(pl.UTF-8):      Wtyczka Pythona dla serwera Crossfire
80 Group:          X11/Applications/Games
81 Requires:       %{name} = %{version}-%{release}
82
83 %description plugin-python
84 Python plugin for Crossfire server.
85
86 %description plugin-python -l pl.UTF-8
87 Wtyczka Pythona dla serwera Crossfire.
88
89 %package plugin-anim
90 Summary:        Animation plugin for Crossfire server
91 Summary(pl.UTF-8):      Wtyczka animacji dla serwera Crossfire
92 Group:          X11/Applications/Games
93 Requires:       %{name} = %{version}-%{release}
94
95 %description plugin-anim
96 Animation plugin for Crossfire server.
97
98 %description plugin-anim -l pl.UTF-8
99 Wtyczka animacji dla serwera Crossfire.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 touch include/autoconf.h{,.in}
116 %configure
117 install -d test/include
118 %{__make} -C test/toolkit proto
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
124         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/*.a
130 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
131 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
132 rm $RPM_BUILD_ROOT%{_bindir}/player_dl.pl
133 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
134 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
135 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
136 touch $RPM_BUILD_ROOT/var/log/crossfire
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/chkconfig --add crossfire
143 %service crossfire restart "Crossfire server"
144
145 %preun
146 if [ "$1" = "0" ]; then
147         %service crossfire stop
148         /sbin/chkconfig --del crossfire
149 fi
150
151 %files
152 %defattr(644,root,root,755)
153 %doc DEVELOPERS README TODO ChangeLog
154 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
155 %attr(750,root,games) %{_bindir}/crossfire
156 %attr(755,root,games) %{_bindir}/crossfire-config
157 %dir %attr(750,root,games) %{_datadir}/crossfire
158 %{_datadir}/crossfire/*
159 %{_mandir}/man?/crossfire*
160 %dir %attr(770,root,games) %{_localstatedir}/crossfire
161 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
162 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
163 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
164 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
165 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/bookarch
166 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/highscore
167 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/temp.maps
168 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/clockdata
169 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/banish_file
170 %dir %{_sysconfdir}/crossfire
171 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/crossfire/*
172 %attr(754,root,root) /etc/rc.d/init.d/crossfire
173 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/crossfire
174 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/crossfire
175 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) /var/log/crossfire
176 %dir %{_libdir}/crossfire
177 %dir %{_libdir}/crossfire/plugins
178 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
179 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
180 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
181 %attr(755,root,root) %{_libdir}/crossfire/random_map
182
183 %files editor
184 %defattr(644,root,root,755)
185 %doc crossedit/doc/*.doc
186 %attr(755,root,root) %{_bindir}/crossedit
187 %{_mandir}/man?/crossedit*
188
189 %files doc
190 %defattr(644,root,root,755)
191 %doc doc/{handbook.ps,spoiler.ps}
192 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
193 %doc doc/{skills.doc,spellcasters_guide_to_runes}
194 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
195
196 %files plugin-python
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfpython.*
199
200 %files plugin-anim
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfanim.*
This page took 0.032145 seconds and 2 git commands to generate.