]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
8ef0b447360a875d8cb35270aaaebeb8500691e5
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.3.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/crossfire/%{name}-%{version}.tar.bz2
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.logrotate
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-directories.patch
14 Patch2:         %{name}-tmp_maps.patch
15 Patch3:         %{name}-python.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _localstatedir  /var/lib
23
24 %description 
25 This is a multiplayer graphical arcade and adventure game made for the
26 X-Window environment. There are also Windows and Java clients
27 available.
28
29 It has certain flavours from other games, especially Gauntlet (TM) and
30 Nethack/Moria.
31
32 Any number of players can move around in their own window, finding and
33 sing items and battle monsters. They can choose to cooperate or
34 compete in the same "world".
35
36 %description -l pl
37 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
38 dostêpni klienci pod Windows i w Javie.
39
40 %package editor
41 Summary:        Crossfire map editor
42 Summary(pl):    Edytor map crossfire
43 Group:          Applications/Games
44
45 %description editor
46 Crossfire map editor.
47
48 %description editor -l pl
49 Edytor map crossfire.
50
51 %package doc
52 Summary:        Crossfire game documentation
53 Summary(pl):    Dokumentacja gry crossfire
54 Group:          Applications/Games
55
56 %description doc
57 Crossfire documentation for players. Includes handbook and spoiler.
58
59 %description doc -l pl
60 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 # don't apply, its unfinished
68 #%patch3 -p1
69 cd lib
70
71 %build
72 %{__autoconf}
73 %configure
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
79         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
80
81 %{__make} install DESTDIR="$RPM_BUILD_ROOT"
82
83 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/{ban_file,settings,dm_file,motd,forbid} \
84         $RPM_BUILD_ROOT/etc/%{name}
85
86 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
87 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
88 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
89
90 touch $RPM_BUILD_ROOT%{_localstatedir}/%{name}/clockdata \
91         $RPM_BUILD_ROOT/var/log/crossfire
92
93 rm doc/Developers/Makefile*
94  
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add crossfire
100 if [ -r /var/lock/subsys/crossfire ]; then
101         /etc/rc.d/init.d/crossfire restart >&2
102 else
103         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
104 fi
105
106 %preun
107 if [ "$1" = "0" ]; then
108         if [ -r /var/lock/subsys/crossfire ]; then
109                 /etc/rc.d/init.d/crossfire stop >&2
110         fi
111         /sbin/chkconfig --del crossfire
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc CHANGES CREDITS DEVELOPERS README TODO
117 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
118 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
119 %doc doc/Developers
120 %attr(750,root,games) %{_bindir}/crossfire
121 %attr(750,root,games) %{_bindir}/random_map
122 %dir %attr(750,root,games) %{_datadir}/crossfire
123 %{_datadir}/crossfire/*
124 %{_mandir}/man?/crossfire*
125 %dir %attr(750,root,games) %{_localstatedir}/crossfire
126 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
127 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
128 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
129 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
130 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
131 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
132 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
133 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
134 %dir /etc/crossfire
135 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
136 %attr(754,root,root) /etc/rc.d/init.d/crossfire
137 %attr(660,root,root) /etc/logrotate.d/crossfire
138 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
139 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
140
141 %files editor
142 %defattr(644,root,root,755)
143 %doc doc/Crossedit.doc crossedit/doc/*.doc
144 %attr(755,root,root) %{_bindir}/crossedit
145 %{_mandir}/man?/crossedit*
146
147 %files doc
148 %defattr(644,root,root,755)
149 %doc doc/{handbook.ps,spoiler.ps}
150 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
151 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
This page took 0.027376 seconds and 2 git commands to generate.