]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- %%defattr for doc subpackage
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.3.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/crossfire/%{name}-%{version}.tar.bz2
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.logrotate
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-directories.patch
14 Patch2:         %{name}-tmp_maps.patch
15 Patch3:         %{name}-python.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  XFree86-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Prereq:         /sbin/chkconfig
20
21 %define         _prefix /usr/X11R6
22 %define         _localstatedir /var/lib
23
24 %description 
25 This is a multiplayer graphical arcade and adventure game made for the
26 X-Window environment. There are also Windows and Java clients
27 available.
28
29 It has certain flavours from other games, especially Gauntlet (TM) and
30 Nethack/Moria.
31
32 Any number of players can move around in their own window, finding and
33 sing items and battle monsters. They can choose to cooperate or
34 compete in the same "world".
35
36 %description -l pl
37 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
38 dostêpni klienci pod Windows i w Javie.
39
40 %package editor
41 Summary:        Crossfire map editor
42 Summary(pl):    Edytor map crossfire
43 Group:          Applications/Games
44
45 %description editor
46 Crossfire map editor.
47
48 %description editor -l pl
49 Edytor map crossfire.
50
51 %package doc
52 Summary:        Crossfire game documentation
53 Summary(pl):    Dokumentacja gry crossfire
54 Group:          Applications/Games
55
56 %description doc
57 Crossfire documentation for players. Includes handbook and spoiler.
58
59 %description doc -l pl
60 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 # don't apply, its unfinished
68 #%patch3 -p1
69 cd lib
70
71 %build
72 autoconf
73 %configure
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d}
79 install -d $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
80 %{__make} install DESTDIR="$RPM_BUILD_ROOT"
81 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/{ban_file,settings,dm_file,motd,forbid} \
82         $RPM_BUILD_ROOT/etc/%{name}
83 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
84 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
85 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
86 touch $RPM_BUILD_ROOT%{_localstatedir}/%{name}/clockdata
87 touch $RPM_BUILD_ROOT/var/log/crossfire
88 rm doc/Developers/Makefile*
89  
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/chkconfig --add crossfire
95 if [ -r /var/lock/subsys/crossfire ]; then
96         /etc/rc.d/init.d/crossfire restart >&2
97 else
98         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
99 fi
100
101 %preun
102 if [ "$1" = "0" ]; then
103         if [ -r /var/lock/subsys/crossfire ]; then
104                 /etc/rc.d/init.d/crossfire stop >&2
105         fi
106         /sbin/chkconfig --del crossfire
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGES CREDITS DEVELOPERS README TODO
112 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
113 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
114 %doc doc/Developers
115 %attr(750,root,games) %{_bindir}/crossfire
116 %attr(750,root,games) %{_bindir}/random_map
117 %dir %attr(750,root,games) %{_datadir}/crossfire
118 %{_datadir}/crossfire/*
119 %{_mandir}/man?/crossfire*
120 %dir %attr(750,root,games) %{_localstatedir}/crossfire
121 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
122 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
123 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
124 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
125 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
126 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
127 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
128 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
129 %dir /etc/crossfire
130 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
131 %attr(754,root,root) /etc/rc.d/init.d/crossfire
132 %attr(660,root,root) /etc/logrotate.d/crossfire
133 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
134 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
135
136 %files editor
137 %defattr(644,root,root,755)
138 %doc doc/Crossedit.doc crossedit/doc/*.doc
139 %attr(755,root,root) %{_bindir}/crossedit
140 %{_mandir}/man?/crossedit*
141
142 %files doc
143 %defattr(644,root,root,755)
144 %doc doc/{handbook.ps,spoiler.ps}
145 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
146 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
This page took 0.036068 seconds and 3 git commands to generate.