]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- formatting
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.5.0
5 Release:        1
6 Group:          Applications/Games
7 License:        GPL
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  b22556499a1aa99a19e6c5c7b33d501f
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-perlpath.patch
14 URL:            http://crossfire.real-time.com/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  autoconf
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       crossfire-maps
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _localstatedir  /var/lib
22
23 %description 
24 This is a multiplayer graphical arcade and adventure game made for the
25 X-Window environment. There are also Windows and Java clients
26 available.
27
28 It has certain flavours from other games, especially Gauntlet (TM) and
29 Nethack/Moria.
30
31 Any number of players can move around in their own window, finding and
32 sing items and battle monsters. They can choose to cooperate or
33 compete in the same "world".
34
35 %description -l pl
36 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
37 dostêpni klienci pod Windows i w Javie.
38
39 %package editor
40 Summary:        Crossfire map editor
41 Summary(pl):    Edytor map crossfire
42 Group:          Applications/Games
43
44 %description editor
45 Crossfire map editor.
46
47 %description editor -l pl
48 Edytor map crossfire.
49
50 %package doc
51 Summary:        Crossfire game documentation
52 Summary(pl):    Dokumentacja gry crossfire
53 Group:          Applications/Games
54
55 %description doc
56 Crossfire documentation for players. Includes handbook and spoiler.
57
58 %description doc -l pl
59 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
60
61 %package plugin-python
62 Summary:        python plugin for crossfire server
63 Group:          Applications/Games
64 Requires:       %{name} = %{version}
65
66 %description plugin-python
67 Python plugin for crossfire server.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__autoconf}
75 %configure
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
81         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
82
83 %{__make} install DESTDIR="$RPM_BUILD_ROOT"
84 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/plugin_python.a
85 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
86 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
87 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
88 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
89 touch $RPM_BUILD_ROOT/var/log/crossfire
90  
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 /sbin/chkconfig --add crossfire
96 if [ -r /var/lock/subsys/crossfire ]; then
97         /etc/rc.d/init.d/crossfire restart >&2
98 else
99         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
100 fi
101
102 %preun
103 if [ "$1" = "0" ]; then
104         if [ -r /var/lock/subsys/crossfire ]; then
105                 /etc/rc.d/init.d/crossfire stop >&2
106         fi
107         /sbin/chkconfig --del crossfire
108 fi
109
110 %files
111 %defattr(644,root,root,755)
112 %doc DEVELOPERS README TODO
113 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
114 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
115 %doc doc/Developers
116 %doc utils/crossloop{,.web,.pl}
117 %attr(750,root,games) %{_bindir}/crossfire
118 %attr(755,root,games) %{_bindir}/crossfire-config
119 %dir %attr(750,root,games) %{_datadir}/crossfire
120 %{_datadir}/crossfire/*
121 %{_mandir}/man?/crossfire*
122 %dir %attr(750,root,games) %{_localstatedir}/crossfire
123 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
124 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
125 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
126 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
127 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
128 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
129 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
130 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
131 %dir /etc/crossfire
132 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
133 %attr(754,root,root) /etc/rc.d/init.d/crossfire
134 %attr(660,root,root) /etc/logrotate.d/crossfire
135 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
136 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
137 %dir %{_libdir}/crossfire
138 %dir %{_libdir}/crossfire/plugins
139 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
140 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
141 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
142 %attr(755,root,root) %{_libdir}/crossfire/random_map
143                      
144 %files editor
145 %defattr(644,root,root,755)
146 %doc crossedit/doc/*.doc
147 %attr(755,root,root) %{_bindir}/crossedit
148 %{_mandir}/man?/crossedit*
149
150 %files doc
151 %defattr(644,root,root,755)
152 %doc doc/{handbook.ps,spoiler.ps}
153 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
154 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
155
156 %files plugin-python
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/crossfire/plugins/plugin_python.*
This page took 0.040229 seconds and 3 git commands to generate.