]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- add Python 2.3.x support to configure
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.6.0
5 Release:        1
6 Group:          Applications/Games
7 License:        GPL
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  cac617806c2430821f8bd918726a66e1
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-python2.3.patch
14 URL:            http://crossfire.real-time.com/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  python-devel >= 2.3
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       crossfire-maps
22 %pyrequires_eq  python
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _localstatedir  /var/lib
26
27 %description
28 This is a multiplayer graphical arcade and adventure game made for the
29 X-Window environment. There are also Windows and Java clients
30 available.
31
32 It has certain flavours from other games, especially Gauntlet (TM) and
33 Nethack/Moria.
34
35 Any number of players can move around in their own window, finding and
36 sing items and battle monsters. They can choose to cooperate or
37 compete in the same "world".
38
39 %description -l pl
40 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
41 dostêpni klienci pod Windows i w Javie.
42
43 %package editor
44 Summary:        Crossfire map editor
45 Summary(pl):    Edytor map Crossfire
46 Group:          Applications/Games
47
48 %description editor
49 Crossfire map editor.
50
51 %description editor -l pl
52 Edytor map Crossfire.
53
54 %package doc
55 Summary:        Crossfire game documentation
56 Summary(pl):    Dokumentacja gry Crossfire
57 Group:          Applications/Games
58
59 %description doc
60 Crossfire documentation for players. Includes handbook and spoiler.
61
62 %description doc -l pl
63 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
64
65 %package plugin-python
66 Summary:        Python plugin for Crossfire server
67 Summary(pl):    Wtyczka Pythona dla serwera Crossfire
68 Group:          Applications/Games
69 Requires:       %{name} = %{version}-%{release}
70
71 %description plugin-python
72 Python plugin for Crossfire server.
73
74 %description plugin-python -l pl
75 Wtyczka Pythona dla serwera Crossfire.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__automake}
86 %configure
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
92         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/plugin_python.a
98 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
99 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
100 rm $RPM_BUILD_ROOT/usr/bin/player_dl.pl
101 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
102 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
103 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
104 touch $RPM_BUILD_ROOT/var/log/crossfire
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /sbin/chkconfig --add crossfire
111 if [ -r /var/lock/subsys/crossfire ]; then
112         /etc/rc.d/init.d/crossfire restart >&2
113 else
114         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
115 fi
116
117 %preun
118 if [ "$1" = "0" ]; then
119         if [ -r /var/lock/subsys/crossfire ]; then
120                 /etc/rc.d/init.d/crossfire stop >&2
121         fi
122         /sbin/chkconfig --del crossfire
123 fi
124
125 %files
126 %defattr(644,root,root,755)
127 %doc DEVELOPERS README TODO ChangeLog
128 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
129 %attr(750,root,games) %{_bindir}/crossfire
130 %attr(755,root,games) %{_bindir}/crossfire-config
131 %dir %attr(750,root,games) %{_datadir}/crossfire
132 %{_datadir}/crossfire/*
133 %{_mandir}/man?/crossfire*
134 %dir %attr(770,root,games) %{_localstatedir}/crossfire
135 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
136 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
137 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
138 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
139 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
140 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
141 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
142 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
143 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/banish_file
144 %dir /etc/crossfire
145 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
146 %attr(754,root,root) /etc/rc.d/init.d/crossfire
147 %attr(660,root,root) /etc/logrotate.d/crossfire
148 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
149 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
150 %dir %{_libdir}/crossfire
151 %dir %{_libdir}/crossfire/plugins
152 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
153 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
154 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
155 %attr(755,root,root) %{_libdir}/crossfire/random_map
156
157 %files editor
158 %defattr(644,root,root,755)
159 %doc crossedit/doc/*.doc
160 %attr(755,root,root) %{_bindir}/crossedit
161 %{_mandir}/man?/crossedit*
162
163 %files doc
164 %defattr(644,root,root,755)
165 %doc doc/{handbook.ps,spoiler.ps}
166 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
167 %doc doc/{skills.doc,spellcasters_guide_to_runes}
168 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
169
170 %files plugin-python
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/crossfire/plugins/plugin_python.*
This page took 0.042177 seconds and 3 git commands to generate.