]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
2cb2995a0d70e9cdca909b56b94d1db7caf44d14
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl.UTF-8):   Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.9.1
5 Release:        2
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  9444daefe1a457b4a18101c255be6cdc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-ac260.patch
14 Patch1:         %{name}-check.patch
15 Patch2:         %{name}-daemon.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  xorg-lib-libX11-devel
18 BuildRequires:  xorg-lib-libXaw-devel
19 BuildRequires:  xorg-lib-libXmu-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  cproto
23 BuildRequires:  libtool
24 BuildRequires:  python-devel >= 1:2.3
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires(post,preun):   /sbin/chkconfig
27 Requires:       crossfire-maps
28 Requires:       rc-scripts
29 %pyrequires_eq  python
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _localstatedir  /var/lib
33
34 %description
35 This is a multiplayer graphical arcade and adventure game made for the
36 X-Window environment. There are also Windows and Java clients
37 available.
38
39 It has certain flavours from other games, especially Gauntlet (TM) and
40 Nethack/Moria.
41
42 Any number of players can move around in their own window, finding and
43 sing items and battle monsters. They can choose to cooperate or
44 compete in the same "world".
45
46 %description -l pl.UTF-8
47 To jest graficzna gra przygodowa dla środowiska X-Window. Są także
48 dostępni klienci pod Windows i w Javie.
49
50 %package editor
51 Summary:        Crossfire map editor
52 Summary(pl.UTF-8):   Edytor map Crossfire
53 Group:          Applications/Games
54
55 %description editor
56 Crossfire map editor.
57
58 %description editor -l pl.UTF-8
59 Edytor map Crossfire.
60
61 %package doc
62 Summary:        Crossfire game documentation
63 Summary(pl.UTF-8):   Dokumentacja gry Crossfire
64 Group:          Documentation
65
66 %description doc
67 Crossfire documentation for players. Includes handbook and spoiler.
68
69 %description doc -l pl.UTF-8
70 Dokumentacja dla graczy Crossfire. Zawiera podręcznik oraz spoiler.
71
72 %package plugin-python
73 Summary:        Python plugin for Crossfire server
74 Summary(pl.UTF-8):   Wtyczka Pythona dla serwera Crossfire
75 Group:          Applications/Games
76 Requires:       %{name} = %{version}-%{release}
77
78 %description plugin-python
79 Python plugin for Crossfire server.
80
81 %description plugin-python -l pl.UTF-8
82 Wtyczka Pythona dla serwera Crossfire.
83
84 %package plugin-anim
85 Summary:        Animation plugin for Crossfire server
86 Summary(pl.UTF-8):   Wtyczka animacji dla serwera Crossfire
87 Group:          Applications/Games
88 Requires:       %{name} = %{version}-%{release}
89
90 %description plugin-anim
91 Animation plugin for Crossfire server.
92
93 %description plugin-anim -l pl.UTF-8
94 Wtyczka animacji dla serwera Crossfire.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 touch include/autoconf.h{,.in}
108 %configure
109 install -d test/include
110 %{__make} -C test/toolkit proto
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
116         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/*.a
122 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
123 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
124 rm $RPM_BUILD_ROOT%{_bindir}/player_dl.pl
125 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
126 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
127 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
128 touch $RPM_BUILD_ROOT/var/log/crossfire
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 /sbin/chkconfig --add crossfire
135 %service crossfire restart "Crossfire server"
136
137 %preun
138 if [ "$1" = "0" ]; then
139         %service crossfire stop
140         /sbin/chkconfig --del crossfire
141 fi
142
143 %files
144 %defattr(644,root,root,755)
145 %doc DEVELOPERS README TODO ChangeLog
146 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
147 %attr(750,root,games) %{_bindir}/crossfire
148 %attr(755,root,games) %{_bindir}/crossfire-config
149 %dir %attr(750,root,games) %{_datadir}/crossfire
150 %{_datadir}/crossfire/*
151 %{_mandir}/man?/crossfire*
152 %dir %attr(770,root,games) %{_localstatedir}/crossfire
153 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
154 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
155 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
156 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
157 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/bookarch
158 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/highscore
159 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/temp.maps
160 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/clockdata
161 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/banish_file
162 %dir %{_sysconfdir}/crossfire
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/crossfire/*
164 %attr(754,root,root) /etc/rc.d/init.d/crossfire
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/crossfire
166 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/crossfire
167 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) /var/log/crossfire
168 %dir %{_libdir}/crossfire
169 %dir %{_libdir}/crossfire/plugins
170 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
171 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
172 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
173 %attr(755,root,root) %{_libdir}/crossfire/random_map
174
175 %files editor
176 %defattr(644,root,root,755)
177 %doc crossedit/doc/*.doc
178 %attr(755,root,root) %{_bindir}/crossedit
179 %{_mandir}/man?/crossedit*
180
181 %files doc
182 %defattr(644,root,root,755)
183 %doc doc/{handbook.ps,spoiler.ps}
184 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
185 %doc doc/{skills.doc,spellcasters_guide_to_runes}
186 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
187
188 %files plugin-python
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfpython.*
191
192 %files plugin-anim
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfanim.*
This page took 0.0278310000000001 seconds and 2 git commands to generate.