]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
2bd8bae7a699472b9f83ae09b223d487af83ad7e
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl.UTF-8):      Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.9.1
5 Release:        10
6 License:        GPL
7 Group:          X11/Applications/Games
8 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
9 # Source0-md5:  9444daefe1a457b4a18101c255be6cdc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-ac260.patch
14 Patch1:         %{name}-check.patch
15 Patch2:         %{name}-daemon.patch
16 Patch3:         %{name}-python.patch
17 URL:            http://crossfire.real-time.com/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  check
21 BuildRequires:  cproto
22 BuildRequires:  libtool
23 BuildRequires:  python-devel >= 1:2.3
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRequires:  xorg-lib-libXaw-devel
27 BuildRequires:  xorg-lib-libXmu-devel
28 Requires(post,preun):   /sbin/chkconfig
29 %pyrequires_eq  python
30 Requires:       crossfire-maps
31 Requires:       rc-scripts
32 Conflicts:      logrotate < 3.8.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _localstatedir  /var/lib
36
37 %description
38 This is a multiplayer graphical arcade and adventure game made for the
39 X-Window environment. There are also Windows and Java clients
40 available.
41
42 It has certain flavours from other games, especially Gauntlet (TM) and
43 Nethack/Moria.
44
45 Any number of players can move around in their own window, finding and
46 sing items and battle monsters. They can choose to cooperate or
47 compete in the same "world".
48
49 %description -l pl.UTF-8
50 To jest graficzna gra przygodowa dla środowiska X-Window. Są także
51 dostępni klienci pod Windows i w Javie.
52
53 %package editor
54 Summary:        Crossfire map editor
55 Summary(pl.UTF-8):      Edytor map Crossfire
56 Group:          X11/Applications/Games
57
58 %description editor
59 Crossfire map editor.
60
61 %description editor -l pl.UTF-8
62 Edytor map Crossfire.
63
64 %package doc
65 Summary:        Crossfire game documentation
66 Summary(pl.UTF-8):      Dokumentacja gry Crossfire
67 Group:          Documentation
68
69 %description doc
70 Crossfire documentation for players. Includes handbook and spoiler.
71
72 %description doc -l pl.UTF-8
73 Dokumentacja dla graczy Crossfire. Zawiera podręcznik oraz spoiler.
74
75 %package plugin-python
76 Summary:        Python plugin for Crossfire server
77 Summary(pl.UTF-8):      Wtyczka Pythona dla serwera Crossfire
78 Group:          X11/Applications/Games
79 Requires:       %{name} = %{version}-%{release}
80
81 %description plugin-python
82 Python plugin for Crossfire server.
83
84 %description plugin-python -l pl.UTF-8
85 Wtyczka Pythona dla serwera Crossfire.
86
87 %package plugin-anim
88 Summary:        Animation plugin for Crossfire server
89 Summary(pl.UTF-8):      Wtyczka animacji dla serwera Crossfire
90 Group:          X11/Applications/Games
91 Requires:       %{name} = %{version}-%{release}
92
93 %description plugin-anim
94 Animation plugin for Crossfire server.
95
96 %description plugin-anim -l pl.UTF-8
97 Wtyczka animacji dla serwera Crossfire.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 touch include/autoconf.h{,.in}
112 %configure
113 install -d test/include
114 %{__make} -C test/toolkit proto
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
120         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 rm $RPM_BUILD_ROOT%{_libdir}/crossfire/plugins/*.a
126 rm $RPM_BUILD_ROOT%{_bindir}/crossloop*
127 rm $RPM_BUILD_ROOT%{_mandir}/*/crossloop*
128 rm $RPM_BUILD_ROOT%{_bindir}/player_dl.pl
129 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
130 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
131 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
132 touch $RPM_BUILD_ROOT/var/log/crossfire
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 /sbin/chkconfig --add crossfire
139 %service crossfire restart "Crossfire server"
140
141 %preun
142 if [ "$1" = "0" ]; then
143         %service crossfire stop
144         /sbin/chkconfig --del crossfire
145 fi
146
147 %files
148 %defattr(644,root,root,755)
149 %doc DEVELOPERS README TODO ChangeLog
150 %doc doc/{alchemy.doc,experience,metaserver,multigod,plugins}
151 %attr(750,root,games) %{_bindir}/crossfire
152 %attr(755,root,games) %{_bindir}/crossfire-config
153 %dir %attr(750,root,games) %{_datadir}/crossfire
154 %{_datadir}/crossfire/*
155 %{_mandir}/man?/crossfire*
156 %dir %attr(770,root,games) %{_localstatedir}/crossfire
157 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
158 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
159 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
160 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
161 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/bookarch
162 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/highscore
163 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/temp.maps
164 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/clockdata
165 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/crossfire/banish_file
166 %dir %{_sysconfdir}/crossfire
167 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/crossfire/*
168 %attr(754,root,root) /etc/rc.d/init.d/crossfire
169 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/crossfire
170 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/crossfire
171 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) /var/log/crossfire
172 %dir %{_libdir}/crossfire
173 %dir %{_libdir}/crossfire/plugins
174 %attr(755,root,root) %{_libdir}/crossfire/add_throw.perl
175 %attr(755,root,root) %{_libdir}/crossfire/metaserver.pl
176 %attr(755,root,root) %{_libdir}/crossfire/mktable.script
177 %attr(755,root,root) %{_libdir}/crossfire/random_map
178
179 %files editor
180 %defattr(644,root,root,755)
181 %doc crossedit/doc/*.doc
182 %attr(755,root,root) %{_bindir}/crossedit
183 %{_mandir}/man?/crossedit*
184
185 %files doc
186 %defattr(644,root,root,755)
187 %doc doc/{handbook.ps,spoiler.ps}
188 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide}
189 %doc doc/{skills.doc,spellcasters_guide_to_runes}
190 %doc doc/spell-docs/{*.txt,spell-list.ps,spell-summary.ps}
191
192 %files plugin-python
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfpython.*
195
196 %files plugin-anim
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/crossfire/plugins/cfanim.*
This page took 0.029569 seconds and 2 git commands to generate.