]> git.pld-linux.org Git - packages/crossfire.git/blame_incremental - crossfire.spec
- more FHS fixes (all config files to /etc/crossfire)
[packages/crossfire.git] / crossfire.spec
... / ...
CommitLineData
1Summary: Multiplayer roguelike game server.
2Name: crossfire
3Version: 0.98.0
4Release: 1
5License: GPL
6Group: Applications/Games
7Source0: ftp://ftp.scruz.net/users/mwedel/public/%{name}-%{version}.tar.bz2
8Source1: %{name}.init
9Source2: %{name}.sysconfig
10Source3: %{name}.logrotate
11Patch0: %{name}-DESTDIR.patch
12Patch1: %{name}-directories.patch
13Patch2: %{name}-tmp_maps.patch
14URL: http://crossfire.real-time.com
15BuildRequires: XFree86-devel
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _prefix /usr/X11R6
19%define _localstatedir /var/lib
20
21%description
22This is a multiplayer graphical arcade and adventure game made for the
23X-Windows environment. There are also Windows and Java clients
24available.
25
26It has certain flavours from other games, especially Gauntlet (TM) and
27Nethack/Moria.
28
29Any number of players can move around in their own window, finding and
30sing items and battle monsters. They can choose to cooperate or
31compete in the same "world".
32
33%package editor
34Summary: Crossfire map editor.
35Group: Applications/Games
36Group(de): Applikationen/Spiele
37Group(pl): Aplikacje/Gry
38
39%description editor
40Crossfire map editor.
41
42%prep
43%setup -q
44%patch0 -p1
45%patch1 -p1
46%patch2 -p1
47
48%build
49%configure
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d}
55install -d $RPM_BUILD_ROOT%{_localstatedir}/%{name}/tmp
56%{__make} install DESTDIR="$RPM_BUILD_ROOT"
57mv $RPM_BUILD_ROOT%{_datadir}/%{name}/{ban_file,settings,dm_file,motd,forbid} \
58 $RPM_BUILD_ROOT/etc/%{name}
59install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
60install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
61install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
62touch $RPM_BUILD_ROOT/var/log/crossfire
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68/sbin/chkconfig --add crossfire
69if [ -r /var/lock/subsys/crossfire ]; then
70 /etc/rc.d/init.d/crossfire restart >&2
71else
72 echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
73fi
74
75%preun
76if [ "$1" = "0" ]; then
77 if [ -r /var/lock/subsys/crossfire ]; then
78 /etc/rc.d/init.d/crossfire stop >&2
79 fi
80 /sbin/chkconfig --del crossfire
81fi
82
83
84
85
86%files
87%defattr(644,root,root,755)
88%doc CHANGES CREDITS DEVELOPERS DONE README TODO
89%doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide,alchemy.doc,experience,multigod}
90%doc doc/{skills.doc,spell-paths,spellcasters_guide_to_runes,spells}
91%attr(750,root,games) %{_bindir}/crossfire
92%attr(750,root,games) %{_bindir}/random_map
93%dir %attr(750,root,games) %{_datadir}/crossfire
94%{_datadir}/crossfire/*
95%{_mandir}/man?/crossfire*
96%dir %attr(750,root,games) %{_localstatedir}/crossfire
97%dir %attr(770,root,games) %{_localstatedir}/crossfire/players
98%dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
99%dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
100%attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
101%attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
102%attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
103%dir /etc/crossfire
104%config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
105%attr(754,root,root) /etc/rc.d/init.d/crossfire
106%attr(660,root,root) /etc/logrotate.d/crossfire
107%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
108%attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
109
110%files editor
111%defattr(644,root,root,755)
112%doc doc/{Crossedit.doc,RandomMaps.doc,Styles.doc,mapguide,mapmakers_guide_to_runes,teleporter.doc}
113%attr(755,root,root) %{_bindir}/crossedit
114%{_mandir}/man?/crossedit*
This page took 0.055585 seconds and 4 git commands to generate.