]> git.pld-linux.org Git - packages/crossfire-client.git/commitdiff
- allow disabling dmalloc support
authorArtur Frysiak <artur@frysiak.net>
Mon, 10 Mar 2003 14:05:11 +0000 (14:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- detect errno.h and include if present

Changed files:
    crossfire-client-dmalloc.patch -> 1.1
    crossfire-client-errno.patch -> 1.1

crossfire-client-dmalloc.patch [new file with mode: 0644]
crossfire-client-errno.patch [new file with mode: 0644]

diff --git a/crossfire-client-dmalloc.patch b/crossfire-client-dmalloc.patch
new file mode 100644 (file)
index 0000000..a5de5a7
--- /dev/null
@@ -0,0 +1,34 @@
+--- crossfire-client-1.5.0/configure.in.wiget  Mon Mar 10 14:26:56 2003
++++ crossfire-client-1.5.0/configure.in        Mon Mar 10 14:44:40 2003
+@@ -74,6 +74,9 @@
+                 use_sdl=no, use_sdl=yes)
++AC_ARG_ENABLE(dmalloc, [  --enable-dmalloc           Use dmalloc to debug memory allocations [default=yes]],
++                  , enable_dmalloc=yes)
++
+ AC_PROG_CC
+ AC_C_BIGENDIAN
+@@ -308,14 +311,17 @@
+ AC_CHECK_LIB(png, main, , [AC_MSG_ERROR([You must have the png library installed to compile the client])])
+-dnl not strictly needed, but since the X11 client uses it, lets use it here
+-AC_CHECK_LIB(dmalloc, main, DMALLOC_LIB="-ldmalloc")
+-
++DMALLOC_LIB=
++if eval "test x$enable_dmalloc = xyes"; then
++      dnl not strictly needed, but since the X11 client uses it, lets use it here
++      AC_CHECK_LIB(dmalloc, main, DMALLOC_LIB="-ldmalloc")
++      AC_CHECK_HEADERS(dmalloc.h)
++fi
+ AC_SUBST(DMALLOC_LIB)
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h string.h sys/select.h dmalloc.h)
++AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h string.h sys/select.h)
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/crossfire-client-errno.patch b/crossfire-client-errno.patch
new file mode 100644 (file)
index 0000000..fb14ef9
--- /dev/null
@@ -0,0 +1,34 @@
+--- crossfire-client-1.5.0/gtk/gx11.c.errno    Tue Feb 25 08:49:40 2003
++++ crossfire-client-1.5.0/gtk/gx11.c  Mon Mar 10 14:51:12 2003
+@@ -64,7 +64,7 @@
+ #include "config.h"
+-#ifdef __CYGWIN__
++#ifdef HAVE_ERRNO_H
+ #include <errno.h>
+ #endif
+--- crossfire-client-1.5.0/common/config.h.in.errno    Tue Feb 25 08:49:40 2003
++++ crossfire-client-1.5.0/common/config.h.in  Mon Mar 10 14:56:15 2003
+@@ -66,6 +66,9 @@
+ /* Define if you have the <unistd.h> header file.  */
+ #undef HAVE_UNISTD_H
++/* Define if you have the <errno.h> header file.  */
++#undef HAVE_ERRNO_H
++
+ /* Define if you have the m library (-lm).  */
+ #undef HAVE_LIBM
+--- crossfire-client-1.5.0/configure.in.errno  Mon Mar 10 14:52:40 2003
++++ crossfire-client-1.5.0/configure.in        Mon Mar 10 14:52:52 2003
+@@ -321,7 +321,7 @@
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h string.h sys/select.h)
++AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h string.h sys/select.h errno.h)
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
This page took 0.089993 seconds and 4 git commands to generate.