]> git.pld-linux.org Git - packages/crossdjgpp-platform.git/blob - crossdjgpp-platform.spec
- unified
[packages/crossdjgpp-platform.git] / crossdjgpp-platform.spec
1 Summary:        DJGPP GNU Binary Utility Development Utilities - libraries
2 Summary(pl.UTF-8):      Narzędzia programistyczne GNU DJGPP - biblioteki
3 Name:           crossdjgpp-platform
4 Version:        203
5 Release:        2
6 Epoch:          1
7 License:        GPL
8 Group:          Development/Libraries
9 Source0:        http://www.delorie.com/pub/djgpp/current/v2/djcrx%{version}.zip
10 # Source0-md5:  dbaceb26365a14e702f2e1c9def16afc
11 URL:            http://www.delorie.com/djgpp/
12 BuildRequires:  unzip
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         target          i386-pc-msdosdjgpp
16 %define         arch            %{_prefix}/%{target}
17 %define         no_install_post_strip   1
18
19 %description
20 DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
21 Gnu Programming Platform, if it has to stand for something, but it's
22 best left ambiguous.)
23
24 This package contains DOS API includes and libraries.
25
26 %description -l pl.UTF-8
27 DJGPP to port GNU GCC dla środowiska DOS (skrót oznacza DJ's Gnu
28 Programming Platform, jeśli już koniecznie ma coś oznaczać).
29
30 Ten pakiet zawiera pliki nagłówkowe i biblioteki DOS API.
31
32 %prep
33 %setup -q -c -T -n djcrx-%{version}
34 unzip -a %{SOURCE0} > /dev/null
35
36 %build
37 %{__cc} %{rpmcflags} -o stubify src/stub/stubify.c
38 %{__cc} %{rpmcflags} -o stubedit src/stub/stubedit.c
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 install -d $RPM_BUILD_ROOT{%{_infodir},%{arch}/{include,lib,bin},%{_bindir}}
44 cp -fa include/* $RPM_BUILD_ROOT%{arch}/include
45 cp -fa lib/* $RPM_BUILD_ROOT%{arch}/lib
46 # required by linker... strange
47 ln -sf ../lib/djgpp.djl $RPM_BUILD_ROOT%{arch}/bin
48
49 ( cat <<EOF
50 This is foobarbaz.
51
52 INFO-DIR-SECTION Libraries:
53 START-INFO-DIR-ENTRY
54 * DJGPP Libc: (djgpp-libc)              Libc for cross-djgpp
55 END-INFO-DIR-ENTRY
56 EOF
57   cat info/libc.info ) | \
58         sed -e 's/libc\.info/djgpp-libc.info/g' \
59                 > $RPM_BUILD_ROOT%{_infodir}/djgpp-libc.info
60
61 install stubify stubedit $RPM_BUILD_ROOT%{_bindir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/postshell
67 -/usr/sbin/fix-info-dir -c %{_infodir}
68
69 %postun -p /sbin/postshell
70 -/usr/sbin/fix-info-dir -c %{_infodir}
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/stubedit
75 %attr(755,root,root) %{_bindir}/stubify
76 %dir %{arch}
77 %{arch}/bin
78 %{arch}/include
79 %{arch}/lib
80 %{_infodir}/djgpp-libc.info*
This page took 0.060795 seconds and 3 git commands to generate.