]> git.pld-linux.org Git - packages/crossdjgpp-gcc.git/blobdiff - crossdjgpp-gcc.spec
- mass commit; now req: name = epoch:version
[packages/crossdjgpp-gcc.git] / crossdjgpp-gcc.spec
index 051d5550d29735f86ecddf0e7f44ef3916cf68b6..7f19882f9f47210415f05bdde99a239bf631ea76 100644 (file)
@@ -1,13 +1,13 @@
 Summary:       DJGPP GNU Binary Utility Development Utilities - gcc
+Summary(pl):   Narzêdzia programistyczne GNU DJGPP - gcc
 Name:          crossdjgpp-gcc
 Version:       3.0.3
 Release:       1
 Epoch:         1
 License:       GPL
 Group:         Development/Languages
-Group(de):     Entwicklung/Sprachen
-Group(pl):     Programowanie/Jêzyki
-Source0:       ftp://ftp.gnu.org/pub/gnu/gcc-%{version}.tar.bz2
+Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
+# Source0-md5: d94d66619d69d9fd27717409c8a67740
 BuildRequires: crossdjgpp-platform
 BuildRequires: crossdjgpp-binutils
 BuildRequires: flex
@@ -26,50 +26,65 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
 
 %description
-DJGPP is a port of GNU GCC to the DOS environment. (It stands for
-DJ's Gnu Programming Platform, if it has to stand for something, but
-it's best left ambiguous.)
+DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
+Gnu Programming Platform, if it has to stand for something, but it's
+best left ambiguous.)
 
 This package contains cross targeted gcc.
 
-%if %{cxx}
+%description -l pl
+DJGPP to port GNU GCC dla ¶rodowiska DOS (skrót oznacza DJ's Gnu
+Programming Platform, je¶li ju¿ koniecznie ma co¶ oznaczaæ).
+
+Ten pakiet zawiera gcc skompilowane jako kroskompilator.
+
 %package c++
 Summary:       DJGPP GNU Binary Utility Development Utilities - g++
+Summary(pl):   Narzêdzia programistyczne GNU DJGPP - g++
 Group:         Development/Languages
-Group(de):     Entwicklung/Sprachen
-Group(pl):     Programowanie/Jêzyki
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}
 
 %description c++
-DJGPP is a port of GNU GCC to the DOS environment. (It stands for
-DJ's Gnu Programming Platform, if it has to stand for something, but
-it's best left ambiguous.)
+DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
+Gnu Programming Platform, if it has to stand for something, but it's
+best left ambiguous.)
 
 This package contains cross targeted g++ and (static) libstdc++.
-%endif
+
+%description c++ -l pl
+DJGPP to port GNU GCC dla ¶rodowiska DOS (skrót oznacza DJ's Gnu
+Programming Platform, je¶li ju¿ koniecznie ma co¶ oznaczaæ).
+
+Ten pakiet zawiera g++ skompilowane jako kroskompilator oraz
+(statyczne) libstdc++.
 
 # does this even work?
 %package g77
 Summary:       DJGPP GNU Binary Utility Development Utilities - g77
+Summary(pl):   Narzêdzia programistyczne GNU DJGPP - g77
 Group:         Development/Languages
-Group(de):     Entwicklung/Sprachen
-Group(pl):     Programowanie/Jêzyki
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}
 
 %description g77
-DJGPP is a port of GNU GCC to the DOS environment. (It stands for
-DJ's Gnu Programming Platform, if it has to stand for something, but
-it's best left ambiguous.)
+DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
+Gnu Programming Platform, if it has to stand for something, but it's
+best left ambiguous.)
 
 This package contains cross targeted g77.
 
+%description g77 -l pl
+DJGPP to port GNU GCC dla ¶rodowiska DOS (skrót oznacza DJ's Gnu
+Programming Platform, je¶li ju¿ koniecznie ma co¶ oznaczaæ).
+
+Ten pakiet zawiera g77 skompilowane jako kroskompilator.
+
 %prep
 %setup -q -n gcc-%{version}
 
 %build
-rm -rf obj-%{target} 
+rm -rf obj-%{target}
 install -d obj-%{target}
-cd obj-%{target} 
+cd obj-%{target}
 
 CFLAGS="%{rpmcflags}" \
 CXXFLAGS="%{rpmcflags}" \
@@ -92,15 +107,15 @@ TEXCONFIG=false ../configure \
 # kluge, we already have full system headers and libraries ready,
 # needed to get right limits.h
 cd gcc
-cp Makefile Makefile.new
-sed -e "s|^SYSTEM_HEADER_DIR.*|SYSTEM_HEADER_DIR := /usr/%{target}/include|" \
+cp -f Makefile Makefile.new
+sed -e "s|^SYSTEM_HEADER_DIR.*|SYSTEM_HEADER_DIR := %{_prefix}/%{target}/include|" \
        Makefile.new > Makefile
 rm -f Makefile.new
 cd ..
 
 # YAK (Yet Another Kluge) :<
 cd ../libstdc++-v3
-cp configure configure.tmp
+cp -f configure configure.tmp
 # don't use newlib, we want djgpp
 sed -e 's|os_include_dir="config/os/newlib"|#&|' configure.tmp > configure
 cd ../obj-%{target}
@@ -112,7 +127,7 @@ cd ..
 #LDFLAGS_FOR_TARGET="%{rpmldflags}"
 
 %{__make} -C obj-%{target}
-       
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_bindir}}
@@ -136,7 +151,7 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
 # the same... make hardlink
 #ln -f $RPM_BUILD_ROOT%{arch}/bin/gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
 
-%{target}-strip -g $RPM_BUILD_ROOT/%{gcclib}/libgcc.a
+%{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -149,27 +164,27 @@ rm -rf $RPM_BUILD_ROOT
 #%attr(755,root,root) %{arch}/bin/cpp
 #%attr(755,root,root) %{arch}/bin/gcc
 #%attr(755,root,root) %{arch}/bin/gcov
-#%{arch}/include/_G_config.h
+#%%{arch}/include/_G_config.h
 %dir %{gccarch}
 %dir %{gcclib}
 %attr(755,root,root) %{gcclib}/cc1
 %attr(755,root,root) %{gcclib}/tradcpp0
 %attr(755,root,root) %{gcclib}/cpp0
 %attr(755,root,root) %{gcclib}/collect2
-#%{gcclib}/SYSCALLS.c.X
+#%%{gcclib}/SYSCALLS.c.X
 %{gcclib}/libgcc.a
 %{gcclib}/specs*
 %dir %{gcclib}/include
 %{gcclib}/include/*.h
-#%{gcclib}/include/iso646.h
-#%{gcclib}/include/limits.h
-#%{gcclib}/include/proto.h
-#%{gcclib}/include/stdarg.h
-#%{gcclib}/include/stdbool.h
-#%{gcclib}/include/stddef.h
-#%{gcclib}/include/syslimits.h
-#%{gcclib}/include/varargs.h
-#%{gcclib}/include/va-*.h
+#%%{gcclib}/include/iso646.h
+#%%{gcclib}/include/limits.h
+#%%{gcclib}/include/proto.h
+#%%{gcclib}/include/stdarg.h
+#%%{gcclib}/include/stdbool.h
+#%%{gcclib}/include/stddef.h
+#%%{gcclib}/include/syslimits.h
+#%%{gcclib}/include/varargs.h
+#%%{gcclib}/include/va-*.h
 %{_mandir}/man1/%{target}-gcc.1*
 
 %if %{cxx}
This page took 0.098377 seconds and 4 git commands to generate.