]> git.pld-linux.org Git - packages/crossavr-gdb.git/blobdiff - gdb-readline.patch
- try to direct load before searching in specific dirs.
[packages/crossavr-gdb.git] / gdb-readline.patch
index 89dd8f732ccac52794c7594c3851b47a3cf7d6c4..dae9bc8bce1ae1cb060aaeac94e3496fae06b092 100644 (file)
@@ -1,75 +1,19 @@
-diff -ur gdb-5.1.orig/Makefile.in gdb-5.1/Makefile.in
---- gdb-5.1.orig/Makefile.in   Sun Nov 18 20:37:49 2001
-+++ gdb-5.1/Makefile.in        Tue Jan 22 23:52:34 2002
-@@ -530,7 +530,6 @@
-       all-perl \
-       all-prms \
-       all-rcs \
--      all-readline \
-       all-release \
-       all-recode \
-       all-sed \
-@@ -607,7 +606,6 @@
-       check-perl \
-       check-prms \
-       check-rcs \
--      check-readline \
-       check-recode \
-       check-sed \
-       check-send-pr \
-@@ -684,7 +682,6 @@
-       install-perl \
-       install-prms \
-       install-rcs \
--      install-readline \
-       install-recode \
-       install-sed \
-       install-send-pr \
-@@ -886,7 +883,6 @@
-       clean-perl \
-       clean-prms \
-       clean-rcs \
--      clean-readline \
-       clean-release \
-       clean-recode \
-       clean-sed \
-@@ -1602,7 +1598,7 @@
- all-gcc: all-bison all-byacc all-binutils all-gas all-ld all-zlib
- all-bootstrap: all-libiberty all-texinfo all-bison all-byacc all-binutils all-gas all-ld all-zlib
- GDB_TK = all-tk all-tcl all-itcl all-tix all-libgui
--all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-readline all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
-+all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
- all-gettext:
- all-gnuserv:
- configure-target-gperf: $(ALL_GCC_C)
-@@ -1662,13 +1658,12 @@
- configure-target-qthreads: $(ALL_GCC_C)
- all-target-qthreads: configure-target-qthreads
- all-rcs:
--all-readline:
- all-recode: all-libiberty
- all-sed: all-libiberty
- all-send-pr: all-prms
- all-shellutils:
- all-sid: all-tcl all-tk
--all-sim: all-libiberty all-bfd all-opcodes all-readline all-cgen
-+all-sim: all-libiberty all-bfd all-opcodes all-cgen
- all-snavigator: all-tcl all-tk all-itcl all-db all-grep all-libgui
- all-tar: all-libiberty
- all-tcl:
-@@ -1925,7 +1920,7 @@
-               SUPPORT_FILES="$(GNATS_SUPPORT_DIRS)"
+diff -urN gdb-6.0.org/gdb/gdbserver/Makefile.in gdb-6.0/gdb/gdbserver/Makefile.in
+--- gdb-6.0.org/gdb/gdbserver/Makefile.in      2003-10-09 19:42:41.000000000 +0200
++++ gdb-6.0/gdb/gdbserver/Makefile.in  2003-10-09 19:48:08.000000000 +0200
+@@ -76,7 +76,7 @@
  
- .PHONY: gdb.tar.bz2
--GDB_SUPPORT_DIRS= bfd include libiberty mmalloc opcodes readline sim utils intl
-+GDB_SUPPORT_DIRS= bfd include libiberty mmalloc opcodes sim utils intl
- gdb.tar.bz2: $(DIST_SUPPORT) $(GDB_SUPPORT_DIRS) gdb
-       $(MAKE) -f Makefile.in gdb-taz TOOL=gdb \
-               MD5PROG="$(MD5PROG)" \
-diff -ur gdb-5.1.orig/gdb/Makefile.in gdb-5.1/gdb/Makefile.in
---- gdb-5.1.orig/gdb/Makefile.in       Sun Nov 18 06:08:36 2001
-+++ gdb-5.1/gdb/Makefile.in    Tue Jan 22 23:54:56 2002
-@@ -120,10 +120,10 @@
+ # Where is the source dir for the READLINE library?  Traditionally in .. or .
+ # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
+-READLINE_DIR = ${srcdir}/../readline
++READLINE_DIR = /usr/lib
+ READLINE_DEP = $$(READLINE_DIR)
+ # All the includes used for CFLAGS and for lint.
+diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
+--- gdb-6.0.org/gdb/Makefile.in        2003-10-09 19:42:39.000000000 +0200
++++ gdb-6.0/gdb/Makefile.in    2003-10-09 19:48:08.000000000 +0200
+@@ -116,10 +116,10 @@
  BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
  
  # Where is the READLINE library?  Typically in ../readline.
@@ -84,141 +28,158 @@ diff -ur gdb-5.1.orig/gdb/Makefile.in gdb-5.1/gdb/Makefile.in
  
  WARN_CFLAGS = @WARN_CFLAGS@
  WERROR_CFLAGS = @WERROR_CFLAGS@
-diff -ur gdb-5.1.orig/gdb/defs.h gdb-5.1/gdb/defs.h
---- gdb-5.1.orig/gdb/defs.h    Thu Aug  2 23:36:51 2001
-+++ gdb-5.1/gdb/defs.h Tue Jan 22 23:59:50 2002
-@@ -800,7 +800,7 @@
- /* From readline (but not in any readline .h files).  */
--extern char *tilde_expand (char *);
-+extern char *tilde_expand (const char *);
- /* Control types for commands */
-diff -ur gdb-5.1.orig/gdb/event-top.c gdb-5.1/gdb/event-top.c
---- gdb-5.1.orig/gdb/event-top.c       Sat Jul 14 20:59:07 2001
-+++ gdb-5.1/gdb/event-top.c    Tue Jan 22 23:59:50 2002
-@@ -32,6 +32,7 @@
- #include "gdbcmd.h"
- /* readline include files */
-+#define savestring
- #include <readline/readline.h>
- #include <readline/history.h>
-diff -ur gdb-5.1.orig/gdb/gdbserver/Makefile.in gdb-5.1/gdb/gdbserver/Makefile.in
---- gdb-5.1.orig/gdb/gdbserver/Makefile.in     Tue Mar  6 09:21:43 2001
-+++ gdb-5.1/gdb/gdbserver/Makefile.in  Tue Jan 22 23:59:50 2002
-@@ -88,7 +88,7 @@
- # Where is the source dir for the READLINE library?  Traditionally in .. or .
- # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
--READLINE_DIR = ${srcdir}/../readline
-+READLINE_DIR = /usr/lib
- READLINE_DEP = $$(READLINE_DIR)
- # All the includes used for CFLAGS and for lint.
-diff -ur gdb-5.1.orig/gdb/top.c gdb-5.1/gdb/top.c
---- gdb-5.1.orig/gdb/top.c     Sun Oct 21 21:41:19 2001
-+++ gdb-5.1/gdb/top.c  Tue Jan 22 23:59:50 2002
-@@ -42,6 +42,7 @@
- #include "serial.h"
- /* readline include files */
-+#define savestring
- #include <readline/readline.h>
- #include <readline/history.h>
-diff -ur gdb-5.1.orig/gdb/tracepoint.c gdb-5.1/gdb/tracepoint.c
---- gdb-5.1.orig/gdb/tracepoint.c      Thu Aug  2 14:05:57 2001
-+++ gdb-5.1/gdb/tracepoint.c   Tue Jan 22 23:59:50 2002
-@@ -40,6 +40,7 @@
- #include "ax-gdb.h"
- /* readline include files */
-+#define savestring
- #include <readline/readline.h>
- #include <readline/history.h>
-diff -ur gdb-5.1.orig/gdb/utils.c gdb-5.1/gdb/utils.c
---- gdb-5.1.orig/gdb/utils.c   Fri Nov  2 23:06:29 2001
-+++ gdb-5.1/gdb/utils.c        Tue Jan 22 23:59:50 2002
-@@ -54,6 +54,7 @@
- #include "inferior.h" /* for signed_pointer_to_address */
-+#define savestring
- #include <readline/readline.h>
- #ifndef MALLOC_INCOMPATIBLE
---- gdb-5.1.1/gdb/tui/tuiWin.c.orig    Sat Jul 28 21:30:54 2001
-+++ gdb-5.1.1/gdb/tui/tuiWin.c Sat Feb  2 15:19:33 2002
-@@ -619,10 +619,10 @@
- tuiResizeAll (void)
- {
-   int heightDiff, widthDiff;
--  extern int screenheight, screenwidth;               /* in readline */
-+  extern int _rl_screenheight, _rl_screenwidth;               /* in readline */
--  widthDiff = screenwidth - termWidth ();
--  heightDiff = screenheight - termHeight ();
-+  widthDiff = _rl_screenwidth - termWidth ();
-+  heightDiff = _rl_screenheight - termHeight ();
-   if (heightDiff || widthDiff)
-     {
-       TuiLayoutType curLayout = currentLayout ();
-@@ -636,8 +636,8 @@
-       if (winWithFocus != cmdWin)
-       keypad (cmdWin->generic.handle, FALSE);
-       init_page_info ();
--      setTermHeightTo (screenheight);
--      setTermWidthTo (screenwidth);
-+      setTermHeightTo (_rl_screenheight);
-+      setTermWidthTo (_rl_screenwidth);
-       if (curLayout == SRC_DISASSEM_COMMAND ||
-       curLayout == SRC_DATA_COMMAND || curLayout == DISASSEM_DATA_COMMAND)
-       numWinsDisplayed++;
-@@ -664,8 +664,8 @@
-         if (heightDiff == 0)
-           newHeight = firstWin->generic.height;
-         else if ((firstWin->generic.height + splitDiff) >=
--                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
--          newHeight = screenheight - MIN_CMD_WIN_HEIGHT - 1;
-+                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
-+          newHeight = _rl_screenheight - MIN_CMD_WIN_HEIGHT - 1;
-         else if ((firstWin->generic.height + splitDiff) <= 0)
-           newHeight = MIN_WIN_HEIGHT;
-         else
-@@ -674,7 +674,7 @@
-         _makeInvisibleAndSetNewHeight (firstWin, newHeight);
-         cmdWin->generic.origin.y = locator->origin.y + 1;
-         cmdWin->generic.width += widthDiff;
--        newHeight = screenheight - cmdWin->generic.origin.y;
-+        newHeight = _rl_screenheight - cmdWin->generic.origin.y;
-         _makeInvisibleAndSetNewHeight (cmdWin, newHeight);
-         _makeVisibleWithNewHeight (firstWin);
-         _makeVisibleWithNewHeight (cmdWin);
-@@ -702,8 +702,8 @@
-           newHeight = firstWin->generic.height;
-         else if ((firstWin->generic.height +
-                   secondWin->generic.height + (splitDiff * 2)) >=
--                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
--          newHeight = (screenheight - MIN_CMD_WIN_HEIGHT - 1) / 2;
-+                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
-+          newHeight = (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1) / 2;
-         else if ((firstWin->generic.height + splitDiff) <= 0)
-           newHeight = MIN_WIN_HEIGHT;
-         else
-@@ -722,9 +722,9 @@
-           newHeight = secondWin->generic.height;
-         else if ((firstWin->generic.height +
-                   secondWin->generic.height + (splitDiff * 2)) >=
--                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
-+                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
-           {
--            newHeight = screenheight - MIN_CMD_WIN_HEIGHT - 1;
-+            newHeight = _rl_screenheight - MIN_CMD_WIN_HEIGHT - 1;
-             if (newHeight % 2)
-               newHeight = (newHeight / 2) + 1;
-             else
+@@ -369,7 +369,7 @@
+       $(XM_CLIBS) $(TM_CLIBS) $(NAT_CLIBS) $(GDBTKLIBS) @LIBS@ \
+       $(LIBICONV) \
+       $(LIBIBERTY) $(WIN32LIBS)
+-CDEPS = $(XM_CDEPS) $(TM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE) \
++CDEPS = $(XM_CDEPS) $(TM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) \
+       $(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS)
+ ADD_FILES = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
+--- gdb-6.5/Makefile.in.orig   2006-06-21 07:14:44.000000000 +0200
++++ gdb-6.5/Makefile.in        2006-06-22 15:57:50.144440000 +0200
+@@ -598,7 +598,6 @@
+     maybe-configure-perl \
+     maybe-configure-prms \
+     maybe-configure-rcs \
+-    maybe-configure-readline \
+     maybe-configure-release \
+     maybe-configure-recode \
+     maybe-configure-sed \
+@@ -740,7 +739,6 @@
+ all-host: maybe-all-perl
+ all-host: maybe-all-prms
+ all-host: maybe-all-rcs
+-all-host: maybe-all-readline
+ all-host: maybe-all-release
+ all-host: maybe-all-recode
+ all-host: maybe-all-sed
+@@ -851,7 +849,6 @@
+ info-host: maybe-info-perl
+ info-host: maybe-info-prms
+ info-host: maybe-info-rcs
+-info-host: maybe-info-readline
+ info-host: maybe-info-release
+ info-host: maybe-info-recode
+ info-host: maybe-info-sed
+@@ -955,7 +952,6 @@
+ dvi-host: maybe-dvi-perl
+ dvi-host: maybe-dvi-prms
+ dvi-host: maybe-dvi-rcs
+-dvi-host: maybe-dvi-readline
+ dvi-host: maybe-dvi-release
+ dvi-host: maybe-dvi-recode
+ dvi-host: maybe-dvi-sed
+@@ -1059,7 +1055,6 @@
+ html-host: maybe-html-perl
+ html-host: maybe-html-prms
+ html-host: maybe-html-rcs
+-html-host: maybe-html-readline
+ html-host: maybe-html-release
+ html-host: maybe-html-recode
+ html-host: maybe-html-sed
+@@ -1163,7 +1158,6 @@
+ TAGS-host: maybe-TAGS-perl
+ TAGS-host: maybe-TAGS-prms
+ TAGS-host: maybe-TAGS-rcs
+-TAGS-host: maybe-TAGS-readline
+ TAGS-host: maybe-TAGS-release
+ TAGS-host: maybe-TAGS-recode
+ TAGS-host: maybe-TAGS-sed
+@@ -1267,7 +1261,6 @@
+ install-info-host: maybe-install-info-perl
+ install-info-host: maybe-install-info-prms
+ install-info-host: maybe-install-info-rcs
+-install-info-host: maybe-install-info-readline
+ install-info-host: maybe-install-info-release
+ install-info-host: maybe-install-info-recode
+ install-info-host: maybe-install-info-sed
+@@ -1371,7 +1364,6 @@
+ install-html-host: maybe-install-html-perl
+ install-html-host: maybe-install-html-prms
+ install-html-host: maybe-install-html-rcs
+-install-html-host: maybe-install-html-readline
+ install-html-host: maybe-install-html-release
+ install-html-host: maybe-install-html-recode
+ install-html-host: maybe-install-html-sed
+@@ -1475,7 +1467,6 @@
+ installcheck-host: maybe-installcheck-perl
+ installcheck-host: maybe-installcheck-prms
+ installcheck-host: maybe-installcheck-rcs
+-installcheck-host: maybe-installcheck-readline
+ installcheck-host: maybe-installcheck-release
+ installcheck-host: maybe-installcheck-recode
+ installcheck-host: maybe-installcheck-sed
+@@ -1579,7 +1570,6 @@
+ mostlyclean-host: maybe-mostlyclean-perl
+ mostlyclean-host: maybe-mostlyclean-prms
+ mostlyclean-host: maybe-mostlyclean-rcs
+-mostlyclean-host: maybe-mostlyclean-readline
+ mostlyclean-host: maybe-mostlyclean-release
+ mostlyclean-host: maybe-mostlyclean-recode
+ mostlyclean-host: maybe-mostlyclean-sed
+@@ -1683,7 +1673,6 @@
+ clean-host: maybe-clean-perl
+ clean-host: maybe-clean-prms
+ clean-host: maybe-clean-rcs
+-clean-host: maybe-clean-readline
+ clean-host: maybe-clean-release
+ clean-host: maybe-clean-recode
+ clean-host: maybe-clean-sed
+@@ -1787,7 +1776,6 @@
+ distclean-host: maybe-distclean-perl
+ distclean-host: maybe-distclean-prms
+ distclean-host: maybe-distclean-rcs
+-distclean-host: maybe-distclean-readline
+ distclean-host: maybe-distclean-release
+ distclean-host: maybe-distclean-recode
+ distclean-host: maybe-distclean-sed
+@@ -1891,7 +1879,6 @@
+ maintainer-clean-host: maybe-maintainer-clean-perl
+ maintainer-clean-host: maybe-maintainer-clean-prms
+ maintainer-clean-host: maybe-maintainer-clean-rcs
+-maintainer-clean-host: maybe-maintainer-clean-readline
+ maintainer-clean-host: maybe-maintainer-clean-release
+ maintainer-clean-host: maybe-maintainer-clean-recode
+ maintainer-clean-host: maybe-maintainer-clean-sed
+@@ -2050,7 +2037,6 @@
+     maybe-check-perl \
+     maybe-check-prms \
+     maybe-check-rcs \
+-    maybe-check-readline \
+     maybe-check-release \
+     maybe-check-recode \
+     maybe-check-sed \
+@@ -2180,7 +2166,6 @@
+     maybe-install-perl \
+     maybe-install-prms \
+     maybe-install-rcs \
+-    maybe-install-readline \
+     maybe-install-release \
+     maybe-install-recode \
+     maybe-install-sed \
+@@ -2251,7 +2236,6 @@
+     maybe-install-perl \
+     maybe-install-prms \
+     maybe-install-rcs \
+-    maybe-install-readline \
+     maybe-install-release \
+     maybe-install-recode \
+     maybe-install-sed \
+@@ -40764,7 +40748,6 @@
+ all-gdb: maybe-all-libiberty
+ all-gdb: maybe-all-opcodes
+ all-gdb: maybe-all-bfd
+-all-gdb: maybe-all-readline
+ all-gdb: maybe-all-build-bison
+ all-gdb: maybe-all-build-byacc
+ all-gdb: maybe-all-sim
+@@ -40993,7 +40976,6 @@
+ all-sim: maybe-all-libiberty
+ all-sim: maybe-all-bfd
+ all-sim: maybe-all-opcodes
+-all-sim: maybe-all-readline
+ all-sim: maybe-configure-gdb
+ all-fastjar: maybe-all-zlib
+ all-fastjar: maybe-all-build-texinfo
This page took 0.079295 seconds and 4 git commands to generate.