]> git.pld-linux.org Git - packages/crossavr-gdb.git/blame - crossavr-gdb.spec
- updated to 6.6, reordered patches
[packages/crossavr-gdb.git] / crossavr-gdb.spec
CommitLineData
f6fdc30b 1Summary: A GNU source-level debugger for C, C++ and Fortran
3e4fa848
ER
2Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
3Summary(es.UTF-8): Depurador de programas C y otras lenguajes
4Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
5Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
6Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
7Summary(ru.UTF-8): Символический отладчик для C и других языков
8Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
9Summary(uk.UTF-8): Символьний відладчик для С та інших мов
10Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
11Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
f6fdc30b 12Name: crossavr-gdb
dc0c373a 13Version: 6.6
14Release: 1
f6fdc30b
AM
15License: GPL
16Group: Development/Debuggers
0da9cde4 17Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
dc0c373a 18# Source0-md5: a4df41d28dd514d64e8ccbfe125fd9a6
19Patch0: gdb-readline.patch
20Patch1: gdb-info.patch
21Patch2: gdb-passflags.patch
f6fdc30b
AM
22BuildRequires: XFree86-devel
23BuildRequires: autoconf >= 2.53
24BuildRequires: automake
25BuildRequires: libtool
26BuildRequires: ncurses-devel >= 5.2
27BuildRequires: readline-devel >= 4.2
03160ba6 28BuildRequires: texinfo
913366b2 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f6fdc30b 30
68687887 31%define target avr
f6fdc30b
AM
32
33%description
34Gdb is a full featured, command driven debugger. Gdb allows you to
35trace the execution of programs and examine their internal state at
36any time. Gdb works for C and C++ compiled with the GNU C compiler
37gcc.
38
14ab84e5
JR
39%description -l de.UTF-8
40dem Sie die Ausführung von Programmen verfolgen und jederzeit den
41inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
f6fdc30b
AM
42kompiliertes C++.
43
14ab84e5
JR
44%description -l es.UTF-8
45Este es un depurador orientado a comandos repleto de características.
46Te permite rastrear la ejecución de programas y examinar su estado
f6fdc30b
AM
47interno a cualquier momento. Funciona para C y C++ compilado con el
48compilador GNU C.
49
14ab84e5
JR
50%description -l fr.UTF-8
51Débugger complet, piloté par commandes. Permet de tracer l'exécution
52des programmes et d'examiner à tout moment leur état interne.
53Fonctionne avec les binaires C et C++ compilés avec le compilateur C
f6fdc30b
AM
54de GNU, gcc.
55
14ab84e5
JR
56%description -l pl.UTF-8
57Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
58śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
59umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
f6fdc30b
AM
60przy pomocy kompilatora GNU (gcc).
61
14ab84e5
JR
62%description -l pt_BR.UTF-8
63Este é um debugger orientado a comandos repleto de características.
64Ele permite à você rastrear a execução de programas e examinar o seu
f6fdc30b
AM
65estado interno a qualquer momento. Ele funciona para para C e C++
66compilado com o compilador GNU C.
67
14ab84e5
JR
68%description -l ru.UTF-8
69Это полноценный отладчик, управляемый командами. Он позволяет
70трассировать исполнение программ и изучать их внутреннее состояние в
71любой момент времени. Работает с программами на C и C++,
72скомпилированными GNU компилятором C (gcc, egcs, pgcc).
f6fdc30b 73
14ab84e5
JR
74%description -l tr.UTF-8
75Bir komut arayüzü üzerinden programcıya programını adım adım izleme
76(trace) ve herhangi bir anda programın durumunu inceleme olanağı
f6fdc30b
AM
77verir.
78
14ab84e5
JR
79%description -l uk.UTF-8
80Це повноцінний відладчик, що керується командами. Він дозволяє
81трасувати виконання програм та вивчати їх внутрішній стан в довільний
82момент часу. Працює з програмами на C та C++, зкомпільованими
83компіляторами GNU C (gcc, egcs, pgcc).
f6fdc30b
AM
84
85%prep
86%setup -q -n gdb-%{version}
87%patch0 -p1
88%patch1 -p1
89%patch2 -p1
f6fdc30b
AM
90
91%build
92for dir in `find gdb/ -name 'configure.in'`; do
93 dir=$(dirname "$dir")
94 olddir=$(pwd)
95 cd $dir
f6fdc30b
AM
96 %{__aclocal}
97 %{__autoconf}
98 cd $olddir
99done
100cp -f /usr/share/automake/config.* .
101# !! Don't enable shared here !!
102# This will cause serious problems --misiek
103%configure2_13 \
104 --target=%{target} \
105 --disable-shared \
106 --enable-nls \
107 --without-included-gettext \
108 --without-included-regex \
109 --enable-gdcli \
110 --enable-gdbmi \
111 --enable-multi-ice \
112 --enable-netrom \
113 --with-cpu=%{_target_cpu} \
114 --enable-tui \
115%ifnarch alpha
116 --with-mmalloc
117%endif
118
119# something is wrong after above - e.g. $exeext=="no" - fix it:
120cd gdb
121%configure \
122 --target=%{target}
123cd ..
124
125%{__make}
126%{__make} info
127
128%install
129rm -rf $RPM_BUILD_ROOT
130install -d $RPM_BUILD_ROOT%{_infodir}
131
0da9cde4 132%{__make} install \
f6fdc30b
AM
133 prefix=$RPM_BUILD_ROOT%{_prefix} \
134 bindir=$RPM_BUILD_ROOT%{_bindir} \
135 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
136 infodir=$RPM_BUILD_ROOT%{_infodir} \
137 includedir=$RPM_BUILD_ROOT%{_includedir} \
138 libdir=$RPM_BUILD_ROOT%{_libdir} \
139 mandir=$RPM_BUILD_ROOT%{_mandir}
140
141bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
f6fdc30b
AM
146%files
147%defattr(644,root,root,755)
0da9cde4
JB
148%attr(755,root,root) %{_bindir}/%{target}-gdb*
149%{_mandir}/man1/%{target}-gdb*.1*
This page took 0.089162 seconds and 4 git commands to generate.