]> git.pld-linux.org Git - packages/crossavr-gdb.git/blame - crossavr-gdb.spec
- tabs in preamble
[packages/crossavr-gdb.git] / crossavr-gdb.spec
CommitLineData
f6fdc30b 1Summary: A GNU source-level debugger for C, C++ and Fortran
3e4fa848
ER
2Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
3Summary(es.UTF-8): Depurador de programas C y otras lenguajes
4Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
5Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
6Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
7Summary(ru.UTF-8): Символический отладчик для C и других языков
8Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
9Summary(uk.UTF-8): Символьний відладчик для С та інших мов
10Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
11Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
f6fdc30b 12Name: crossavr-gdb
c629d6ae 13Version: 6.2.1
f6fdc30b
AM
14Release: 0.1
15License: GPL
16Group: Development/Debuggers
0da9cde4 17Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
c629d6ae 18# Source0-md5: 3b3898cfd426e1acd5efc89560aa93ba
f6fdc30b
AM
19Patch0: gdb-ncurses.patch
20Patch1: gdb-readline.patch
21Patch2: gdb-info.patch
0da9cde4
JB
22Patch3: gdb-passflags.patch
23Patch4: gdb-headers.patch
f6fdc30b
AM
24BuildRequires: XFree86-devel
25BuildRequires: autoconf >= 2.53
26BuildRequires: automake
27BuildRequires: libtool
28BuildRequires: ncurses-devel >= 5.2
29BuildRequires: readline-devel >= 4.2
03160ba6 30BuildRequires: texinfo
913366b2 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f6fdc30b 32
68687887 33%define target avr
f6fdc30b
AM
34
35%description
36Gdb is a full featured, command driven debugger. Gdb allows you to
37trace the execution of programs and examine their internal state at
38any time. Gdb works for C and C++ compiled with the GNU C compiler
39gcc.
40
14ab84e5
JR
41%description -l de.UTF-8
42dem Sie die Ausführung von Programmen verfolgen und jederzeit den
43inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
f6fdc30b
AM
44kompiliertes C++.
45
14ab84e5
JR
46%description -l es.UTF-8
47Este es un depurador orientado a comandos repleto de características.
48Te permite rastrear la ejecución de programas y examinar su estado
f6fdc30b
AM
49interno a cualquier momento. Funciona para C y C++ compilado con el
50compilador GNU C.
51
14ab84e5
JR
52%description -l fr.UTF-8
53Débugger complet, piloté par commandes. Permet de tracer l'exécution
54des programmes et d'examiner à tout moment leur état interne.
55Fonctionne avec les binaires C et C++ compilés avec le compilateur C
f6fdc30b
AM
56de GNU, gcc.
57
14ab84e5
JR
58%description -l pl.UTF-8
59Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
60śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
61umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
f6fdc30b
AM
62przy pomocy kompilatora GNU (gcc).
63
14ab84e5
JR
64%description -l pt_BR.UTF-8
65Este é um debugger orientado a comandos repleto de características.
66Ele permite à você rastrear a execução de programas e examinar o seu
f6fdc30b
AM
67estado interno a qualquer momento. Ele funciona para para C e C++
68compilado com o compilador GNU C.
69
14ab84e5
JR
70%description -l ru.UTF-8
71Это полноценный отладчик, управляемый командами. Он позволяет
72трассировать исполнение программ и изучать их внутреннее состояние в
73любой момент времени. Работает с программами на C и C++,
74скомпилированными GNU компилятором C (gcc, egcs, pgcc).
f6fdc30b 75
14ab84e5
JR
76%description -l tr.UTF-8
77Bir komut arayüzü üzerinden programcıya programını adım adım izleme
78(trace) ve herhangi bir anda programın durumunu inceleme olanağı
f6fdc30b
AM
79verir.
80
14ab84e5
JR
81%description -l uk.UTF-8
82Це повноцінний відладчик, що керується командами. Він дозволяє
83трасувати виконання програм та вивчати їх внутрішній стан в довільний
84момент часу. Працює з програмами на C та C++, зкомпільованими
85компіляторами GNU C (gcc, egcs, pgcc).
f6fdc30b
AM
86
87%prep
88%setup -q -n gdb-%{version}
89%patch0 -p1
90%patch1 -p1
91%patch2 -p1
92%patch3 -p1
93%patch4 -p1
f6fdc30b
AM
94
95%build
96for dir in `find gdb/ -name 'configure.in'`; do
97 dir=$(dirname "$dir")
98 olddir=$(pwd)
99 cd $dir
f6fdc30b
AM
100 %{__aclocal}
101 %{__autoconf}
102 cd $olddir
103done
104cp -f /usr/share/automake/config.* .
105# !! Don't enable shared here !!
106# This will cause serious problems --misiek
107%configure2_13 \
108 --target=%{target} \
109 --disable-shared \
110 --enable-nls \
111 --without-included-gettext \
112 --without-included-regex \
113 --enable-gdcli \
114 --enable-gdbmi \
115 --enable-multi-ice \
116 --enable-netrom \
117 --with-cpu=%{_target_cpu} \
118 --enable-tui \
119%ifnarch alpha
120 --with-mmalloc
121%endif
122
123# something is wrong after above - e.g. $exeext=="no" - fix it:
124cd gdb
125%configure \
126 --target=%{target}
127cd ..
128
129%{__make}
130%{__make} info
131
132%install
133rm -rf $RPM_BUILD_ROOT
134install -d $RPM_BUILD_ROOT%{_infodir}
135
0da9cde4 136%{__make} install \
f6fdc30b
AM
137 prefix=$RPM_BUILD_ROOT%{_prefix} \
138 bindir=$RPM_BUILD_ROOT%{_bindir} \
139 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
140 infodir=$RPM_BUILD_ROOT%{_infodir} \
141 includedir=$RPM_BUILD_ROOT%{_includedir} \
142 libdir=$RPM_BUILD_ROOT%{_libdir} \
143 mandir=$RPM_BUILD_ROOT%{_mandir}
144
145bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
f6fdc30b
AM
150%files
151%defattr(644,root,root,755)
0da9cde4
JB
152%attr(755,root,root) %{_bindir}/%{target}-gdb*
153%{_mandir}/man1/%{target}-gdb*.1*
This page took 0.085661 seconds and 4 git commands to generate.