]> git.pld-linux.org Git - packages/crossavr-binutils.git/blame - crossavr-binutils.spec
- add gcc 4.4.0 patch
[packages/crossavr-binutils.git] / crossavr-binutils.spec
CommitLineData
15547bba 1Summary: Cross AVR GNU binary utility development utilities - binutils
80e2ec2d
ER
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - AVR binutils
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla AVR - binutils
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - AVR binutils
6Summary(tr.UTF-8): GNU geliştirme araçları - AVR binutils
c31c0377 7Name: crossavr-binutils
323ea808 8Version: 2.19.1
c31c0377
WK
9Release: 1
10License: GPL
11Group: Development/Tools
323ea808 12Source0: ftp://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13# Source0-md5: 09a8c5821a2dfdbb20665bc0bd680791
14Patch0: %{name}-avr-size.patch
15Patch1: %{name}-avr-coff.patch
16Patch2: %{name}-new-sections.patch
17Patch3: %{name}-data-origin.patch
18Patch4: %{name}-xmega.patch
19Patch5: %{name}-xmega2.patch
20Patch6: %{name}-atmega32u6.patch
39aef82e 21Patch7: %{name}-gcc44.patch
c3700061 22URL: http://sources.redhat.com/binutils/
4f1d398f 23BuildRequires: automake
c3700061 24BuildRequires: bash
c31c0377 25BuildRequires: bison
c3700061 26BuildRequires: flex
3076856f 27BuildRequires: gettext-devel
f4a6ca9d 28BuildRequires: texinfo
c31c0377
WK
29%ifarch sparc sparc32
30BuildRequires: sparc32
31%endif
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define target avr
35%define arch %{_prefix}/%{target}
36
37%description
38Binutils is a collection of binary utilities, including:
39- ar - create, modify and extract from archives,
40- nm - lists symbols from object files,
41- objcopy - copy and translate object files,
42- objdump - display information from object files,
43- ranlib - generate an index for the contents of an archive,
44- size - list the section sizes of an object or archive file,
45- strings - list printable strings from files,
46- strip - discard symbols,
47- c++filt - a filter for demangling encoded C++ symbols,
48- addr2line - convert addresses to file and line,
49- nlmconv - convert object code into an NLM.
50
15547bba 51This package contains the cross version for Atmel AVR.
c31c0377 52
f3e2688f
JR
53%description -l pl.UTF-8
54Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
55programów. Znajdują się tutaj między innymi assembler, konsolidator
56(linker), a także inne narzędzia do manipulowania binarnymi plikami
57programów i bibliotek.
c31c0377 58
f3e2688f 59Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
c31c0377
WK
60
61%prep
62%setup -q -n binutils-%{version}
2d50d5c0 63%patch0 -p0
323ea808 64%patch1 -p0
01b4427c 65%patch2 -p0
323ea808 66%patch3 -p0
67%patch4 -p0
68%patch5 -p0
69%patch6 -p0
39aef82e 70%patch7 -p1
c31c0377
WK
71
72%build
4f1d398f 73cp /usr/share/automake/config.sub .
74
c31c0377 75# ldscripts won't be generated properly if SHELL is not bash...
c3700061
JB
76CFLAGS="%{rpmcflags}" \
77LDFLAGS="%{rpmldflags}" \
c31c0377
WK
78CONFIG_SHELL="/bin/bash" \
79%ifarch sparc
80sparc32 \
81%endif
82./configure \
2de3da85 83 --disable-shared \
c31c0377 84 --prefix=%{_prefix} \
4f1d398f 85 --libdir=%{_libdir} \
c31c0377 86 --mandir=%{_mandir} \
4f1d398f 87 --infodir=%{_infodir} \
d7e2b08f 88 --host=%{_target_platform} \
89 --build=%{_target_platform} \
c31c0377
WK
90 --target=%{target}
91
323ea808 92# We have to regenerate headers after patching.
93%{__make} configure-host \
94 tooldir=%{_prefix} \
95 EXEEXT=""
96
97%{__make} -C bfd headers \
98 tooldir=%{_prefix} \
99 EXEEXT=""
100
c3700061
JB
101%{__make} all \
102 tooldir=%{_prefix} \
103 EXEEXT=""
c31c0377
WK
104
105%install
106rm -rf $RPM_BUILD_ROOT
107install -d $RPM_BUILD_ROOT%{_prefix}
108
109%{__make} install \
110 prefix=$RPM_BUILD_ROOT%{_prefix} \
f0155d93 111 mandir=$RPM_BUILD_ROOT%{_mandir} \
14538aa8 112 infodir=$RPM_BUILD_ROOT%{_infodir} \
113 libdir=$RPM_BUILD_ROOT%{_libdir}
078926c2 114cd bfd
115%{__make} install_libbfd DESTDIR=$RPM_BUILD_ROOT
116cd ..
117cd opcodes
118%{__make} install_libopcodes DESTDIR=$RPM_BUILD_ROOT
119cd ..
c31c0377 120
4f1d398f 121# remove these man pages unless we cross-build for win*/netware platforms.
122# however, this should be done in Makefiles.
123rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
124
95d38776
ER
125rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
126rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
127rm -rf $RPM_BUILD_ROOT%{_infodir}
128
c31c0377
WK
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(644,root,root,755)
9959e179 134%doc README
c31c0377 135%attr(755,root,root) %{_bindir}/%{target}-*
9959e179 136%dir %{arch}
c31c0377
WK
137%dir %{arch}/bin
138%attr(755,root,root) %{arch}/bin/*
139%dir %{arch}/lib
140%dir %{arch}/lib/*
f53587c5 141%{arch}/lib/*/*
c31c0377 142%{_mandir}/man?/%{target}-*
This page took 0.063696 seconds and 4 git commands to generate.