]> git.pld-linux.org Git - packages/crossarmdarwin-binutils.git/blame_incremental - crossarmdarwin-binutils.spec
- new, odcctools only now
[packages/crossarmdarwin-binutils.git] / crossarmdarwin-binutils.spec
... / ...
CommitLineData
1# DOCS
2# - http://aakash-bapna.blogspot.com/2007/10/iphone-non-official-sdk-aka-toolchain.html
3# - http://code.google.com/p/iphone-dev/wiki/Building
4# - ...
5# - csu (crt1.o, dylib1.o, and bundle1.o) + bootstrap
6# - ...
7# TO MAKE TARBALL(s):
8# svn co http://iphone-dev.googlecode.com/svn/trunk/odcctools odcctools
9# tar --exclude=.svn -cjf odcctools-r280.tar.bz2 odcctools
10# TODO
11# - name of this cross platform? crossarm-darwin? crossarm-darwin9?
12# - not built from binutils source, should we name package differently?
13# - On 64-bit architectures there are currently compilation and linking problems with structs; as a workaround, try the following:
14# - export CFLAGS="-m32"; export LDFLAGS="-m32"
15Summary: Cross ARM Apple Darwin development utilities - binutils
16Name: crossarmdarwin-binutils
17Version: 0.152
18Release: 0.1
19License: GPL v2
20Group: Development/Tools
21Source0: odcctools-r280.tar.bz2
22# Source0-md5: 8a49b63a883219705de5b4a95265ffca
23URL: http://developer.berlios.de/projects/iphone-binutils/
24BuildRequires: bison
25BuildRequires: flex
26ExcludeArch: %{x8664}
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%define target arm-apple-darwin
30%define arch %{_prefix}/%{target}
31
32%description
33Binutils is a collection of binary utilities, including:
34- ar - create, modify and extract from archives,
35- nm - lists symbols from object files,
36- objcopy - copy and translate object files,
37- objdump - display information from object files,
38- ranlib - generate an index for the contents of an archive,
39- size - list the section sizes of an object or archive file,
40- strings - list printable strings from files,
41- strip - discard symbols,
42- c++filt - a filter for demangling encoded C++ symbols,
43- addr2line - convert addresses to file and line,
44- nlmconv - convert object code into an NLM.
45
46This is a toolchain to produce arm/Mach-O binaries.
47
48%description -l pl.UTF-8
49Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
50programów. Znajdują się tutaj między innymi assembler, konsolidator
51(linker), a także inne narzędzia do manipulowania binarnymi plikami
52programów i bibliotek.
53
54%prep
55%setup -qcT -a0
56
57%build
58install -d build/odcctools
59cd build/odcctools
60../../odcctools/%configure \
61 --prefix=%{arch} \
62 --libexecdir=%{arch} \
63 --target=%{target} \
64 --disable-ld64
65%{__make}
66cd -
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_prefix}
71
72%{__make} -C build/odcctools install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75# prefix manpages
76for a in $RPM_BUILD_ROOT%{_mandir}/man?/*; do
77 n=${a##*/} s=${a##*.} d=${a%/*}
78 mv $a $d/%{target}-$n.$s
79done
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%attr(755,root,root) %{_bindir}/%{target}-*
87%dir %{arch}
88%dir %{arch}/as
89%dir %{arch}/as/*
90%attr(755,root,root) %{arch}/as/*/as
91
92%{_mandir}/man?/%{target}-*
93%dir %{_includedir}/mach-o
94%{_includedir}/mach-o/arch.h
95%{_includedir}/mach-o/fat.h
96%{_includedir}/mach-o/loader.h
97%{_includedir}/mach-o/machine.h
98%{_libdir}/libmacho.a
This page took 0.070021 seconds and 4 git commands to generate.