]> git.pld-linux.org Git - packages/cross-gcc.git/blame - cross-gcc.spec
remove -march from cflags
[packages/cross-gcc.git] / cross-gcc.spec
CommitLineData
b5b0b447
ER
1#
2# Conditional build:
3%bcond_without cloog # cloog
4# Targets:
5%bcond_without aarch64 # enable aarch64
6%bcond_without alpha # enable alpha
7%bcond_without arm # enable arm
8%bcond_without avr32 # enable avr32
9%bcond_without blackfin # enable blackfin
10%bcond_without c6x # enable c6x
11%bcond_without cris # enable cris
12%bcond_without frv # enable frv
13%bcond_without h8300 # enable h8300
14%bcond_without hppa # enable hppa
15%bcond_without hppa64 # enable hppa64
16%bcond_without ia64 # enable ia64
17%bcond_without m32r # enable m32r
18%bcond_without m68k # enable m68k
19%bcond_without microblaze # enable microblaze
20%bcond_without mips64 # enable mips64
21%bcond_without mn10300 # enable mn10300
22%bcond_without nios2 # enable nios2
23%bcond_without powerpc64 # enable powerpc64
24%bcond_without s390x # enable s390x
25%bcond_without sh # enable sh
26%bcond_without sh64 # enable sh64
27%bcond_without sparc64 # enable sparc64
28%bcond_without tile # enable tile
29%bcond_without x86_64 # enable x86_64
30%bcond_without xtensa # enable xtensa
31
32# built compiler generates lots of ICEs
33# - none at this time
34
35# gcc considers obsolete
36%undefine with_score
37
38# gcc doesn't build
39# - sh64 doesn't build on pld:
40# ../../gcc-4.9.2-20141212/gcc/genmultilib[264]: shift: nothing to shift
41# Makefile:1851: recipe for target 's-mlib' failed
42%undefine with_sh64
43# packaging error, files packaged to gcc-hppa-linux-gnu and gcc-hppa64-linux-gnu
44%undefine with_hppa64
45
46# 32-bit packages we don't build as we can use the 64-bit package instead
47%undefine with_i386
48%undefine with_mips
49%undefine with_powerpc
50%undefine with_s390
51%undefine with_sh4
52%undefine with_sparc
53
54# gcc doesn't support
55%undefine with_metag
56%undefine with_openrisc
57
58# not available in binutils-2.22
59%undefine with_unicore32
60
61%define multilib_64_archs sparc64 ppc64 s390x x86_64
62
63# we won't build libgcc for these as it depends on C library or kernel headers
64%define no_libgcc_targets nios2*|tile-*
65
66###############################################################################
67#
68# The gcc versioning information. In a sed command below, the specfile winds
69# pre-release version numbers in BASE-VER back to the last actually-released
70# number.
71%define DATE 20141212
72%define SVNREV 218667
73
74%define srcdir gcc-%{version}-%{DATE}
75%define cross_binutils_version 2.24
76%define isl_version 0.12.2
77%define cloog_version 0.18.1
78
79Summary: Cross C compiler
80Name: cross-gcc
81Version: 4.9.2
82Release: 0.1
83# libgcc, libgfortran, libmudflap, libgomp, libstdc++ and crtstuff have GCC Runtime Exception.
84License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
85Group: Development/Languages
86URL: http://gcc.gnu.org/
87# The source for this package was pulled from upstream's vcs. Use the
88# following commands to generate the tarball:
89# svn export svn://gcc.gnu.org/svn/gcc/branches/redhat/gcc-4_7-branch@%{SVNREV} gcc-%{version}-%{DATE}
90# tar cf - gcc-%{version}-%{DATE} | bzip2 -9 > gcc-%{version}-%{DATE}.tar.bz2
91Source0: http://pkgs.fedoraproject.org/repo/pkgs/cross-gcc/%{srcdir}.tar.bz2/ccd8cac944582f8d2ddf5274a15df176/%{srcdir}.tar.bz2
92# Source0-md5: ccd8cac944582f8d2ddf5274a15df176
93Source1: ftp://gcc.gnu.org/pub/gcc/infrastructure/isl-%{isl_version}.tar.bz2
94# Source1-md5: e039bfcfb6c2ab039b8ee69bf883e824
95Source2: ftp://gcc.gnu.org/pub/gcc/infrastructure/cloog-%{cloog_version}.tar.gz
96# Source2-md5: e34fca0540d840e5d0f6427e98c92252
97Patch0: gcc49-hack.patch
98Patch1: gcc49-java-nomulti.patch
99Patch2: gcc49-ppc32-retaddr.patch
100Patch3: gcc49-rh330771.patch
101Patch4: gcc49-i386-libgomp.patch
102Patch5: gcc49-sparc-config-detection.patch
103Patch6: gcc49-libgomp-omp_h-multilib.patch
104Patch7: gcc49-libtool-no-rpath.patch
105Patch8: gcc49-cloog-dl.patch
106Patch9: gcc49-cloog-dl2.patch
107Patch10: gcc49-pr38757.patch
108Patch11: gcc49-libstdc++-docs.patch
109Patch12: gcc49-no-add-needed.patch
110Patch13: gcc49-color-auto.patch
111Patch14: gcc49-libgo-p224.patch
112Patch15: gcc49-aarch64-async-unw-tables.patch
113Patch16: gcc49-aarch64-unwind-opt.patch
114Patch17: gcc49-pr64269.patch
115Patch900: cross-intl-filename.patch
116# ia64 - http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44553
117# m68k - http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53557
118# alpha - http://gcc.gnu.org/bugzilla/show_bug.cgi?id=55344
119Patch901: cross-gcc-with-libgcc.patch
120Patch903: cross-gcc-bfin.patch
121Patch904: cross-gcc-c6x.patch
122Patch1100: cloog-0.18.1-ppc64le-config.patch
123BuildRequires: cross-binutils-common >= %{cross_binutils_version}
124BuildRequires: binutils >= 2.20.51.0.2-12
125BuildRequires: bison
126BuildRequires: dejagnu
127BuildRequires: flex
128BuildRequires: gettext
129BuildRequires: sharutils
130BuildRequires: texinfo
131BuildRequires: zlib-devel
132# make sure pthread.h doesn't contain __thread tokens
133# make sure glibc supports stack protector
134# make sure glibc supports DT_GNU_HASH
135BuildRequires: elfutils-devel >= 0.147
136BuildRequires: glibc-devel >= 2.4.90-13
137BuildRequires: gmp-devel >= 4.2
138BuildRequires: libmpc-devel >= 0.8.1
139BuildRequires: mpfr-devel >= 2.3.1
140Provides: bundled(libiberty)
141BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
142
143%define builddir %{_builddir}/%{name}-%{version}
144
629150be
ER
145# functions with printf format attribute but with special parser and also
146# receiving non constant format strings
147%define Werror_cflags %{nil}
148
82693282
ER
149# -march= from host is invalid when configuring targets
150%define filterout_c -march=.*
151%define filterout_cxx -march=.*
152
b5b0b447
ER
153%description
154Cross-build GNU C compiler collection.
155
156%package common
157Summary: Cross-build GNU C compiler documentation and translation files
158Group: Development/Languages
159%if "%{_rpmversion}" >= "5"
160BuildArch: noarch
161%endif
162
163%description common
164Documentation, manual pages and translation files for cross-build GNU
165C compiler.
166
167This is the common part of a set of cross-build GNU C compiler
168packages for building kernels for other architectures. No support for
169cross-building user space programs is currently supplied as that would
170massively multiply the number of packages.
171
172%define do_package() \
173%if %{expand:%%{?with_%{2}:1}%%{!?with_%{2}:0}} \
174%package -n gcc-%1 \
175Summary: Cross-build binary utilities for %1 \
176Group: Development/Languages \
177BuildRequires: binutils-%1 >= %{cross_binutils_version}\
178Requires: %{name}-common = %{version}-%{release}\
179Requires: binutils-%1 >= %{cross_binutils_version}\
180\
181%description -n gcc-%1 \
182Cross-build GNU C compiler. \
183\
184Only building kernels is currently supported. Support for cross-building \
185user space programs is not currently provided as that would massively multiply \
186the number of packages. \
187\
188%package -n gcc-c++-%1 \
189Summary: Cross-build binary utilities for %1 \
190Group: Development/Languages \
191Requires: gcc-%1 = %{version}-%{release}\
192\
193%description -n gcc-c++-%1 \
194Cross-build GNU C++ compiler. \
195\
196Only the compiler is provided; not libstdc++. Support for cross-building \
197user space programs is not currently provided as that would massively multiply \
198the number of packages. \
199%endif
200
201%define do_symlink() \
202%if %{expand:%%{?with_%{2}:1}%%{!?with_%{2}:0}} \
203%package -n gcc-%1 \
204Summary: Cross-build binary utilities for %1 \
205Group: Development/Languages \
206Requires: gcc-%3 = %{version}-%{release}\
207\
208%description -n gcc-%1 \
209Cross-build GNU C++ compiler. \
210\
211Only building kernels is currently supported. Support for cross-building \
212user space programs is not currently provided as that would massively multiply \
213the number of packages. \
214\
215%package -n gcc-c++-%1 \
216Summary: Cross-build binary utilities for %1 \
217Group: Development/Languages \
218Requires: gcc-%1 = %{version}-%{release}\
219Requires: gcc-c++-%3 = %{version}-%{release}\
220\
221%description -n gcc-c++-%1 \
222Cross-build GNU C++ compiler. \
223\
224Only the compiler is provided; not libstdc++. Support for cross-building \
225user space programs is not currently provided as that would massively multiply \
226the number of packages. \
227%endif
228
229%do_package alpha-linux-gnu alpha
230%do_package arm-linux-gnu arm
231%do_package aarch64-linux-gnu aarch64
232%do_package avr32-linux-gnu avr32
233%do_package bfin-linux-gnu blackfin
234%do_package c6x-linux-gnu c6x
235%do_package cris-linux-gnu cris
236%do_package frv-linux-gnu frv
237%do_package h8300-linux-gnu h8300
238%do_package hppa-linux-gnu hppa
239%do_package hppa64-linux-gnu hppa64
240%do_package i386-linux-gnu i386
241%do_package ia64-linux-gnu ia64
242%do_package m32r-linux-gnu m32r
243%do_package m68k-linux-gnu m68k
244%do_package metag-linux-gnu metag
245%do_package microblaze-linux-gnu microblaze
246%do_package mips-linux-gnu mips
247%do_package mips64-linux-gnu mips64
248%do_package mn10300-linux-gnu mn10300
249%do_package nios2-linux-gnu nios2
250%do_package openrisc-linux-gnu openrisc
251%do_package powerpc-linux-gnu powerpc
252%do_package powerpc64-linux-gnu powerpc64
253%do_symlink ppc-linux-gnu powerpc powerpc-linux-gnu
254%do_symlink ppc64-linux-gnu powerpc64 powerpc64-linux-gnu
255%do_package s390-linux-gnu s390
256%do_package s390x-linux-gnu s390x
257%do_package score-linux-gnu score
258%do_package sh-linux-gnu sh
259%do_package sh4-linux-gnu sh4
260%do_package sh64-linux-gnu sh64
261%do_package sparc-linux-gnu sparc
262%do_package sparc64-linux-gnu sparc64
263%do_package tile-linux-gnu tile
264%do_package unicore32-linux-gnu unicore32
265%do_package x86_64-linux-gnu x86_64
266%do_package xtensa-linux-gnu xtensa
267
268%prep
269%setup -qc -a 1 -a 2
270cd %{srcdir}
271%patch0 -p0
272%patch1 -p0
273%patch2 -p0
274%patch3 -p0
275%patch4 -p0
276%patch5 -p0
277%patch6 -p0
278%patch7 -p0
279%if %{with cloog}
280%patch8 -p0
281%patch9 -p0
282%endif
283%patch10 -p0
284# % if %{with libstdcxx_docs}
285# % patch11 -p0
286# % endif
287%patch12 -p0
288%patch13 -p0
289%patch14 -p0
290rm -f libgo/go/crypto/elliptic/p224{,_test}.go
291%patch15 -p0
292%patch16 -p0
293%patch17 -p0
294
295%patch900 -p0
296%patch901 -p1
297%patch903 -p0
298%patch904 -p0
299
300cd ..
301%patch1100 -p0
302cd %{srcdir}
303
304# Move the version number back
305sed -i -e 's/4\.9\.3/4.9.2/' gcc/BASE-VER
306echo 'PLD-Linux Cross %{version}-%{release}' > gcc/DEV-PHASE
307
308# Default to -gdwarf-4 -fno-debug-types-section rather than -gdwarf-2
309sed -i '/UInteger Var(dwarf_version)/s/Init(2)/Init(4)/' gcc/common.opt
310sed -i '/flag_debug_types_section/s/Init(1)/Init(0)/' gcc/common.opt
311sed -i '/dwarf_record_gcc_switches/s/Init(0)/Init(1)/' gcc/common.opt
312sed -i 's/\(may be either 2, 3 or 4; the default version is \)2\./\14./' gcc/doc/invoke.texi
313
314./contrib/gcc_update --touch
315
316LC_ALL=C sed -i -e 's/\xa0/ /' gcc/doc/options.texi
317
318cat > target.list <<EOF
319%{?with_alpha:alpha-linux-gnu}
320%{?with_arm:arm-linux-gnu}
321%{?with_aarch64:aarch64-linux-gnu}
322%{?with_avr32:avr32-linux-gnu}
323%{?with_blackfin:bfin-linux-gnu}
324%{?with_c6x:c6x-linux-gnu}
325%{?with_cris:cris-linux-gnu}
326%{?with_frv:frv-linux-gnu}
327%{?with_h8300:h8300-linux-gnu}
328%{?with_hppa:hppa-linux-gnu}
329%{?with_hppa64:hppa64-linux-gnu}
330%{?with_i386:i386-linux-gnu}
331%{?with_ia64:ia64-linux-gnu}
332%{?with_m32r:m32r-linux-gnu}
333%{?with_m68k:m68k-linux-gnu}
334%{?with_metag:metag-linux-gnu}
335%{?with_microblaze:microblaze-linux-gnu}
336%{?with_mips:mips-linux-gnu}
337%{?with_mips64:mips64-linux-gnu}
338%{?with_mn10300:mn10300-linux-gnu}
339%{?with_nios2:nios2-linux-gnu}
340%{?with_openrisc:openrisc-linux-gnu}
341%{?with_powerpc:powerpc-linux-gnu}
342%{?with_powerpc64:powerpc64-linux-gnu}
343%{?with_s390:s390-linux-gnu}
344%{?with_s390x:s390x-linux-gnu}
345%{?with_score:score-linux-gnu}
346%{?with_sh:sh-linux-gnu}
347%{?with_sh4:sh4-linux-gnu}
348%{?with_sh64:sh64-linux-gnu}
349%{?with_sparc:sparc-linux-gnu}
350%{?with_sparc64:sparc64-linux-gnu}
351%{?with_tile:tile-linux-gnu}
352%{?with_unicore32:unicore32-linux-gnu}
353%{?with_x86_64:x86_64-linux-gnu}
354%{?with_xtensa:xtensa-linux-gnu}
355EOF
356
357if [ $(wc -w < target.list) = 0 ]; then
358 echo >&2 "No targets selected"
359 exit 8
360fi
361
362%build
363
364# Undo the broken autoconf change in recent Fedora versions
365export CONFIG_SITE=NONE
366
367#
368# Configure and build the ISL and CLooG libraries
369#
370%if %{with cloog}
371
372%define isl_source %{builddir}/isl-%{isl_version}
373%define isl_build %{builddir}/isl-build
374%define isl_install %{builddir}/isl-install
375
376mkdir %{isl_build} %{isl_install}
377%ifarch s390 s390x
378ISL_FLAG_PIC=-fPIC
379%else
380ISL_FLAG_PIC=-fpic
381%endif
382cd %{isl_build}
383 %{isl_source}/configure \
384 --disable-silent-rules \
385 --disable-shared \
386 CC="%{__cc}" \
387 CXX="%{__cxx}" \
388 CFLAGS="${CFLAGS:-%rpmcflags} $ISL_FLAG_PIC" \
389 --prefix=%{isl_install}
390 %{__make}
391 %{__make} install
392cd ..
393
394%define cloog_source %{builddir}/cloog-%{cloog_version}
395%define cloog_build %{builddir}/cloog-build
396%define cloog_install %{builddir}/cloog-install
397
398install -d %{cloog_build} %{builddir}/cloog-install
399cd %{cloog_build}
400cat >> %{cloog_source}/source/isl/constraints.c << \EOF
401#include <isl/flow.h>
402static void __attribute__((used)) *s1 = (void *) isl_union_map_compute_flow;
403static void __attribute__((used)) *s2 = (void *) isl_map_dump;
404EOF
405sed -i 's|libcloog|libgcc49privatecloog|g' %{cloog_source}/{,test/}Makefile.{am,in}
406
407%{cloog_source}/configure \
408 --disable-silent-rules \
409 --with-isl=system \
410 --with-isl-prefix=%{isl_install} \
411 CC="%{__cc}" \
412 CXX="%{__cxx}" \
413 CFLAGS="${CFLAGS:-%rpmcflags}" \
414 CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" \
415 --prefix=%{cloog_install}
416sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
417sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
418%{__make}
419%{__make} install
420cd %{cloog_install}/lib
421rm libgcc49privatecloog-isl.so{,.4}
422mv libgcc49privatecloog-isl.so.4.0.0 libcloog-isl.so.4
423ln -sf libcloog-isl.so.4 libcloog-isl.so
424ln -sf libcloog-isl.so.4 libcloog.so
425
426%endif
427
428#
429# Configure the compiler
430#
431cd %{builddir}
432config_target() {
433 echo "=== CONFIGURING $1"
434
435 arch=$1
436 prefix=$arch-
437 build_dir=$1
438
439 case $arch in
440 arm-*) target=arm-linux-gnueabi;;
441 aarch64-*) target=aarch64-linux-gnu;;
442 avr32-*) target=avr-linux;;
443 bfin-*) target=bfin-uclinux;;
444 c6x-*) target=c6x-uclinux;;
445 h8300-*) target=h8300-elf;;
446 mn10300-*) target=am33_2.0-linux;;
447 m68knommu-*) target=m68k-linux;;
448 openrisc-*) target=or32-linux;;
449 parisc-*) target=hppa-linux;;
450 score-*) target=score-elf;;
451 sh64-*) target=sh64-linux;;
452 tile-*) target=tilegx-linux;;
453 v850-*) target=v850e-linux;;
454 x86-*) target=x86_64-linux;;
455 *) target=$arch;;
456 esac
457
458 echo $arch: target is $target
459 #export CFLAGS="$RPM_OPT_FLAGS"
460
461 CONFIG_FLAGS=
462 case $arch in
463 arm)
464 CONFIG_FLAGS="--with-cpu=cortex-a8 --with-tune=cortex-a8 --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16 --with-abi=aapcs-linux"
465 ;;
466 powerpc-*|powerpc64-*)
467 CONFIG_FLAGS="--with-cpu-32=power4 --with-tune-32=power6 --with-cpu-64=power4 --with-tune-64=power6 --enable-secureplt"
468 ;;
469 s390*-*)
470 CONFIG_FLAGS="--with-arch=z9-109 --with-tune=z10 --enable-decimal-float"
471 ;;
472 sh-*)
473 CONFIG_FLAGS="--with-multilib-list=m1,m2,m2e,m4,m4-single,m4-single-only,m2a,m2a-single,!m2a,!m2a-single"
474 ;;
475 sh64-*)
476 CONFIG_FLAGS="--with-multilib-list=m5-32media,m5-32media-nofpu,m5-compact,m5-compact-nofpu,m5-64media,m5-64media-nofpu"
477 ;;
478 sparc-*)
479 CONFIG_FLAGS="--disable-linux-futex"
480 ;;
481 tile-*)
482 #CONFIG_FLAGS="--with-arch_32=tilepro"
483 ;;
484 x86-*)
485 CONFIG_FLAGS="--with-arch_32=i686"
486 ;;
487 esac
488
489 case $arch in
490 alpha|powerpc*|s390*|sparc*)
491 CONFIG_FLAGS="$CONFIG_FLAGS --with-long-double-128" ;;
492 esac
493
494 install -d $build_dir
495 cd $build_dir
496
497 # We could optimize the cross builds size by --enable-shared but the produced
498 # binaries may be less convenient in the embedded environment.
499 AR_FOR_TARGET=%{_bindir}/$arch-ar \
500 AS_FOR_TARGET=%{_bindir}/$arch-as \
501 DLLTOOL_FOR_TARGET=%{_bindir}/$arch-dlltool \
502 LD_FOR_TARGET=%{_bindir}/$arch-ld \
503 NM_FOR_TARGET=%{_bindir}/$arch-nm \
504 OBJDUMP_FOR_TARGET=%{_bindir}/$arch-objdump \
505 RANLIB_FOR_TARGET=%{_bindir}/$arch-ranlib \
506 STRIP_FOR_TARGET=%{_bindir}/$arch-strip \
507 WINDRES_FOR_TARGET=%{_bindir}/$arch-windres \
508 WINDMC_FOR_TARGET=%{_bindir}/$arch-windmc \
509 CC="%{__cc}" \
510 CFLAGS="%{rpmcflags}" \
511 CXXFLAGS="%{rpmcxxflags}" \
512 LDFLAGS="-Wl,-z,relro " \
513 ../%{srcdir}/configure \
514 --bindir=%{_bindir} \
515 --build=%{_target_platform} \
516 --datadir=%{_datadir} \
517 --disable-decimal-float \
518 --disable-dependency-tracking \
519 --disable-gold \
520 --disable-libgomp \
521 --disable-libmudflap \
522 --disable-libquadmath \
523 --disable-libssp \
524 --disable-nls \
525 --disable-plugin \
526 --disable-shared \
527 --disable-silent-rules \
528 --disable-sjlj-exceptions \
529 --disable-threads \
530 --with-ld=/usr/bin/$arch-ld \
531 --enable-checking=$checking \
532 --enable-gnu-unique-object \
533 --enable-initfini-array \
534 --enable-languages=c,c++ \
535 --enable-linker-build-id \
536 --enable-nls \
537 --enable-obsolete \
538 --enable-targets=all \
539 --exec-prefix=%{_exec_prefix} \
540 --host=%{_target_platform} \
541 --includedir=%{_includedir} \
542 --infodir=%{_infodir} \
543 --libexecdir=%{_libexecdir} \
544 --localstatedir=%{_localstatedir} \
545 --mandir=%{_mandir} \
546 --prefix=%{_prefix} \
547 --program-prefix=$prefix \
548 --sbindir=%{_sbindir} \
549 --sharedstatedir=%{_sharedstatedir} \
550 --sysconfdir=%{_sysconfdir} \
551 --target=$target \
552 --with-bugurl="http://bugs.pld-linux.org" \
553 --with-linker-hash-style=gnu \
554 --with-newlib \
555 --with-sysroot=%{_prefix}/$arch/sys-root \
556 --with-system-libunwind \
557 --with-system-zlib \
558 --without-headers \
559%if %{with cloog}
560 --with-isl=%{isl_install} --with-cloog=%{cloog_install} \
561%else
562 --without-isl --without-cloog \
563%endif
564 $CONFIG_FLAGS
565%if 0
566 --libdir=%{_libdir} # we want stuff in /usr/lib/gcc/ not /usr/lib64/gcc
567%endif
568 cd ..
569}
570
571for target in $(cat target.list); do
572 config_target $target
573done
574
575build_target() {
576 echo "=== BUILDING $1"
577
578 arch=$1
579 build_dir=$1
580
581 AR_FOR_TARGET=%{_bindir}/$arch-ar \
582 AS_FOR_TARGET=%{_bindir}/$arch-as \
583 DLLTOOL_FOR_TARGET=%{_bindir}/$arch-dlltool \
584 LD_FOR_TARGET=%{_bindir}/$arch-ld \
585 NM_FOR_TARGET=%{_bindir}/$arch-nm \
586 OBJDUMP_FOR_TARGET=%{_bindir}/$arch-objdump \
587 RANLIB_FOR_TARGET=%{_bindir}/$arch-ranlib \
588 STRIP_FOR_TARGET=%{_bindir}/$arch-strip \
589 WINDRES_FOR_TARGET=%{_bindir}/$arch-windres \
590 WINDMC_FOR_TARGET=%{_bindir}/$arch-windmc \
591 %{__make} -C $build_dir tooldir=%{_prefix} all-gcc
592
593 case $arch in
594 %{no_libgcc_targets})
595 ;;
596 *)
597 %{__make} -C $build_dir tooldir=%{_prefix} all-target-libgcc
598 ;;
599 esac
600}
601
602for target in $(cat target.list); do
603 build_target $target
604done
605
606%install
607rm -rf $RPM_BUILD_ROOT
608
609install_bin() {
610 echo "=== INSTALLING $1"
611
612 arch=$1
613 cpu=${1%%%%-*}
614
615 case $arch in
616 %{no_libgcc_targets}) with_libgcc="";;
617 *) with_libgcc="install-target-libgcc";;
618 esac
619
620 %{__make} -C $arch DESTDIR=$RPM_BUILD_ROOT install-gcc ${with_libgcc}
621
622 # We want links for ppc and ppc64 also if we make powerpc or powerpc64
623 case $cpu in
624 powerpc*)
625 cd $RPM_BUILD_ROOT%{_bindir}
626 for i in $cpu-*; do
627 ln -s $i ppc${i#powerpc}
628 done
629 cd -
630 ;;
631 esac
632}
633
634for target in $(cat target.list); do
635 install -d $RPM_BUILD_ROOT%{_prefix}/$target/sys-root
636 install_bin $target
637done
638
639grep ^powerpc target.list | sed -e s/powerpc/ppc/ > symlink-target.list
640
641# We have to copy cloog somewhere graphite can dlopen it from
642%if %{with cloog}
643for i in $RPM_BUILD_ROOT%{_prefix}/lib/gcc/*/%{version}; do
644 cp -a %{cloog_install}/lib/libcloog-isl.so.4 $i
645done
646%endif
647
648# For cross-gcc we drop the documentation.
649rm -rf $RPM_BUILD_ROOT%{_infodir}
650
651# Remove binaries we will not be including, so that they don't end up in
652# gcc-debuginfo
653rm -f $RPM_BUILD_ROOT%{_libdir}/{libffi*,libiberty.a}
654rm -f $RPM_BUILD_ROOT%{_libexecdir}/gcc/*/%{version}/install-tools/{mkheaders,fixincl}
655rm -f $RPM_BUILD_ROOT%{_bindir}/*-gcc-%{version} || :
656rm -f $RPM_BUILD_ROOT%{_bindir}/*-ar || :
657rm -f $RPM_BUILD_ROOT%{_bindir}/*-nm || :
658rm -f $RPM_BUILD_ROOT%{_bindir}/*-ranlib || :
659rmdir $RPM_BUILD_ROOT%{_includedir}
660
661find $RPM_BUILD_ROOT%{_datadir} -name gcc.mo |
662while read x; do
663 y=$(dirname $x)
664 mv $x $y/cross-gcc.mo
665done
666
667%find_lang cross-gcc
668
669rm $RPM_BUILD_ROOT%{_mandir}/man7/*.7
670rmdir $RPM_BUILD_ROOT%{_mandir}/man7
671
672# All the installed manual pages and translation files for each program are the
673# same, so symlink them to the common package
674cd $RPM_BUILD_ROOT%{_mandir}/man1
675 for i in cross-cpp.1 cross-gcc.1 cross-g++.1 cross-gcov.1; do
676 j=${i#cross-}
677
678 for k in *-$j; do
679 if [ $k != $i -a ! -L $k ]; then
680 mv $k $i
681 ln -s $i $k
682 fi
683 done
684 done
685
686 # Add manpages the additional symlink-only targets
687 %if %{with powerpc}%{with powerpc64}
688 for i in powerpc*; do
689 ln -s $i ppc${i#powerpc}
690 done
691 %endif
692cd -
693
694install_lang() {
695 arch=$1
696 cpu=${arch%%%%-*}
697
698 case $cpu in
699 avr32) target_cpu=avr;;
700 bfin) target_cpu=bfin;;
701 h8300) target_cpu=h8300;;
702 mn10300) target_cpu=am33_2.0;;
703 openrisc) target_cpu=openrisc;;
704 parisc) target_cpu=hppa;;
705 score) target_cpu=score;;
706 tile) target_cpu=tilegx;;
707 v850) target_cpu=v850e;;
708 x86) target_cpu=x86_64;;
709 *) target_cpu=$cpu;;
710 esac
711
712 (
713 echo "%%defattr(-,root,root,-)"
714 echo "%{_bindir}/$arch*-cpp"
715 echo "%{_bindir}/$arch*-gcc"
716 echo "%{_bindir}/$arch*-gcov"
717 echo "%{_mandir}/man1/$arch*-cpp*"
718 echo "%{_mandir}/man1/$arch*-gcc*"
719 echo "%{_mandir}/man1/$arch*-gcov*"
720 case $cpu in
721 ppc*|ppc64*)
722 ;;
723 *)
724 echo "/usr/lib/gcc/$target_cpu-*/"
725 echo "%{_libexecdir}/gcc/$target_cpu*/*/cc1"
726 echo "%{_libexecdir}/gcc/$target_cpu*/*/collect2"
727 echo "%{_libexecdir}/gcc/$target_cpu*/*/[abd-z]*"
728 echo "%{_prefix}/$arch/sys-root"
729 esac
730
731 ) >files.$arch
732
733 (
734 echo "%%defattr(-,root,root,-)"
735 echo "%{_bindir}/$arch*-c++"
736 echo "%{_bindir}/$arch*-g++"
737 echo "%{_mandir}/man1/$arch*-g++*"
738 case $cpu in
739 ppc*|ppc64*)
740 ;;
741 *)
742 echo "%{_libexecdir}/gcc/$target_cpu*/*/cc1plus"
743 esac
744 ) > files-c++.$arch
745}
746
747for target in $(cat target.list symlink-target.list); do
748 install_lang $target
749done
750
751%define __ar_no_strip $RPM_BUILD_DIR/%{name}-%{version}/ar-no-strip
752cat >%{__ar_no_strip} <<'EOF'
753#!/bin/sh
754f=$2
755if [ ${f##*/} = libgcc.a -o ${f##*/} = libgcov.a ]; then
756 :
757else
758 %{__strip} $*
759fi
760EOF
761chmod +x %{__ar_no_strip}
762%undefine __strip
763%define __strip %{__ar_no_strip}
764
765%clean
766rm -rf $RPM_BUILD_ROOT
767
768%files common -f cross-gcc.lang
769%doc %{srcdir}/COPYING*
770%doc %{srcdir}/README
771%{_mandir}/man1/cross-*
772
773%define do_files() \
774%files -n gcc-%1 -f files.%1 \
775%files -n gcc-c++-%1 -f files-c++.%1 \
776
777%{?with_alpha:%do_files alpha-linux-gnu}
778%{?with_arm:%do_files arm-linux-gnu}
779%{?with_aarch64:%do_files aarch64-linux-gnu}
780%{?with_avr32:%do_files avr32-linux-gnu}
781%{?with_blackfin:%do_files bfin-linux-gnu}
782%{?with_c6x:%do_files c6x-linux-gnu}
783%{?with_cris:%do_files cris-linux-gnu}
784%{?with_frv:%do_files frv-linux-gnu}
785%{?with_h8300:%do_files h8300-linux-gnu}
786%{?with_hppa:%do_files hppa-linux-gnu}
787%{?with_hppa64:%do_files hppa64-linux-gnu}
788%{?with_i386:%do_files i386-linux-gnu}
789%{?with_ia64:%do_files ia64-linux-gnu}
790%{?with_m32r:%do_files m32r-linux-gnu}
791%{?with_m68k:%do_files m68k-linux-gnu}
792%{?with_metag:%do_files metag-linux-gnu}
793%{?with_microblaze:%do_files microblaze-linux-gnu}
794%{?with_mips:%do_files mips-linux-gnu}
795%{?with_mips64:%do_files mips64-linux-gnu}
796%{?with_mn10300:%do_files mn10300-linux-gnu}
797%{?with_nios2:%do_files nios2-linux-gnu}
798%{?with_openrisc:%do_files openrisc-linux-gnu}
799%{?with_powerpc:%do_files powerpc-linux-gnu}
800%{?with_powerpc64:%do_files powerpc64-linux-gnu}
801%{?with_powerpc:%do_files ppc-linux-gnu}
802%{?with_powerpc64:%do_files ppc64-linux-gnu}
803%{?with_s390:%do_files s390-linux-gnu}
804%{?with_s390x:%do_files s390x-linux-gnu}
805%{?with_score:%do_files score-linux-gnu}
806%{?with_sh:%do_files sh-linux-gnu}
807%{?with_sh4:%do_files sh4-linux-gnu}
808%{?with_sh64:%do_files sh64-linux-gnu}
809%{?with_sparc:%do_files sparc-linux-gnu}
810%{?with_sparc64:%do_files sparc64-linux-gnu}
811%{?with_tile:%do_files tile-linux-gnu}
812%{?with_unicore32:%do_files unicore32-linux-gnu}
813%{?with_x86_64:%do_files x86_64-linux-gnu}
814%{?with_xtensa:%do_files xtensa-linux-gnu}
This page took 0.185017 seconds and 4 git commands to generate.