]> git.pld-linux.org Git - packages/cronie.git/commitdiff
Drop all Upstart hacks auto/th/cronie-1.4.12-5
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 23 Apr 2015 06:54:15 +0000 (08:54 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 23 Apr 2015 06:54:15 +0000 (08:54 +0200)
Release: 5

cronie.init
cronie.spec
cronie.upstart [deleted file]

index 10d19270d37dcf89a6229cd1b2231b42b03c1b27..f86537bac61fdddcc61802df4462d82fc6c21334 100644 (file)
@@ -77,8 +77,6 @@ condrestart() {
        start
 }
 
-upstart_controlled
-
 RETVAL=0
 # See how we were called.
 case "$1" in
index 90f75990e8cd182c5a26c410451b4ff877336656..56e7073bc000baa71b6242ed483f2fad7476378e 100644 (file)
@@ -17,7 +17,7 @@
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.12
-Release:       4
+Release:       5
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
@@ -27,8 +27,7 @@ Source2:      cron.logrotate
 Source3:       cron.sysconfig
 Source4:       %{name}.crontab
 Source5:       %{name}.pam
-Source6:       %{name}.upstart
-Source7:       crond.service
+Source6:       crond.service
 Patch0:                inotify-nosys.patch
 Patch1:                sendmail-path.patch
 URL:           https://fedorahosted.org/cronie/
@@ -83,19 +82,6 @@ Anacron becames part of cronie. Anacron is used only for running
 regular jobs. The default settings execute regular jobs by anacron,
 however this could be overloaded in settings.
 
-%package upstart
-Summary:       Upstart job description for Cronie
-Summary(pl.UTF-8):     Opis zadania Upstart dla Cronie
-Group:         Daemons
-Requires:      %{name} = %{version}-%{release}
-Requires:      upstart >= 0.6
-
-%description upstart
-Upstart job description for Cronie.
-
-%description upstart -l pl.UTF-8
-Opis zadania Upstart dla Cronie.
-
 %prep
 %setup -q
 %patch0 -p1
@@ -127,7 +113,7 @@ Opis zadania Upstart dla Cronie.
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
 %{__make} install \
@@ -148,8 +134,7 @@ cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
 cp -a crond.pam  $RPM_BUILD_ROOT/etc/pam.d/crond
-cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
-cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
+cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
 
 touch $RPM_BUILD_ROOT/var/log/cron
 
@@ -217,12 +202,6 @@ chmod 754 /etc/rc.d/init.d/crond
 /sbin/chkconfig --del crond
 /sbin/chkconfig --add crond
 
-%post upstart
-%upstart_post crond
-
-%postun upstart
-%upstart_postun crond
-
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
@@ -259,9 +238,3 @@ chmod 754 /etc/rc.d/init.d/crond
 %{_mandir}/man8/anacron.8*
 
 %attr(1730,root,crontab) /var/spool/anacron
-
-%if "%{pld_release}" == "th"
-%files upstart
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
-%endif
diff --git a/cronie.upstart b/cronie.upstart
deleted file mode 100644 (file)
index 75c3c8d..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-description "Cronie - the cron daemon"
-
-start on pld.sysinit-done
-stop on pld.shutdown-started
-
-# This option will direct cron to send job output to the system log using syslog(3).
-# This is useful if your system has no sendmail(8), or if mail is disabled using "off".
-env CROND_SYSLOG_RESULT="no"
-
-# This option allows you to specify a shell command string to use
-# for sending cron mail output instead of sendmail(8).
-# This command must accept a fully formatted mail message (with headers) on
-# stdin and send it as a mail message to the recipients specified in the mail
-# headers.
-# As a special case, the string "off" will disable sending mail.
-#env CROND_MAIL_PROG="/usr/lib/sendmail"
-env CROND_MAIL_PROG
-
-respawn
-
-script
-       CROND_ARGS=""
-       # Read the old-style service config
-       [ -f /etc/sysconfig/cron ] && . /etc/sysconfig/cron
-
-       # no 'is_yes' as we don't want the havy init.d/functions here
-       if [ "$CROND_SYSLOG_RESULT" = "yes" ] ; then
-               CROND_ARGS="$CROND_ARGS -s"
-       fi
-
-       if [ -n "$CROND_MAIL_PROG" ]; then
-               # XXX: should we handle spaces in $CROND_MAIL_PROG?
-               CROND_ARGS="$CROND_ARGS -m $CROND_MAIL_PROG"
-       fi
-
-       exec /usr/sbin/crond -n $CROND_ARGS
-end script
This page took 0.051175 seconds and 4 git commands to generate.