]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
- up to 1.4.12
[packages/cronie.git] / cronie.spec
index 583838cc38b927161b11cc1de894500d7a4e7028..f59eda879231750142c9a28e511c064e8e381e80 100644 (file)
@@ -9,28 +9,19 @@
 %if "%{pld_release}" == "ac"
 %bcond_with            selinux         # with SELinux support
 %bcond_with            audit           # with audit support
-%bcond_with            systemd         # with systemd units
 %else
 %bcond_without selinux         # without SELinux support
 %bcond_without audit           # without audit support
-%bcond_with            systemd         # without systemd units
-%endif
-
-%if %{without systemd}
-%define        systemd_post() %{nil}
-%define        systemd_preun() %{nil}
-%define        systemd_reload() %{nil}
-%define        systemd_trigger() %{nil}
 %endif
 
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
-Version:       1.4.8
-Release:       17
+Version:       1.4.12
+Release:       1
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
-# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
+# Source0-md5: 199db91e514a4d75e3222d69874b132f
 Source1:       %{name}.init
 Source2:       cron.logrotate
 Source3:       cron.sysconfig
@@ -39,9 +30,7 @@ Source5:      %{name}.pam
 Source6:       %{name}.upstart
 Source7:       crond.service
 Patch0:                inotify-nosys.patch
-Patch1:                %{name}-nosyscrontab.patch
-Patch2:                sendmail-path.patch
-Patch3:                cronie-1.4.8-inotify-fix.patch
+Patch1:                sendmail-path.patch
 URL:           https://fedorahosted.org/cronie/
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf
@@ -49,7 +38,7 @@ BuildRequires:        automake
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.626
+BuildRequires: rpmbuild(macros) >= 1.647
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -58,7 +47,10 @@ Requires(pre):       /usr/sbin/groupadd
 Requires:      /bin/run-parts
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.3.0
-%{?with_systemd:Requires:      systemd-units >= 37-0.10}
+%if "%{pld_release}" != "ac"
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      systemd-units >= 38}
+%endif
 %{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
@@ -108,8 +100,6 @@ Opis zadania Upstart dla Cronie.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
 %{__aclocal}
@@ -120,10 +110,12 @@ Opis zadania Upstart dla Cronie.
        SYSCRONTAB=/etc/crontab \
        SYS_CROND_DIR=/etc/cron.d \
        --sysconfdir=/etc/cron \
+       --with-editor=/bin/vi \
        --with-pam \
        --with%{!?with_selinux:out}-selinux \
        --with%{!?with_audit:out}-audit \
        --with%{!?with_inotify:out}-inotify \
+       --disable-syscrontab \
 %if "%{cc_version}" >= "3.4"
        --enable-pie \
 %endif
@@ -142,12 +134,19 @@ install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitd
        pamdir=/etc/pam.d \
        DESTDIR=$RPM_BUILD_ROOT
 
+cp -p %{SOURCE5} crond.pam
+
+%if %{without audit}
+# remove recording user's login uid to the process attribute
+%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
+%endif
+
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
-cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
+cp -a crond.pam  $RPM_BUILD_ROOT/etc/pam.d/crond
 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
 
@@ -206,11 +205,11 @@ if [ -f /etc/sysconfig/cron ]; then
 fi
 %systemd_trigger crond.service
 
-%triggerun -- hc-cron,fcron,vixie-cron
+%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
 # Prevent preun from crond from working
 chmod a-x /etc/rc.d/init.d/crond
 
-%triggerpostun -- hc-cron,fcron,vixie-cron
+%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
 # Restore what triggerun removed
 chmod 754 /etc/rc.d/init.d/crond
 # reinstall crond init.d links, which could be different
@@ -234,7 +233,7 @@ chmod 754 /etc/rc.d/init.d/crond
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
 %attr(754,root,root) /etc/rc.d/init.d/crond
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
-%{?with_systemd:%{systemdunitdir}/crond.service}
+%{systemdunitdir}/crond.service
 %attr(755,root,root) %{_sbindir}/crond
 %attr(2755,root,crontab) %{_bindir}/crontab
 
This page took 0.045171 seconds and 4 git commands to generate.