]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
Rel 4; make cronie restart itself when PAM problems happen.
[packages/cronie.git] / cronie.spec
index 2907777814e44fd71b4cc31367831c2bd5e4182b..c7b5da6ce59f87b655d8a46b250c69b7331871db 100644 (file)
 %endif
 
 Summary:       Cron daemon for executing programs at set times
+Summary(pl.UTF-8):     Demon cron do uruchamiania programów o zadanym czasie
 Name:          cronie
-Version:       1.5.0
+Version:       1.5.7
 Release:       4
 License:       MIT and BSD and GPL v2
 Group:         Daemons
-Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
-# Source0-md5: 9db75e1884d83a45e002d145c6c54d45
+Source0:       https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 544f141aa4e34e0a176529be08441756
 Source1:       %{name}.init
 Source3:       cron.sysconfig
 Source4:       %{name}.crontab
@@ -29,10 +30,9 @@ Source5:     %{name}.pam
 Source6:       crond.service
 Patch0:                inotify-nosys.patch
 Patch1:                sendmail-path.patch
-Patch2:                cronie-temp.patch
-URL:           https://fedorahosted.org/cronie/
+URL:           https://github.com/cronie-crond/cronie/
 %{?with_audit:BuildRequires:   audit-libs-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: glibc-devel >= 6:2.21
 %{?with_selinux:BuildRequires: libselinux-devel}
@@ -54,6 +54,7 @@ Requires:     systemd-units >= 38}
 %{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
+Provides:      cronjobs
 Provides:      group(crontab)
 %if "%{pld_release}" == "th"
 Provides:      vixie-cron = 4.3-1
@@ -61,6 +62,7 @@ Provides:     vixie-cron = 4.3-1
 Obsoletes:     crondaemon
 Obsoletes:     cronie-systemd
 Obsoletes:     crontabs
+Obsoletes:     cronjobs
 %if "%{pld_release}" == "th"
 Obsoletes:     vixie-cron < 4.3-1
 %endif
@@ -73,10 +75,18 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Cronie contains the standard UNIX daemon crond that runs specified
 programs at scheduled times and related tools. It is based on the
 original cron and has security and configuration enhancements like the
-ability to use pam and SELinux.
+ability to use PAM and SELinux.
+
+%description -l pl.UTF-8
+Cronie zawiera standardowego demona uniksowego crond, uruchamiającego
+podane programy o zadanym czasie, oraz powiązane narzędzia. Jest
+oparty na oryginalnym cronie i zawiera rozszerzenia bezpieczeństwa i
+konfiguracji, takie jak możliwość wykorzystania mechanizmów PAM i
+SELinux.
 
 %package anacron
 Summary:       Utility for running regular jobs
+Summary(pl.UTF-8):     Narzędzie do uruchamiania regularnych zadań
 Group:         Base
 Provides:      anacron = 2.4
 Obsoletes:     anacron <= 2.3
@@ -86,11 +96,15 @@ Anacron becames part of cronie. Anacron is used only for running
 regular jobs. The default settings execute regular jobs by anacron,
 however this could be overloaded in settings.
 
+%description anacron -l pl.UTF-8
+Anacron stał się częścią cronie. Służy tylko do uruchamiania
+regularnych zadań. Domyślne ustawienia wykonują zadania przy użyciu
+anacrona, ale może to być zmienione w ustawieniach.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 %{__aclocal}
@@ -102,16 +116,17 @@ however this could be overloaded in settings.
        SYS_CROND_DIR=/etc/cron.d \
        --sysconfdir=/etc/cron \
        --with-editor=/bin/vi \
+       --with-audit%{!?with_audit:=no} \
+       --with-inotify%{!?with_inotify:=no} \
        --with-pam \
-       --with%{!?with_selinux:out}-selinux \
-       --with%{!?with_audit:out}-audit \
-       --with%{!?with_inotify:out}-inotify \
+       --with-selinux%{!?with_selinux:=no} \
+       --disable-silent-rules \
        --disable-syscrontab \
+       --enable-anacron \
 %if "%{cc_version}" >= "3.4"
        --enable-pie \
 %endif
-       --enable-relro \
-       --enable-anacron
+       --enable-relro
 
 %{__make}
 
@@ -151,6 +166,18 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
 #              NOT allowed to use the local cron daemon
 EOF
 
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/check-crond << 'EOF'
+#!/bin/sh
+
+# ugly and limited hack. make cronie restart itself
+if [ -x /bin/awk -a -x /bin/grep -a -f /var/log/cron ]; then
+       LC_ALL=C /bin/awk -v d="$(LC_ALL=C date "+%b %e")" ' $1 " " $2 ~ d' /var/log/cron \
+               | /bin/grep -qE "PAM.*(Modu. jest nieznany|Module is unknown)" \
+               && echo "crond is failing on PAM, restarting ( https://github.com/cronie-crond/cronie/issues/87 )" >&2 \
+               && /sbin/service crond restart
+fi
+EOF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -206,6 +233,7 @@ chmod 754 /etc/rc.d/init.d/crond
 %doc AUTHORS ChangeLog README
 %attr(750,root,crontab) %dir /etc/cron
 %attr(750,root,crontab) %dir /etc/cron.daily
+%attr(750,root,root) /etc/cron.daily/check-crond
 %attr(750,root,crontab) %dir /etc/cron.hourly
 %attr(750,root,crontab) %dir /etc/cron.monthly
 %attr(750,root,crontab) %dir /etc/cron.weekly
@@ -217,11 +245,13 @@ chmod 754 /etc/rc.d/init.d/crond
 %attr(754,root,root) /etc/rc.d/init.d/crond
 %{systemdunitdir}/crond.service
 %attr(755,root,root) %{_sbindir}/crond
+%attr(2755,root,crontab) %{_bindir}/cronnext
 %attr(2755,root,crontab) %{_bindir}/crontab
 
 %{_mandir}/man8/crond.8*
 %{_mandir}/man8/cron.8*
 %{_mandir}/man5/crontab.5*
+%{_mandir}/man1/cronnext.1*
 %{_mandir}/man1/crontab.1*
 
 %attr(1730,root,crontab) /var/spool/cron
This page took 0.043582 seconds and 4 git commands to generate.