]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- updated to 1.4.8
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # without SELinux support
11 %bcond_with             audit           # without audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.8
20 Release:        1
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  9b1d2ce6db8d1883e06635f437170657
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Patch0:         inotify-nosys.patch
32 Patch1:         %{name}-nosyscrontab.patch
33 Patch2:         sendmail-path.patch
34 URL:            https://fedorahosted.org/cronie/
35 %{?with_audit:BuildRequires:    audit-libs-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_selinux:BuildRequires:  libselinux-devel}
39 BuildRequires:  pam-devel
40 BuildRequires:  rpm >= 4.4.9-56
41 BuildRequires:  rpmbuild(macros) >= 1.561
42 Requires(post): fileutils
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires:       /bin/run-parts
48 Requires:       /sbin/chkconfig
49 Requires:       psmisc >= 20.1
50 Requires:       rc-scripts >= 0.4.3.0
51 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
52 Provides:       crondaemon
53 Provides:       crontabs = 1.7
54 Provides:       group(crontab)
55 %if "%{pld_release}" == "th"
56 Provides:       vixie-cron = 4:4.4
57 %endif
58 Obsoletes:      crondaemon
59 Obsoletes:      crontabs
60 %if "%{pld_release}" == "th"
61 Obsoletes:      vixie-cron <= 4:4.3
62 %endif
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Cronie contains the standard UNIX daemon crond that runs specified
67 programs at scheduled times and related tools. It is based on the
68 original cron and has security and configuration enhancements like the
69 ability to use pam and SELinux.
70
71 %package anacron
72 Summary:        Utility for running regular jobs
73 Group:          Base
74 Provides:       anacron = 2.4
75 Obsoletes:      anacron <= 2.3
76
77 %description anacron
78 Anacron becames part of cronie. Anacron is used only for running
79 regular jobs. The default settings execute regular jobs by anacron,
80 however this could be overloaded in settings.
81
82 %package upstart
83 Summary:        Upstart job description for Cronie
84 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
85 Group:          Daemons
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       upstart >= 0.6
88
89 %description upstart
90 Upstart job description for Cronie.
91
92 %description upstart -l pl.UTF-8
93 Opis zadania Upstart dla Cronie.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         SYSCRONTAB=/etc/crontab \
108         SYS_CROND_DIR=/etc/cron.d \
109         --sysconfdir=/etc/cron \
110         --with-pam \
111         --with%{!?with_selinux:out}-selinux \
112         --with%{!?with_audit:out}-audit \
113         --with%{!?with_inotify:out}-inotify \
114         --enable-pie \
115         --enable-relro \
116         --enable-anacron
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
123         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
124         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
125
126 %{__make} install \
127         pamdir=/etc/pam.d \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
131 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
132 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
133 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
134 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
135 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
136 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
137
138 touch $RPM_BUILD_ROOT/var/log/cron
139
140 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
141 # cron.allow    This file describes the names of the users which are
142 #               allowed to use the local cron daemon
143 root
144 EOF
145
146 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
147 # cron.deny     This file describes the names of the users which are
148 #               NOT allowed to use the local cron daemon
149 EOF
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 %groupadd -g 117 -r -f crontab
156
157 %post
158 if [ ! -f /var/log/cron ]; then
159         install -m 660 -g crontab /dev/null /var/log/cron
160 fi
161 /sbin/chkconfig --add crond
162 %service crond restart "Cron Daemon"
163
164 %preun
165 if [ "$1" = "0" ]; then
166         %service crond stop
167         /sbin/chkconfig --del crond
168 fi
169
170 %postun
171 if [ "$1" = "0" ]; then
172         %groupremove crontab
173 fi
174
175 %triggerun -- hc-cron,fcron,vixie-cron
176 # Prevent preun from crond from working
177 chmod a-x /etc/rc.d/init.d/crond
178
179 %triggerpostun -- hc-cron,fcron,vixie-cron
180 # Restore what triggerun removed
181 chmod 754 /etc/rc.d/init.d/crond
182 # reinstall crond init.d links, which could be different
183 /sbin/chkconfig --del crond
184 /sbin/chkconfig --add crond
185
186 %post upstart
187 %upstart_post crond
188
189 %postun upstart
190 %upstart_postun crond
191
192 %files
193 %defattr(644,root,root,755)
194 %doc AUTHORS ChangeLog README
195 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
196 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
197 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
198 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
199 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
200 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
201 %attr(754,root,root) /etc/rc.d/init.d/crond
202 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
203 %attr(755,root,root) %{_sbindir}/crond
204 %attr(2755,root,crontab) %{_bindir}/crontab
205
206 %{_mandir}/man8/crond.8*
207 %{_mandir}/man8/cron.8*
208 %{_mandir}/man5/crontab.5*
209 %{_mandir}/man1/crontab.1*
210
211 %attr(1730,root,crontab) /var/spool/cron
212 %attr(660,root,crontab) %ghost /var/log/cron
213
214 %files anacron
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_sbindir}/anacron
217 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
218 %{_mandir}/man5/anacrontab.5*
219 %{_mandir}/man8/anacron.8*
220
221 %attr(1730,root,crontab) /var/spool/anacron
222
223 %if "%{pld_release}" != "ti"
224 %files upstart
225 %defattr(644,root,root,755)
226 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
227 %endif
This page took 0.053952 seconds and 4 git commands to generate.