]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- %*post scripts for systemd
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # without SELinux support
11 %bcond_with             audit           # without audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.8
20 Release:        5
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  9b1d2ce6db8d1883e06635f437170657
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Source7:        crond.service
32 Patch0:         inotify-nosys.patch
33 Patch1:         %{name}-nosyscrontab.patch
34 Patch2:         sendmail-path.patch
35 URL:            https://fedorahosted.org/cronie/
36 %{?with_audit:BuildRequires:    audit-libs-devel}
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 %{?with_selinux:BuildRequires:  libselinux-devel}
40 BuildRequires:  pam-devel
41 BuildRequires:  rpm >= 4.4.9-56
42 BuildRequires:  rpmbuild(macros) >= 1.623
43 Requires(post): fileutils
44 Requires(post,preun):   /sbin/chkconfig
45 Requires(postun):       /usr/sbin/groupdel
46 Requires(pre):  /usr/bin/getgid
47 Requires(pre):  /usr/sbin/groupadd
48 Requires:       /bin/run-parts
49 Requires:       psmisc >= 20.1
50 Requires:       rc-scripts >= 0.4.3.0
51 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
52 Provides:       crondaemon
53 Provides:       crontabs = 1.7
54 Provides:       group(crontab)
55 %if "%{pld_release}" == "th"
56 Provides:       vixie-cron = 4.3-1
57 %endif
58 Obsoletes:      crondaemon
59 Obsoletes:      crontabs
60 %if "%{pld_release}" == "th"
61 Obsoletes:      vixie-cron < 4.3-1
62 %endif
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Cronie contains the standard UNIX daemon crond that runs specified
67 programs at scheduled times and related tools. It is based on the
68 original cron and has security and configuration enhancements like the
69 ability to use pam and SELinux.
70
71 %package anacron
72 Summary:        Utility for running regular jobs
73 Group:          Base
74 Provides:       anacron = 2.4
75 Obsoletes:      anacron <= 2.3
76
77 %description anacron
78 Anacron becames part of cronie. Anacron is used only for running
79 regular jobs. The default settings execute regular jobs by anacron,
80 however this could be overloaded in settings.
81
82 %package upstart
83 Summary:        Upstart job description for Cronie
84 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
85 Group:          Daemons
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       upstart >= 0.6
88
89 %description upstart
90 Upstart job description for Cronie.
91
92 %description upstart -l pl.UTF-8
93 Opis zadania Upstart dla Cronie.
94
95 %package systemd
96 Summary:        systemd units for cronie
97 Group:          Base
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       systemd-units
100
101 %description systemd
102 systemd units for cronie.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         SYSCRONTAB=/etc/crontab \
117         SYS_CROND_DIR=/etc/cron.d \
118         --sysconfdir=/etc/cron \
119         --with-pam \
120         --with%{!?with_selinux:out}-selinux \
121         --with%{!?with_audit:out}-audit \
122         --with%{!?with_inotify:out}-inotify \
123         --enable-pie \
124         --enable-relro \
125         --enable-anacron
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},/lib/systemd/system}\
132         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
133         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
134
135 %{__make} install \
136         pamdir=/etc/pam.d \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
140 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
141 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
142 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
143 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
144 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
145 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
146 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
147 ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
148
149 touch $RPM_BUILD_ROOT/var/log/cron
150
151 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
152 # cron.allow    This file describes the names of the users which are
153 #               allowed to use the local cron daemon
154 root
155 EOF
156
157 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
158 # cron.deny     This file describes the names of the users which are
159 #               NOT allowed to use the local cron daemon
160 EOF
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %pre
166 %groupadd -g 117 -r -f crontab
167
168 %post
169 if [ ! -f /var/log/cron ]; then
170         install -m 660 -g crontab /dev/null /var/log/cron
171 fi
172 /sbin/chkconfig --add crond
173 %service crond restart "Cron Daemon"
174
175 %preun
176 if [ "$1" = "0" ]; then
177         %service crond stop
178         /sbin/chkconfig --del crond
179 fi
180
181 %postun
182 if [ "$1" = "0" ]; then
183         %groupremove crontab
184 fi
185
186 %triggerun -- hc-cron,fcron,vixie-cron
187 # Prevent preun from crond from working
188 chmod a-x /etc/rc.d/init.d/crond
189
190 %triggerpostun -- hc-cron,fcron,vixie-cron
191 # Restore what triggerun removed
192 chmod 754 /etc/rc.d/init.d/crond
193 # reinstall crond init.d links, which could be different
194 /sbin/chkconfig --del crond
195 /sbin/chkconfig --add crond
196
197 %post upstart
198 %upstart_post crond
199
200 %postun upstart
201 %upstart_postun crond
202
203 %post systemd
204 %systemd_post
205 %systemd_enable cronie.service
206
207 %preun systemd
208 %systemd_preun cornie.service
209
210 %postun systemd
211 %systemd_postun cornie.service
212
213 %files
214 %defattr(644,root,root,755)
215 %doc AUTHORS ChangeLog README
216 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
217 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
218 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
219 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
220 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
221 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
222 %attr(754,root,root) /etc/rc.d/init.d/crond
223 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
224 %attr(755,root,root) %{_sbindir}/crond
225 %attr(2755,root,crontab) %{_bindir}/crontab
226
227 %{_mandir}/man8/crond.8*
228 %{_mandir}/man8/cron.8*
229 %{_mandir}/man5/crontab.5*
230 %{_mandir}/man1/crontab.1*
231
232 %attr(1730,root,crontab) /var/spool/cron
233 %attr(660,root,crontab) %ghost /var/log/cron
234
235 %files anacron
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_sbindir}/anacron
238 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
239 %{_mandir}/man5/anacrontab.5*
240 %{_mandir}/man8/anacron.8*
241
242 %attr(1730,root,crontab) /var/spool/anacron
243
244 %if "%{pld_release}" != "ti"
245 %files upstart
246 %defattr(644,root,root,755)
247 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
248 %endif
249
250 %files systemd
251 %defattr(644,root,root,755)
252 %{systemdunitdir}/crond.service
253 %{systemdunitdir}/cronie.service
This page took 0.042262 seconds and 4 git commands to generate.