]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- pam trigger in pam package, where it is more natural; rel 4
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # without SELinux support
11 %bcond_with             audit           # without audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.6
20 Release:        4
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  968e3d3e7c8e1d0588d533883482d3fa
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Patch0:         inotify-nosys.patch
32 Patch1:         %{name}-nosyscrontab.patch
33 Patch2:         sendmail-path.patch
34 URL:            https://fedorahosted.org/cronie/
35 %{?with_audit:BuildRequires:    audit-libs-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_selinux:BuildRequires:  libselinux-devel}
39 BuildRequires:  pam-devel
40 BuildRequires:  rpm >= 4.4.9-56
41 BuildRequires:  rpmbuild(macros) >= 1.561
42 Requires(post): fileutils
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires:       /bin/run-parts
48 Requires:       /sbin/chkconfig
49 Requires:       psmisc >= 20.1
50 Requires:       rc-scripts >= 0.4.3.0
51 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
52 Provides:       crondaemon
53 Provides:       crontabs = 1.7
54 Provides:       group(crontab)
55 %if "%{pld_release}" == "th"
56 Provides:       vixie-cron = 4:4.4
57 %endif
58 Obsoletes:      crondaemon
59 Obsoletes:      crontabs
60 %if "%{pld_release}" == "th"
61 Obsoletes:      vixie-cron <= 4:4.3
62 %endif
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Cronie contains the standard UNIX daemon crond that runs specified
67 programs at scheduled times and related tools. It is based on the
68 original cron and has security and configuration enhancements like the
69 ability to use pam and SELinux.
70
71 %package anacron
72 Summary:        Utility for running regular jobs
73 Group:          Base
74 Provides:       anacron = 2.4
75 Obsoletes:      anacron <= 2.3
76
77 %description anacron
78 Anacron becames part of cronie. Anacron is used only for running
79 regular jobs. The default settings execute regular jobs by anacron,
80 however this could be overloaded in settings.
81
82 %package upstart
83 Summary:        Upstart job description for Cronie
84 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
85 Group:          Daemons
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       upstart >= 0.6
88
89 %description upstart
90 Upstart job description for Cronie.
91
92 %description upstart -l pl.UTF-8
93 Opis zadania Upstart dla Cronie.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         SYSCRONTAB=/etc/crontab \
108         SYS_CROND_DIR=/etc/cron.d \
109         --sysconfdir=/etc/cron \
110         --with-pam \
111         --with%{!?with_selinux:out}-selinux \
112         --with%{!?with_audit:out}-audit \
113         --with%{!?with_inotify:out}-inotify \
114         --enable-anacron
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
121         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
122         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
123
124 %{__make} install \
125         pamdir=/etc/pam.d \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
129 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
130 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
131 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
132 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
133 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
134 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
135
136 touch $RPM_BUILD_ROOT/var/log/cron
137
138 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
139 # cron.allow    This file describes the names of the users which are
140 #               allowed to use the local cron daemon
141 root
142 EOF
143
144 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
145 # cron.deny     This file describes the names of the users which are
146 #               NOT allowed to use the local cron daemon
147 EOF
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %pre
153 %groupadd -g 117 -r -f crontab
154
155 %post
156 if [ ! -f /var/log/cron ]; then
157         install -m 660 -g crontab /dev/null /var/log/cron
158 fi
159 /sbin/chkconfig --add crond
160 %service crond restart "Cron Daemon"
161
162 %preun
163 if [ "$1" = "0" ]; then
164         %service crond stop
165         /sbin/chkconfig --del crond
166 fi
167
168 %postun
169 if [ "$1" = "0" ]; then
170         %groupremove crontab
171 fi
172
173 %triggerun -- hc-cron,fcron,vixie-cron
174 # Prevent preun from crond from working
175 chmod a-x /etc/rc.d/init.d/crond
176
177 %triggerpostun -- hc-cron,fcron,vixie-cron
178 # Restore what triggerun removed
179 chmod 754 /etc/rc.d/init.d/crond
180 # reinstall crond init.d links, which could be different
181 /sbin/chkconfig --del crond
182 /sbin/chkconfig --add crond
183
184 %post upstart
185 %upstart_post crond
186
187 %postun upstart
188 %upstart_postun crond
189
190 %files
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog README
193 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
194 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
195 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
196 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
198 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
199 %attr(754,root,root) /etc/rc.d/init.d/crond
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
201 %attr(755,root,root) %{_sbindir}/crond
202 %attr(2755,root,crontab) %{_bindir}/crontab
203
204 %{_mandir}/man8/crond.8*
205 %{_mandir}/man8/cron.8*
206 %{_mandir}/man5/crontab.5*
207 %{_mandir}/man1/crontab.1*
208
209 %attr(1730,root,crontab) /var/spool/cron
210 %attr(660,root,crontab) %ghost /var/log/cron
211
212 %files anacron
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_sbindir}/anacron
215 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
216 %{_mandir}/man5/anacrontab.5*
217 %{_mandir}/man8/anacron.8*
218
219 %attr(1730,root,crontab) /var/spool/anacron
220
221 %if "%{pld_release}" != "ti"
222 %files upstart
223 %defattr(644,root,root,755)
224 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
225 %endif
This page took 0.080727 seconds and 4 git commands to generate.