]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- rel 12
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # without SELinux support
11 %bcond_with             audit           # without audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.8
20 Release:        12
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  9b1d2ce6db8d1883e06635f437170657
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Source7:        crond.service
32 Patch0:         inotify-nosys.patch
33 Patch1:         %{name}-nosyscrontab.patch
34 Patch2:         sendmail-path.patch
35 URL:            https://fedorahosted.org/cronie/
36 %{?with_audit:BuildRequires:    audit-libs-devel}
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 %{?with_selinux:BuildRequires:  libselinux-devel}
40 BuildRequires:  pam-devel
41 BuildRequires:  rpm >= 4.4.9-56
42 BuildRequires:  rpmbuild(macros) >= 1.626
43 Requires(post): fileutils
44 Requires(post,preun):   /sbin/chkconfig
45 Requires(postun):       /usr/sbin/groupdel
46 Requires(pre):  /usr/bin/getgid
47 Requires(pre):  /usr/sbin/groupadd
48 Requires:       /bin/run-parts
49 Requires:       psmisc >= 20.1
50 Requires:       rc-scripts >= 0.4.3.0
51 Requires:       systemd-units >= 37-0.10
52 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
53 Provides:       crondaemon
54 Provides:       crontabs = 1.7
55 Provides:       group(crontab)
56 %if "%{pld_release}" == "th"
57 Provides:       vixie-cron = 4.3-1
58 %endif
59 Obsoletes:      crondaemon
60 Obsoletes:      cronie-systemd
61 Obsoletes:      crontabs
62 %if "%{pld_release}" == "th"
63 Obsoletes:      vixie-cron < 4.3-1
64 %endif
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Cronie contains the standard UNIX daemon crond that runs specified
69 programs at scheduled times and related tools. It is based on the
70 original cron and has security and configuration enhancements like the
71 ability to use pam and SELinux.
72
73 %package anacron
74 Summary:        Utility for running regular jobs
75 Group:          Base
76 Provides:       anacron = 2.4
77 Obsoletes:      anacron <= 2.3
78
79 %description anacron
80 Anacron becames part of cronie. Anacron is used only for running
81 regular jobs. The default settings execute regular jobs by anacron,
82 however this could be overloaded in settings.
83
84 %package upstart
85 Summary:        Upstart job description for Cronie
86 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
87 Group:          Daemons
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       upstart >= 0.6
90
91 %description upstart
92 Upstart job description for Cronie.
93
94 %description upstart -l pl.UTF-8
95 Opis zadania Upstart dla Cronie.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         SYSCRONTAB=/etc/crontab \
110         SYS_CROND_DIR=/etc/cron.d \
111         --sysconfdir=/etc/cron \
112         --with-pam \
113         --with%{!?with_selinux:out}-selinux \
114         --with%{!?with_audit:out}-audit \
115         --with%{!?with_inotify:out}-inotify \
116         --enable-pie \
117         --enable-relro \
118         --enable-anacron
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
125         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
126         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
127
128 %{__make} install \
129         pamdir=/etc/pam.d \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
133 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
134 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
135 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
136 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
137 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
138 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
139 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
140 ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
141
142 touch $RPM_BUILD_ROOT/var/log/cron
143
144 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
145 # cron.allow    This file describes the names of the users which are
146 #               allowed to use the local cron daemon
147 root
148 EOF
149
150 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
151 # cron.deny     This file describes the names of the users which are
152 #               NOT allowed to use the local cron daemon
153 EOF
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %pre
159 %groupadd -g 117 -r -f crontab
160
161 %post
162 if [ ! -f /var/log/cron ]; then
163         install -m 660 -g crontab /dev/null /var/log/cron
164 fi
165 /sbin/chkconfig --add crond
166 %service crond restart "Cron Daemon"
167 %systemd_post cronie.service
168
169 %preun
170 if [ "$1" = "0" ]; then
171         %service crond stop
172         /sbin/chkconfig --del crond
173 fi
174 %systemd_preun cronie.service
175
176 %postun
177 if [ "$1" = "0" ]; then
178         %groupremove crontab
179 fi
180 %systemd_reload
181
182 %triggerpostun -- cronie < 1.4.8-11
183 if [ -f /etc/sysconfig/cron ]; then
184         . /etc/sysconfig/cron
185         __CROND_ARGS=
186         [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
187         [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
188         [ -z "$__CROND_ARGS" ] && exit 0
189         cp -f /etc/sysconfig/cron{,.rpmsave}
190         echo >>/etc/sysconfig/cron
191         echo "# Added by rpm trigger" >>/etc/sysconfig/cron
192         echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
193 fi
194 %systemd_trigger cronie.service
195
196 %triggerun -- hc-cron,fcron,vixie-cron
197 # Prevent preun from crond from working
198 chmod a-x /etc/rc.d/init.d/crond
199
200 %triggerpostun -- hc-cron,fcron,vixie-cron
201 # Restore what triggerun removed
202 chmod 754 /etc/rc.d/init.d/crond
203 # reinstall crond init.d links, which could be different
204 /sbin/chkconfig --del crond
205 /sbin/chkconfig --add crond
206
207 %post upstart
208 %upstart_post crond
209
210 %postun upstart
211 %upstart_postun crond
212
213 %files
214 %defattr(644,root,root,755)
215 %doc AUTHORS ChangeLog README
216 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
217 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
218 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
219 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
220 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
221 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
222 %attr(754,root,root) /etc/rc.d/init.d/crond
223 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
224 %{systemdunitdir}/crond.service
225 %{systemdunitdir}/cronie.service
226 %attr(755,root,root) %{_sbindir}/crond
227 %attr(2755,root,crontab) %{_bindir}/crontab
228
229 %{_mandir}/man8/crond.8*
230 %{_mandir}/man8/cron.8*
231 %{_mandir}/man5/crontab.5*
232 %{_mandir}/man1/crontab.1*
233
234 %attr(1730,root,crontab) /var/spool/cron
235 %attr(660,root,crontab) %ghost /var/log/cron
236
237 %files anacron
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_sbindir}/anacron
240 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
241 %{_mandir}/man5/anacrontab.5*
242 %{_mandir}/man8/anacron.8*
243
244 %attr(1730,root,crontab) /var/spool/anacron
245
246 %if "%{pld_release}" != "ti"
247 %files upstart
248 %defattr(644,root,root,755)
249 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
250 %endif
This page took 0.092035 seconds and 4 git commands to generate.