]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- rel 9
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # without SELinux support
11 %bcond_with             audit           # without audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.8
20 Release:        9
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  9b1d2ce6db8d1883e06635f437170657
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Source7:        crond.service
32 Patch0:         inotify-nosys.patch
33 Patch1:         %{name}-nosyscrontab.patch
34 Patch2:         sendmail-path.patch
35 URL:            https://fedorahosted.org/cronie/
36 %{?with_audit:BuildRequires:    audit-libs-devel}
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 %{?with_selinux:BuildRequires:  libselinux-devel}
40 BuildRequires:  pam-devel
41 BuildRequires:  rpm >= 4.4.9-56
42 BuildRequires:  rpmbuild(macros) >= 1.626
43 Requires(post): fileutils
44 Requires(post,preun):   /sbin/chkconfig
45 Requires(postun):       /usr/sbin/groupdel
46 Requires(pre):  /usr/bin/getgid
47 Requires(pre):  /usr/sbin/groupadd
48 Requires:       /bin/run-parts
49 Requires:       psmisc >= 20.1
50 Requires:       rc-scripts >= 0.4.3.0
51 Requires:       systemd-units >= 37-0.10
52 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
53 Provides:       crondaemon
54 Provides:       crontabs = 1.7
55 Provides:       group(crontab)
56 %if "%{pld_release}" == "th"
57 Provides:       vixie-cron = 4.3-1
58 %endif
59 Obsoletes:      crondaemon
60 Obsoletes:      crontabs
61 %if "%{pld_release}" == "th"
62 Obsoletes:      vixie-cron < 4.3-1
63 %endif
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Cronie contains the standard UNIX daemon crond that runs specified
68 programs at scheduled times and related tools. It is based on the
69 original cron and has security and configuration enhancements like the
70 ability to use pam and SELinux.
71
72 %package anacron
73 Summary:        Utility for running regular jobs
74 Group:          Base
75 Provides:       anacron = 2.4
76 Obsoletes:      anacron <= 2.3
77
78 %description anacron
79 Anacron becames part of cronie. Anacron is used only for running
80 regular jobs. The default settings execute regular jobs by anacron,
81 however this could be overloaded in settings.
82
83 %package upstart
84 Summary:        Upstart job description for Cronie
85 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
86 Group:          Daemons
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       upstart >= 0.6
89
90 %description upstart
91 Upstart job description for Cronie.
92
93 %description upstart -l pl.UTF-8
94 Opis zadania Upstart dla Cronie.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101
102 %build
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         SYSCRONTAB=/etc/crontab \
109         SYS_CROND_DIR=/etc/cron.d \
110         --sysconfdir=/etc/cron \
111         --with-pam \
112         --with%{!?with_selinux:out}-selinux \
113         --with%{!?with_audit:out}-audit \
114         --with%{!?with_inotify:out}-inotify \
115         --enable-pie \
116         --enable-relro \
117         --enable-anacron
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
124         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
125         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
126
127 %{__make} install \
128         pamdir=/etc/pam.d \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
132 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
133 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
134 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
135 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
136 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
137 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
138 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
139 ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
140
141 touch $RPM_BUILD_ROOT/var/log/cron
142
143 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
144 # cron.allow    This file describes the names of the users which are
145 #               allowed to use the local cron daemon
146 root
147 EOF
148
149 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
150 # cron.deny     This file describes the names of the users which are
151 #               NOT allowed to use the local cron daemon
152 EOF
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %pre
158 %groupadd -g 117 -r -f crontab
159
160 %post
161 if [ ! -f /var/log/cron ]; then
162         install -m 660 -g crontab /dev/null /var/log/cron
163 fi
164 /sbin/chkconfig --add crond
165 %service crond restart "Cron Daemon"
166 %systemd_post cronie.service
167
168 %preun
169 if [ "$1" = "0" ]; then
170         %service crond stop
171         /sbin/chkconfig --del crond
172 fi
173 %systemd_preun cronie.service
174
175 %postun
176 if [ "$1" = "0" ]; then
177         %groupremove crontab
178 fi
179 %systemd_reload
180
181 %triggerpostun -- cronie < 1.4.8-9
182 %systemd_trigger cronie.service
183
184 %triggerun -- hc-cron,fcron,vixie-cron
185 # Prevent preun from crond from working
186 chmod a-x /etc/rc.d/init.d/crond
187
188 %triggerpostun -- hc-cron,fcron,vixie-cron
189 # Restore what triggerun removed
190 chmod 754 /etc/rc.d/init.d/crond
191 # reinstall crond init.d links, which could be different
192 /sbin/chkconfig --del crond
193 /sbin/chkconfig --add crond
194
195 %post upstart
196 %upstart_post crond
197
198 %postun upstart
199 %upstart_postun crond
200
201 %files
202 %defattr(644,root,root,755)
203 %doc AUTHORS ChangeLog README
204 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
205 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
206 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
207 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
208 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
209 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
210 %attr(754,root,root) /etc/rc.d/init.d/crond
211 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
212 %{systemdunitdir}/crond.service
213 %{systemdunitdir}/cronie.service
214 %attr(755,root,root) %{_sbindir}/crond
215 %attr(2755,root,crontab) %{_bindir}/crontab
216
217 %{_mandir}/man8/crond.8*
218 %{_mandir}/man8/cron.8*
219 %{_mandir}/man5/crontab.5*
220 %{_mandir}/man1/crontab.1*
221
222 %attr(1730,root,crontab) /var/spool/cron
223 %attr(660,root,crontab) %ghost /var/log/cron
224
225 %files anacron
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_sbindir}/anacron
228 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
229 %{_mandir}/man5/anacrontab.5*
230 %{_mandir}/man8/anacron.8*
231
232 %attr(1730,root,crontab) /var/spool/anacron
233
234 %if "%{pld_release}" != "ti"
235 %files upstart
236 %defattr(644,root,root,755)
237 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
238 %endif
This page took 0.098429 seconds and 4 git commands to generate.