]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
- updated to 1.4.9
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # with SELinux support
11 %bcond_with             audit           # with audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Name:           cronie
19 Version:        1.4.9
20 Release:        1
21 License:        MIT and BSD and GPL v2
22 Group:          Daemons
23 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24 # Source0-md5:  9133195e5e6f824ef460f5ccc533f1b7
25 Source1:        %{name}.init
26 Source2:        cron.logrotate
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        %{name}.upstart
31 Source7:        crond.service
32 Patch0:         inotify-nosys.patch
33 Patch1:         sendmail-path.patch
34 URL:            https://fedorahosted.org/cronie/
35 %{?with_audit:BuildRequires:    audit-libs-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_selinux:BuildRequires:  libselinux-devel}
39 BuildRequires:  pam-devel
40 BuildRequires:  rpm >= 4.4.9-56
41 BuildRequires:  rpmbuild(macros) >= 1.647
42 Requires(post): fileutils
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires:       /bin/run-parts
48 Requires:       psmisc >= 20.1
49 Requires:       rc-scripts >= 0.4.3.0
50 %if "%{pld_release}" != "ac"
51 Requires(post,preun,postun):    systemd-units >= 38
52 Requires:       systemd-units >= 38}
53 %endif
54 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
55 Provides:       crondaemon
56 Provides:       crontabs = 1.7
57 Provides:       group(crontab)
58 %if "%{pld_release}" == "th"
59 Provides:       vixie-cron = 4.3-1
60 %endif
61 Obsoletes:      crondaemon
62 Obsoletes:      cronie-systemd
63 Obsoletes:      crontabs
64 %if "%{pld_release}" == "th"
65 Obsoletes:      vixie-cron < 4.3-1
66 %endif
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Cronie contains the standard UNIX daemon crond that runs specified
71 programs at scheduled times and related tools. It is based on the
72 original cron and has security and configuration enhancements like the
73 ability to use pam and SELinux.
74
75 %package anacron
76 Summary:        Utility for running regular jobs
77 Group:          Base
78 Provides:       anacron = 2.4
79 Obsoletes:      anacron <= 2.3
80
81 %description anacron
82 Anacron becames part of cronie. Anacron is used only for running
83 regular jobs. The default settings execute regular jobs by anacron,
84 however this could be overloaded in settings.
85
86 %package upstart
87 Summary:        Upstart job description for Cronie
88 Summary(pl.UTF-8):      Opis zadania Upstart dla Cronie
89 Group:          Daemons
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       upstart >= 0.6
92
93 %description upstart
94 Upstart job description for Cronie.
95
96 %description upstart -l pl.UTF-8
97 Opis zadania Upstart dla Cronie.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         SYSCRONTAB=/etc/crontab \
111         SYS_CROND_DIR=/etc/cron.d \
112         --sysconfdir=/etc/cron \
113         --with-pam \
114         --with%{!?with_selinux:out}-selinux \
115         --with%{!?with_audit:out}-audit \
116         --with%{!?with_inotify:out}-inotify \
117         --without-syscrontab \
118 %if "%{cc_version}" >= "3.4"
119         --enable-pie \
120 %endif
121         --enable-relro \
122         --enable-anacron
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
129         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
130         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
131
132 %{__make} install \
133         pamdir=/etc/pam.d \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
137 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
138 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
139 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
140 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
141 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
142 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
143 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
144
145 touch $RPM_BUILD_ROOT/var/log/cron
146
147 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
148 # cron.allow    This file describes the names of the users which are
149 #               allowed to use the local cron daemon
150 root
151 EOF
152
153 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
154 # cron.deny     This file describes the names of the users which are
155 #               NOT allowed to use the local cron daemon
156 EOF
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %pre
162 %groupadd -g 117 -r -f crontab
163
164 %post
165 if [ ! -f /var/log/cron ]; then
166         install -m 660 -g crontab /dev/null /var/log/cron
167 fi
168 /sbin/chkconfig --add crond
169 %service crond restart "Cron Daemon"
170 %systemd_post crond.service
171
172 %preun
173 if [ "$1" = "0" ]; then
174         %service crond stop
175         /sbin/chkconfig --del crond
176 fi
177 %systemd_preun crond.service
178
179 %postun
180 if [ "$1" = "0" ]; then
181         %groupremove crontab
182 fi
183 %systemd_reload
184
185 %triggerpostun -- cronie < 1.4.8-13
186 if [ -f /etc/sysconfig/cron ]; then
187         . /etc/sysconfig/cron
188         __CROND_ARGS=
189         [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
190         [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
191         if [ -n "$__CROND_ARGS" ]; then
192                 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
193                 echo >>/etc/sysconfig/cron
194                 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
195                 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
196         fi
197 fi
198 %systemd_trigger crond.service
199
200 %triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
201 # Prevent preun from crond from working
202 chmod a-x /etc/rc.d/init.d/crond
203
204 %triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
205 # Restore what triggerun removed
206 chmod 754 /etc/rc.d/init.d/crond
207 # reinstall crond init.d links, which could be different
208 /sbin/chkconfig --del crond
209 /sbin/chkconfig --add crond
210
211 %post upstart
212 %upstart_post crond
213
214 %postun upstart
215 %upstart_postun crond
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS ChangeLog README
220 %attr(750,root,crontab) %dir %{_sysconfdir}/cron*
221 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
222 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
223 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
224 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
225 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
226 %attr(754,root,root) /etc/rc.d/init.d/crond
227 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
228 %{systemdunitdir}/crond.service
229 %attr(755,root,root) %{_sbindir}/crond
230 %attr(2755,root,crontab) %{_bindir}/crontab
231
232 %{_mandir}/man8/crond.8*
233 %{_mandir}/man8/cron.8*
234 %{_mandir}/man5/crontab.5*
235 %{_mandir}/man1/crontab.1*
236
237 %attr(1730,root,crontab) /var/spool/cron
238 %attr(660,root,crontab) %ghost /var/log/cron
239
240 %files anacron
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_sbindir}/anacron
243 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
244 %{_mandir}/man5/anacrontab.5*
245 %{_mandir}/man8/anacron.8*
246
247 %attr(1730,root,crontab) /var/spool/anacron
248
249 %if "%{pld_release}" == "th"
250 %files upstart
251 %defattr(644,root,root,755)
252 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
253 %endif
This page took 0.088136 seconds and 3 git commands to generate.