]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
2c959cd215848be746b6072eb0d82d9d28c182c6
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ÿ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # with SELinux support
11 %bcond_with             audit           # with audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Summary(pl.UTF-8):      Demon cron do uruchamiania programów o zadanym czasie
19 Name:           cronie
20 Version:        1.5.1
21 Release:        1
22 License:        MIT and BSD and GPL v2
23 Group:          Daemons
24 Source0:        https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
25 # Source0-md5:  910e6effcc032998b0a49fbd46322e18
26 Source1:        %{name}.init
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        crond.service
31 Patch0:         inotify-nosys.patch
32 Patch1:         sendmail-path.patch
33 URL:            https://fedorahosted.org/cronie/
34 %{?with_audit:BuildRequires:    audit-libs-devel}
35 BuildRequires:  autoconf >= 2.60
36 BuildRequires:  automake
37 BuildRequires:  glibc-devel >= 6:2.21
38 %{?with_selinux:BuildRequires:  libselinux-devel}
39 BuildRequires:  pam-devel
40 BuildRequires:  rpm >= 4.4.9-56
41 BuildRequires:  rpmbuild(macros) >= 1.647
42 Requires(post): fileutils
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires:       /bin/run-parts
48 Requires:       psmisc >= 20.1
49 Requires:       rc-scripts >= 0.4.3.0
50 %if "%{pld_release}" != "ac"
51 Requires(post,preun,postun):    systemd-units >= 38
52 Requires:       systemd-units >= 38}
53 %endif
54 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
55 Provides:       crondaemon
56 Provides:       crontabs = 1.7
57 Provides:       group(crontab)
58 %if "%{pld_release}" == "th"
59 Provides:       vixie-cron = 4.3-1
60 %endif
61 Obsoletes:      crondaemon
62 Obsoletes:      cronie-systemd
63 Obsoletes:      crontabs
64 %if "%{pld_release}" == "th"
65 Obsoletes:      vixie-cron < 4.3-1
66 %endif
67 Conflicts:      sysklogd < 1.5.1-2
68 Conflicts:      syslog-ng < 3.6.4-3
69 Conflicts:      rsyslog < 5.10.1-4
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Cronie contains the standard UNIX daemon crond that runs specified
74 programs at scheduled times and related tools. It is based on the
75 original cron and has security and configuration enhancements like the
76 ability to use PAM and SELinux.
77
78 %description -l pl.UTF-8
79 Cronie zawiera standardowego demona uniksowego crond, uruchamiającego
80 podane programy o zadanym czasie, oraz powiązane narzędzia. Jest
81 oparty na oryginalnym cronie i zawiera rozszerzenia bezpieczeństwa i
82 konfiguracji, takie jak możliwość wykorzystania mechanizmów PAM i
83 SELinux.
84
85 %package anacron
86 Summary:        Utility for running regular jobs
87 Summary(pl.UTF-8):      Narzędzie do uruchamiania regularnych zadań
88 Group:          Base
89 Provides:       anacron = 2.4
90 Obsoletes:      anacron <= 2.3
91
92 %description anacron
93 Anacron becames part of cronie. Anacron is used only for running
94 regular jobs. The default settings execute regular jobs by anacron,
95 however this could be overloaded in settings.
96
97 %description anacron -l pl.UTF-8
98 Anacron stał się częścią cronie. Służy tylko do uruchamiania
99 regularnych zadań. Domyślne ustawienia wykonują zadania przy użyciu
100 anacrona, ale może to być zmienione w ustawieniach.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106
107 %build
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         SYSCRONTAB=/etc/crontab \
114         SYS_CROND_DIR=/etc/cron.d \
115         --sysconfdir=/etc/cron \
116         --with-editor=/bin/vi \
117         --with-audit%{!?with_audit:=no} \
118         --with-inotify%{!?with_inotify:=no} \
119         --with-pam \
120         --with-selinux%{!?with_selinux:=no} \
121         --disable-syscrontab \
122         --enable-anacron \
123 %if "%{cc_version}" >= "3.4"
124         --enable-pie \
125 %endif
126         --enable-relro
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
133         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
134         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
135
136 %{__make} install \
137         pamdir=/etc/pam.d \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 cp -p %{SOURCE5} crond.pam
141
142 %if %{without audit}
143 # remove recording user's login uid to the process attribute
144 %{__sed} -i -e '/pam_loginuid.so/d' crond.pam
145 %endif
146
147 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
148 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
149 cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
150 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
151 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
152 cp -a crond.pam  $RPM_BUILD_ROOT/etc/pam.d/crond
153 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
154
155 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
156 # cron.allow    This file describes the names of the users which are
157 #               allowed to use the local cron daemon
158 root
159 EOF
160
161 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
162 # cron.deny     This file describes the names of the users which are
163 #               NOT allowed to use the local cron daemon
164 EOF
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %pre
170 %groupadd -g 117 -r -f crontab
171
172 %post
173 /sbin/chkconfig --add crond
174 %service crond restart "Cron Daemon"
175 %systemd_post crond.service
176
177 %preun
178 if [ "$1" = "0" ]; then
179         %service crond stop
180         /sbin/chkconfig --del crond
181 fi
182 %systemd_preun crond.service
183
184 %postun
185 if [ "$1" = "0" ]; then
186         %groupremove crontab
187 fi
188 %systemd_reload
189
190 %triggerpostun -- cronie < 1.4.8-13
191 if [ -f /etc/sysconfig/cron ]; then
192         . /etc/sysconfig/cron
193         __CROND_ARGS=
194         [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
195         [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
196         if [ -n "$__CROND_ARGS" ]; then
197                 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
198                 echo >>/etc/sysconfig/cron
199                 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
200                 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
201         fi
202 fi
203 %systemd_trigger crond.service
204
205 %triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
206 # Prevent preun from crond from working
207 chmod a-x /etc/rc.d/init.d/crond
208
209 %triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
210 # Restore what triggerun removed
211 chmod 754 /etc/rc.d/init.d/crond
212 # reinstall crond init.d links, which could be different
213 /sbin/chkconfig --del crond
214 /sbin/chkconfig --add crond
215
216 %files
217 %defattr(644,root,root,755)
218 %doc AUTHORS ChangeLog README
219 %attr(750,root,crontab) %dir /etc/cron
220 %attr(750,root,crontab) %dir /etc/cron.daily
221 %attr(750,root,crontab) %dir /etc/cron.hourly
222 %attr(750,root,crontab) %dir /etc/cron.monthly
223 %attr(750,root,crontab) %dir /etc/cron.weekly
224 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
225 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
226 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
227 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
228 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
229 %attr(754,root,root) /etc/rc.d/init.d/crond
230 %{systemdunitdir}/crond.service
231 %attr(755,root,root) %{_sbindir}/crond
232 %attr(2755,root,crontab) %{_bindir}/crontab
233
234 %{_mandir}/man8/crond.8*
235 %{_mandir}/man8/cron.8*
236 %{_mandir}/man5/crontab.5*
237 %{_mandir}/man1/crontab.1*
238
239 %attr(1730,root,crontab) /var/spool/cron
240
241 %files anacron
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_sbindir}/anacron
244 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
245 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
246 %{_mandir}/man5/anacrontab.5*
247 %{_mandir}/man8/anacron.8*
248
249 %attr(1730,root,crontab) /var/spool/anacron
This page took 0.077388 seconds and 2 git commands to generate.