]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- rel 14
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
fdd909fe 20Release: 14
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
9c2aa177 33Patch1: %{name}-nosyscrontab.patch
cb620710 34Patch2: sendmail-path.patch
9088c091 35URL: https://fedorahosted.org/cronie/
828712ad
ER
36%{?with_audit:BuildRequires: audit-libs-devel}
37BuildRequires: autoconf
38BuildRequires: automake
9088c091
AM
39%{?with_selinux:BuildRequires: libselinux-devel}
40BuildRequires: pam-devel
0d2f2c46 41BuildRequires: rpm >= 4.4.9-56
526108d0 42BuildRequires: rpmbuild(macros) >= 1.626
9088c091
AM
43Requires(post): fileutils
44Requires(post,preun): /sbin/chkconfig
9088c091
AM
45Requires(postun): /usr/sbin/groupdel
46Requires(pre): /usr/bin/getgid
47Requires(pre): /usr/sbin/groupadd
48Requires: /bin/run-parts
9088c091 49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
38b3aba9 51Requires: systemd-units >= 37-0.10
f440f0d0 52%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
53Provides: crondaemon
54Provides: crontabs = 1.7
55Provides: group(crontab)
0d2f2c46 56%if "%{pld_release}" == "th"
bf8f51cd 57Provides: vixie-cron = 4.3-1
daf76cdc 58%endif
9088c091 59Obsoletes: crondaemon
f497321d 60Obsoletes: cronie-systemd
9088c091 61Obsoletes: crontabs
0d2f2c46 62%if "%{pld_release}" == "th"
bf8f51cd 63Obsoletes: vixie-cron < 4.3-1
daf76cdc 64%endif
9088c091
AM
65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67%description
84a870a4
AM
68Cronie contains the standard UNIX daemon crond that runs specified
69programs at scheduled times and related tools. It is based on the
70original cron and has security and configuration enhancements like the
71ability to use pam and SELinux.
9088c091
AM
72
73%package anacron
84a870a4
AM
74Summary: Utility for running regular jobs
75Group: Base
76Provides: anacron = 2.4
77Obsoletes: anacron <= 2.3
9088c091
AM
78
79%description anacron
84a870a4
AM
80Anacron becames part of cronie. Anacron is used only for running
81regular jobs. The default settings execute regular jobs by anacron,
82however this could be overloaded in settings.
9088c091 83
bb090c53
JK
84%package upstart
85Summary: Upstart job description for Cronie
86Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
87Group: Daemons
88Requires: %{name} = %{version}-%{release}
89Requires: upstart >= 0.6
90
91%description upstart
92Upstart job description for Cronie.
93
94%description upstart -l pl.UTF-8
95Opis zadania Upstart dla Cronie.
96
9088c091
AM
97%prep
98%setup -q
f440f0d0 99%patch0 -p1
9c2aa177 100%patch1 -p1
cb620710 101%patch2 -p1
9088c091
AM
102
103%build
828712ad
ER
104%{__aclocal}
105%{__autoconf}
106%{__autoheader}
107%{__automake}
9088c091 108%configure \
d39ca4fd 109 SYSCRONTAB=/etc/crontab \
695ed2ed 110 SYS_CROND_DIR=/etc/cron.d \
72768a3d 111 --sysconfdir=/etc/cron \
9088c091 112 --with-pam \
45b0067d 113 --with%{!?with_selinux:out}-selinux \
828712ad 114 --with%{!?with_audit:out}-audit \
946518b7 115 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
116 --enable-pie \
117 --enable-relro \
9088c091
AM
118 --enable-anacron
119
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
acc567ec 124install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
bb090c53 125 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
126 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
127
128%{__make} install \
0d2f2c46 129 pamdir=/etc/pam.d \
9088c091
AM
130 DESTDIR=$RPM_BUILD_ROOT
131
fd39f74d
ER
132install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
133cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
134cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
135cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
136cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
137cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 138cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
fdd909fe 139cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
140
141touch $RPM_BUILD_ROOT/var/log/cron
142
143cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
144# cron.allow This file describes the names of the users which are
145# allowed to use the local cron daemon
146root
147EOF
148
149cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
150# cron.deny This file describes the names of the users which are
151# NOT allowed to use the local cron daemon
152EOF
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%pre
158%groupadd -g 117 -r -f crontab
159
160%post
fd39f74d 161if [ ! -f /var/log/cron ]; then
7ff8f944 162 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 163fi
9088c091 164/sbin/chkconfig --add crond
9088c091 165%service crond restart "Cron Daemon"
fdd909fe 166%systemd_post crond.service
9088c091
AM
167
168%preun
169if [ "$1" = "0" ]; then
170 %service crond stop
171 /sbin/chkconfig --del crond
172fi
fdd909fe 173%systemd_preun crond.service
9088c091
AM
174
175%postun
176if [ "$1" = "0" ]; then
177 %groupremove crontab
178fi
38b3aba9
JR
179%systemd_reload
180
ac14407c 181%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
182if [ -f /etc/sysconfig/cron ]; then
183 . /etc/sysconfig/cron
184 __CROND_ARGS=
185 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
186 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c
JR
187 if [ -n "$__CROND_ARGS" ]; then
188 cp -f /etc/sysconfig/cron{,.rpmsave}
189 echo >>/etc/sysconfig/cron
190 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
191 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
192 fi
0a59c82c 193fi
fdd909fe 194%systemd_trigger crond.service
9088c091 195
8609ee66 196%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
197# Prevent preun from crond from working
198chmod a-x /etc/rc.d/init.d/crond
199
8609ee66 200%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
201# Restore what triggerun removed
202chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
203# reinstall crond init.d links, which could be different
204/sbin/chkconfig --del crond
77af6cfd
AM
205/sbin/chkconfig --add crond
206
bb090c53
JK
207%post upstart
208%upstart_post crond
209
210%postun upstart
211%upstart_postun crond
212
9088c091
AM
213%files
214%defattr(644,root,root,755)
215%doc AUTHORS ChangeLog README
216%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
217%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
218%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
219%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
220%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
221%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
222%attr(754,root,root) /etc/rc.d/init.d/crond
223%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
38b3aba9 224%{systemdunitdir}/crond.service
9088c091
AM
225%attr(755,root,root) %{_sbindir}/crond
226%attr(2755,root,crontab) %{_bindir}/crontab
227
228%{_mandir}/man8/crond.8*
229%{_mandir}/man8/cron.8*
230%{_mandir}/man5/crontab.5*
231%{_mandir}/man1/crontab.1*
232
233%attr(1730,root,crontab) /var/spool/cron
234%attr(660,root,crontab) %ghost /var/log/cron
235
236%files anacron
237%defattr(644,root,root,755)
238%attr(755,root,root) %{_sbindir}/anacron
84a870a4 239%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
240%{_mandir}/man5/anacrontab.5*
241%{_mandir}/man8/anacron.8*
d07a95b8
AM
242
243%attr(1730,root,crontab) /var/spool/anacron
bb090c53 244
c69c0f5a 245%if "%{pld_release}" != "ti"
bb090c53
JK
246%files upstart
247%defattr(644,root,root,755)
248%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 249%endif
This page took 0.088012 seconds and 4 git commands to generate.