]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
/etc/cron.d is now in the filesystem package
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46 9%if "%{pld_release}" == "ac"
2bd551be
ER
10%bcond_with selinux # with SELinux support
11%bcond_with audit # with audit support
0d2f2c46
ER
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
701f4590
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
ab5bdbf0 19Version: 1.4.12
bbfcd712 20Release: 3
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
ab5bdbf0 24# Source0-md5: 199db91e514a4d75e3222d69874b132f
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
6f54bc3d 33Patch1: sendmail-path.patch
9088c091 34URL: https://fedorahosted.org/cronie/
828712ad
ER
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
cd632288 41BuildRequires: rpmbuild(macros) >= 1.647
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
9088c091 48Requires: psmisc >= 20.1
bb090c53 49Requires: rc-scripts >= 0.4.3.0
6f54bc3d 50%if "%{pld_release}" != "ac"
1580d998
JR
51Requires(post,preun,postun): systemd-units >= 38
52Requires: systemd-units >= 38}
cd632288 53%endif
f440f0d0 54%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
55Provides: crondaemon
56Provides: crontabs = 1.7
57Provides: group(crontab)
0d2f2c46 58%if "%{pld_release}" == "th"
bf8f51cd 59Provides: vixie-cron = 4.3-1
daf76cdc 60%endif
9088c091 61Obsoletes: crondaemon
f497321d 62Obsoletes: cronie-systemd
9088c091 63Obsoletes: crontabs
0d2f2c46 64%if "%{pld_release}" == "th"
bf8f51cd 65Obsoletes: vixie-cron < 4.3-1
daf76cdc 66%endif
9088c091
AM
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
84a870a4
AM
70Cronie contains the standard UNIX daemon crond that runs specified
71programs at scheduled times and related tools. It is based on the
72original cron and has security and configuration enhancements like the
73ability to use pam and SELinux.
9088c091
AM
74
75%package anacron
84a870a4
AM
76Summary: Utility for running regular jobs
77Group: Base
78Provides: anacron = 2.4
79Obsoletes: anacron <= 2.3
9088c091
AM
80
81%description anacron
84a870a4
AM
82Anacron becames part of cronie. Anacron is used only for running
83regular jobs. The default settings execute regular jobs by anacron,
84however this could be overloaded in settings.
9088c091 85
bb090c53
JK
86%package upstart
87Summary: Upstart job description for Cronie
88Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
89Group: Daemons
90Requires: %{name} = %{version}-%{release}
91Requires: upstart >= 0.6
92
93%description upstart
94Upstart job description for Cronie.
95
96%description upstart -l pl.UTF-8
97Opis zadania Upstart dla Cronie.
98
9088c091
AM
99%prep
100%setup -q
f440f0d0 101%patch0 -p1
9c2aa177 102%patch1 -p1
9088c091
AM
103
104%build
828712ad
ER
105%{__aclocal}
106%{__autoconf}
107%{__autoheader}
108%{__automake}
9088c091 109%configure \
d39ca4fd 110 SYSCRONTAB=/etc/crontab \
695ed2ed 111 SYS_CROND_DIR=/etc/cron.d \
72768a3d 112 --sysconfdir=/etc/cron \
cf04dab5 113 --with-editor=/bin/vi \
9088c091 114 --with-pam \
45b0067d 115 --with%{!?with_selinux:out}-selinux \
828712ad 116 --with%{!?with_audit:out}-audit \
946518b7 117 --with%{!?with_inotify:out}-inotify \
5769fa92 118 --disable-syscrontab \
a66962af 119%if "%{cc_version}" >= "3.4"
5ab1b510 120 --enable-pie \
a66962af 121%endif
5ab1b510 122 --enable-relro \
9088c091
AM
123 --enable-anacron
124
125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
acc567ec 129install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
bb090c53 130 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
131 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
132
133%{__make} install \
0d2f2c46 134 pamdir=/etc/pam.d \
9088c091
AM
135 DESTDIR=$RPM_BUILD_ROOT
136
5b4e8f01
AZ
137cp -p %{SOURCE5} crond.pam
138
139%if %{without audit}
140# remove recording user's login uid to the process attribute
141%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
142%endif
143
fd39f74d
ER
144install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
145cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
e2d97fc3 146cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
fd39f74d
ER
147cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
148cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
149cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
5b4e8f01 150cp -a crond.pam $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 151cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
fdd909fe 152cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
153
154touch $RPM_BUILD_ROOT/var/log/cron
155
156cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
157# cron.allow This file describes the names of the users which are
158# allowed to use the local cron daemon
159root
160EOF
161
162cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
163# cron.deny This file describes the names of the users which are
164# NOT allowed to use the local cron daemon
165EOF
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%pre
171%groupadd -g 117 -r -f crontab
172
173%post
fd39f74d 174if [ ! -f /var/log/cron ]; then
7ff8f944 175 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 176fi
9088c091 177/sbin/chkconfig --add crond
9088c091 178%service crond restart "Cron Daemon"
fdd909fe 179%systemd_post crond.service
9088c091
AM
180
181%preun
182if [ "$1" = "0" ]; then
183 %service crond stop
184 /sbin/chkconfig --del crond
185fi
fdd909fe 186%systemd_preun crond.service
9088c091
AM
187
188%postun
189if [ "$1" = "0" ]; then
190 %groupremove crontab
191fi
38b3aba9
JR
192%systemd_reload
193
ac14407c 194%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
195if [ -f /etc/sysconfig/cron ]; then
196 . /etc/sysconfig/cron
197 __CROND_ARGS=
198 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
199 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c 200 if [ -n "$__CROND_ARGS" ]; then
8455c8ac 201 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
ac14407c
JR
202 echo >>/etc/sysconfig/cron
203 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
204 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
205 fi
0a59c82c 206fi
fdd909fe 207%systemd_trigger crond.service
9088c091 208
dd40ae0a 209%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
210# Prevent preun from crond from working
211chmod a-x /etc/rc.d/init.d/crond
212
dd40ae0a 213%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
214# Restore what triggerun removed
215chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
216# reinstall crond init.d links, which could be different
217/sbin/chkconfig --del crond
77af6cfd
AM
218/sbin/chkconfig --add crond
219
bb090c53
JK
220%post upstart
221%upstart_post crond
222
223%postun upstart
224%upstart_postun crond
225
9088c091
AM
226%files
227%defattr(644,root,root,755)
228%doc AUTHORS ChangeLog README
bbfcd712
JK
229%attr(750,root,crontab) %dir /etc/cron
230%attr(750,root,crontab) %dir /etc/cron.daily
231%attr(750,root,crontab) %dir /etc/cron.hourly
232%attr(750,root,crontab) %dir /etc/cron.monthly
233%attr(750,root,crontab) %dir /etc/cron.weekly
9088c091
AM
234%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
235%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
236%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
237%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
238%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
239%attr(754,root,root) /etc/rc.d/init.d/crond
240%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
cd632288 241%{systemdunitdir}/crond.service
9088c091
AM
242%attr(755,root,root) %{_sbindir}/crond
243%attr(2755,root,crontab) %{_bindir}/crontab
244
245%{_mandir}/man8/crond.8*
246%{_mandir}/man8/cron.8*
247%{_mandir}/man5/crontab.5*
248%{_mandir}/man1/crontab.1*
249
250%attr(1730,root,crontab) /var/spool/cron
251%attr(660,root,crontab) %ghost /var/log/cron
252
253%files anacron
254%defattr(644,root,root,755)
255%attr(755,root,root) %{_sbindir}/anacron
84a870a4 256%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
e2d97fc3 257%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
9088c091
AM
258%{_mandir}/man5/anacrontab.5*
259%{_mandir}/man8/anacron.8*
d07a95b8
AM
260
261%attr(1730,root,crontab) /var/spool/anacron
bb090c53 262
2bd551be 263%if "%{pld_release}" == "th"
bb090c53
JK
264%files upstart
265%defattr(644,root,root,755)
266%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 267%endif
This page took 0.075297 seconds and 4 git commands to generate.