]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- rel 4; from upstream: In crontab command use a temporary filename that is ignored...
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46 9%if "%{pld_release}" == "ac"
2bd551be
ER
10%bcond_with selinux # with SELinux support
11%bcond_with audit # with audit support
0d2f2c46
ER
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
701f4590
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
ced4ed8f 19Version: 1.5.0
a8f0b8f2 20Release: 4
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
ced4ed8f 24# Source0-md5: 9db75e1884d83a45e002d145c6c54d45
9088c091 25Source1: %{name}.init
9088c091
AM
26Source3: cron.sysconfig
27Source4: %{name}.crontab
28Source5: %{name}.pam
4b896003 29Source6: crond.service
f440f0d0 30Patch0: inotify-nosys.patch
6f54bc3d 31Patch1: sendmail-path.patch
a8f0b8f2 32Patch2: cronie-temp.patch
9088c091 33URL: https://fedorahosted.org/cronie/
828712ad
ER
34%{?with_audit:BuildRequires: audit-libs-devel}
35BuildRequires: autoconf
36BuildRequires: automake
24c321ed 37BuildRequires: glibc-devel >= 6:2.21
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
cd632288 41BuildRequires: rpmbuild(macros) >= 1.647
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
9088c091 48Requires: psmisc >= 20.1
bb090c53 49Requires: rc-scripts >= 0.4.3.0
6f54bc3d 50%if "%{pld_release}" != "ac"
1580d998
JR
51Requires(post,preun,postun): systemd-units >= 38
52Requires: systemd-units >= 38}
cd632288 53%endif
f440f0d0 54%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
55Provides: crondaemon
56Provides: crontabs = 1.7
57Provides: group(crontab)
0d2f2c46 58%if "%{pld_release}" == "th"
bf8f51cd 59Provides: vixie-cron = 4.3-1
daf76cdc 60%endif
9088c091 61Obsoletes: crondaemon
f497321d 62Obsoletes: cronie-systemd
9088c091 63Obsoletes: crontabs
0d2f2c46 64%if "%{pld_release}" == "th"
bf8f51cd 65Obsoletes: vixie-cron < 4.3-1
daf76cdc 66%endif
64a8505a
BS
67Conflicts: sysklogd < 1.5.1-2
68Conflicts: syslog-ng < 3.6.4-3
69Conflicts: rsyslog < 5.10.1-4
9088c091
AM
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%description
84a870a4
AM
73Cronie contains the standard UNIX daemon crond that runs specified
74programs at scheduled times and related tools. It is based on the
75original cron and has security and configuration enhancements like the
76ability to use pam and SELinux.
9088c091
AM
77
78%package anacron
84a870a4
AM
79Summary: Utility for running regular jobs
80Group: Base
81Provides: anacron = 2.4
82Obsoletes: anacron <= 2.3
9088c091
AM
83
84%description anacron
84a870a4
AM
85Anacron becames part of cronie. Anacron is used only for running
86regular jobs. The default settings execute regular jobs by anacron,
87however this could be overloaded in settings.
9088c091
AM
88
89%prep
90%setup -q
f440f0d0 91%patch0 -p1
9c2aa177 92%patch1 -p1
a8f0b8f2 93%patch2 -p1
9088c091
AM
94
95%build
828712ad
ER
96%{__aclocal}
97%{__autoconf}
98%{__autoheader}
99%{__automake}
9088c091 100%configure \
d39ca4fd 101 SYSCRONTAB=/etc/crontab \
695ed2ed 102 SYS_CROND_DIR=/etc/cron.d \
72768a3d 103 --sysconfdir=/etc/cron \
cf04dab5 104 --with-editor=/bin/vi \
9088c091 105 --with-pam \
45b0067d 106 --with%{!?with_selinux:out}-selinux \
828712ad 107 --with%{!?with_audit:out}-audit \
946518b7 108 --with%{!?with_inotify:out}-inotify \
5769fa92 109 --disable-syscrontab \
a66962af 110%if "%{cc_version}" >= "3.4"
5ab1b510 111 --enable-pie \
a66962af 112%endif
5ab1b510 113 --enable-relro \
9088c091
AM
114 --enable-anacron
115
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
acc567ec 120install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
4b896003 121 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
9088c091
AM
122 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
123
124%{__make} install \
0d2f2c46 125 pamdir=/etc/pam.d \
9088c091
AM
126 DESTDIR=$RPM_BUILD_ROOT
127
5b4e8f01
AZ
128cp -p %{SOURCE5} crond.pam
129
130%if %{without audit}
131# remove recording user's login uid to the process attribute
132%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
133%endif
134
fd39f74d
ER
135install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
136cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
e2d97fc3 137cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
fd39f74d
ER
138cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
139cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
5b4e8f01 140cp -a crond.pam $RPM_BUILD_ROOT/etc/pam.d/crond
4b896003 141cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091 142
9088c091
AM
143cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
144# cron.allow This file describes the names of the users which are
145# allowed to use the local cron daemon
146root
147EOF
148
149cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
150# cron.deny This file describes the names of the users which are
151# NOT allowed to use the local cron daemon
152EOF
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%pre
158%groupadd -g 117 -r -f crontab
159
160%post
161/sbin/chkconfig --add crond
9088c091 162%service crond restart "Cron Daemon"
fdd909fe 163%systemd_post crond.service
9088c091
AM
164
165%preun
166if [ "$1" = "0" ]; then
167 %service crond stop
168 /sbin/chkconfig --del crond
169fi
fdd909fe 170%systemd_preun crond.service
9088c091
AM
171
172%postun
173if [ "$1" = "0" ]; then
174 %groupremove crontab
175fi
38b3aba9
JR
176%systemd_reload
177
ac14407c 178%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
179if [ -f /etc/sysconfig/cron ]; then
180 . /etc/sysconfig/cron
181 __CROND_ARGS=
182 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
183 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c 184 if [ -n "$__CROND_ARGS" ]; then
8455c8ac 185 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
ac14407c
JR
186 echo >>/etc/sysconfig/cron
187 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
188 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
189 fi
0a59c82c 190fi
fdd909fe 191%systemd_trigger crond.service
9088c091 192
dd40ae0a 193%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
194# Prevent preun from crond from working
195chmod a-x /etc/rc.d/init.d/crond
196
dd40ae0a 197%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
198# Restore what triggerun removed
199chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
200# reinstall crond init.d links, which could be different
201/sbin/chkconfig --del crond
77af6cfd
AM
202/sbin/chkconfig --add crond
203
9088c091
AM
204%files
205%defattr(644,root,root,755)
206%doc AUTHORS ChangeLog README
bbfcd712
JK
207%attr(750,root,crontab) %dir /etc/cron
208%attr(750,root,crontab) %dir /etc/cron.daily
209%attr(750,root,crontab) %dir /etc/cron.hourly
210%attr(750,root,crontab) %dir /etc/cron.monthly
211%attr(750,root,crontab) %dir /etc/cron.weekly
9088c091
AM
212%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
213%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
214%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
215%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
216%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
217%attr(754,root,root) /etc/rc.d/init.d/crond
cd632288 218%{systemdunitdir}/crond.service
9088c091
AM
219%attr(755,root,root) %{_sbindir}/crond
220%attr(2755,root,crontab) %{_bindir}/crontab
221
222%{_mandir}/man8/crond.8*
223%{_mandir}/man8/cron.8*
224%{_mandir}/man5/crontab.5*
225%{_mandir}/man1/crontab.1*
226
227%attr(1730,root,crontab) /var/spool/cron
9088c091
AM
228
229%files anacron
230%defattr(644,root,root,755)
231%attr(755,root,root) %{_sbindir}/anacron
84a870a4 232%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
e2d97fc3 233%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
9088c091
AM
234%{_mandir}/man5/anacrontab.5*
235%{_mandir}/man8/anacron.8*
d07a95b8
AM
236
237%attr(1730,root,crontab) /var/spool/anacron
This page took 0.126494 seconds and 4 git commands to generate.