]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- -fPIE in gcc 3.4
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
5c77a7a7 20Release: 16
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
9c2aa177 33Patch1: %{name}-nosyscrontab.patch
cb620710 34Patch2: sendmail-path.patch
5c77a7a7 35Patch3: cronie-1.4.8-inotify-fix.patch
9088c091 36URL: https://fedorahosted.org/cronie/
828712ad
ER
37%{?with_audit:BuildRequires: audit-libs-devel}
38BuildRequires: autoconf
39BuildRequires: automake
9088c091
AM
40%{?with_selinux:BuildRequires: libselinux-devel}
41BuildRequires: pam-devel
0d2f2c46 42BuildRequires: rpm >= 4.4.9-56
526108d0 43BuildRequires: rpmbuild(macros) >= 1.626
9088c091
AM
44Requires(post): fileutils
45Requires(post,preun): /sbin/chkconfig
9088c091
AM
46Requires(postun): /usr/sbin/groupdel
47Requires(pre): /usr/bin/getgid
48Requires(pre): /usr/sbin/groupadd
49Requires: /bin/run-parts
9088c091 50Requires: psmisc >= 20.1
bb090c53 51Requires: rc-scripts >= 0.4.3.0
38b3aba9 52Requires: systemd-units >= 37-0.10
f440f0d0 53%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
54Provides: crondaemon
55Provides: crontabs = 1.7
56Provides: group(crontab)
0d2f2c46 57%if "%{pld_release}" == "th"
bf8f51cd 58Provides: vixie-cron = 4.3-1
daf76cdc 59%endif
9088c091 60Obsoletes: crondaemon
f497321d 61Obsoletes: cronie-systemd
9088c091 62Obsoletes: crontabs
0d2f2c46 63%if "%{pld_release}" == "th"
bf8f51cd 64Obsoletes: vixie-cron < 4.3-1
daf76cdc 65%endif
9088c091
AM
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
84a870a4
AM
69Cronie contains the standard UNIX daemon crond that runs specified
70programs at scheduled times and related tools. It is based on the
71original cron and has security and configuration enhancements like the
72ability to use pam and SELinux.
9088c091
AM
73
74%package anacron
84a870a4
AM
75Summary: Utility for running regular jobs
76Group: Base
77Provides: anacron = 2.4
78Obsoletes: anacron <= 2.3
9088c091
AM
79
80%description anacron
84a870a4
AM
81Anacron becames part of cronie. Anacron is used only for running
82regular jobs. The default settings execute regular jobs by anacron,
83however this could be overloaded in settings.
9088c091 84
bb090c53
JK
85%package upstart
86Summary: Upstart job description for Cronie
87Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
88Group: Daemons
89Requires: %{name} = %{version}-%{release}
90Requires: upstart >= 0.6
91
92%description upstart
93Upstart job description for Cronie.
94
95%description upstart -l pl.UTF-8
96Opis zadania Upstart dla Cronie.
97
9088c091
AM
98%prep
99%setup -q
f440f0d0 100%patch0 -p1
9c2aa177 101%patch1 -p1
cb620710 102%patch2 -p1
5c77a7a7 103%patch3 -p1
9088c091
AM
104
105%build
828712ad
ER
106%{__aclocal}
107%{__autoconf}
108%{__autoheader}
109%{__automake}
9088c091 110%configure \
d39ca4fd 111 SYSCRONTAB=/etc/crontab \
695ed2ed 112 SYS_CROND_DIR=/etc/cron.d \
72768a3d 113 --sysconfdir=/etc/cron \
9088c091 114 --with-pam \
45b0067d 115 --with%{!?with_selinux:out}-selinux \
828712ad 116 --with%{!?with_audit:out}-audit \
946518b7 117 --with%{!?with_inotify:out}-inotify \
a66962af 118%if "%{cc_version}" >= "3.4"
5ab1b510 119 --enable-pie \
a66962af 120%endif
5ab1b510 121 --enable-relro \
9088c091
AM
122 --enable-anacron
123
124%{__make}
125
126%install
127rm -rf $RPM_BUILD_ROOT
acc567ec 128install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
bb090c53 129 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
130 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
131
132%{__make} install \
0d2f2c46 133 pamdir=/etc/pam.d \
9088c091
AM
134 DESTDIR=$RPM_BUILD_ROOT
135
fd39f74d
ER
136install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
137cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
138cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
139cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
140cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
141cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 142cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
fdd909fe 143cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
144
145touch $RPM_BUILD_ROOT/var/log/cron
146
147cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
148# cron.allow This file describes the names of the users which are
149# allowed to use the local cron daemon
150root
151EOF
152
153cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
154# cron.deny This file describes the names of the users which are
155# NOT allowed to use the local cron daemon
156EOF
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%pre
162%groupadd -g 117 -r -f crontab
163
164%post
fd39f74d 165if [ ! -f /var/log/cron ]; then
7ff8f944 166 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 167fi
9088c091 168/sbin/chkconfig --add crond
9088c091 169%service crond restart "Cron Daemon"
fdd909fe 170%systemd_post crond.service
9088c091
AM
171
172%preun
173if [ "$1" = "0" ]; then
174 %service crond stop
175 /sbin/chkconfig --del crond
176fi
fdd909fe 177%systemd_preun crond.service
9088c091
AM
178
179%postun
180if [ "$1" = "0" ]; then
181 %groupremove crontab
182fi
38b3aba9
JR
183%systemd_reload
184
ac14407c 185%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
186if [ -f /etc/sysconfig/cron ]; then
187 . /etc/sysconfig/cron
188 __CROND_ARGS=
189 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
190 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c 191 if [ -n "$__CROND_ARGS" ]; then
8455c8ac 192 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
ac14407c
JR
193 echo >>/etc/sysconfig/cron
194 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
195 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
196 fi
0a59c82c 197fi
fdd909fe 198%systemd_trigger crond.service
9088c091 199
8609ee66 200%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
201# Prevent preun from crond from working
202chmod a-x /etc/rc.d/init.d/crond
203
8609ee66 204%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
205# Restore what triggerun removed
206chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
207# reinstall crond init.d links, which could be different
208/sbin/chkconfig --del crond
77af6cfd
AM
209/sbin/chkconfig --add crond
210
bb090c53
JK
211%post upstart
212%upstart_post crond
213
214%postun upstart
215%upstart_postun crond
216
9088c091
AM
217%files
218%defattr(644,root,root,755)
219%doc AUTHORS ChangeLog README
220%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
221%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
222%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
223%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
224%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
225%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
226%attr(754,root,root) /etc/rc.d/init.d/crond
227%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
38b3aba9 228%{systemdunitdir}/crond.service
9088c091
AM
229%attr(755,root,root) %{_sbindir}/crond
230%attr(2755,root,crontab) %{_bindir}/crontab
231
232%{_mandir}/man8/crond.8*
233%{_mandir}/man8/cron.8*
234%{_mandir}/man5/crontab.5*
235%{_mandir}/man1/crontab.1*
236
237%attr(1730,root,crontab) /var/spool/cron
238%attr(660,root,crontab) %ghost /var/log/cron
239
240%files anacron
241%defattr(644,root,root,755)
242%attr(755,root,root) %{_sbindir}/anacron
84a870a4 243%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
244%{_mandir}/man5/anacrontab.5*
245%{_mandir}/man8/anacron.8*
d07a95b8
AM
246
247%attr(1730,root,crontab) /var/spool/anacron
bb090c53 248
c69c0f5a 249%if "%{pld_release}" != "ti"
bb090c53
JK
250%files upstart
251%defattr(644,root,root,755)
252%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 253%endif
This page took 0.06754 seconds and 4 git commands to generate.